
Arrange Menu
Use Arrange menu commands in Layout to work with objects and fields. You can group, lock, and 
position objects, remove extra space at the end of printed fields, and change the sequence of fields 
you move to with the Tab key.

Group 

Ungroup

Lock 

Unlock 

Bring to Front 

Bring Forward 

Send to Back 

Send Backward    

Align Objects 

Alignment... 

Slide Objects... 

Tab Order... 



Group
Arrange Menu

Consolidates a set of selected objects into one object. After you use the Group command, the objects 
can be moved, resized, and formatted as a single object.

To prevent a group from being moved or changed, you can lock it with the Lock command.

Note: To select multiple objects, hold the Shift key as you select each object.

See Also

Arranging a Layout 

Working with Layouts 



Ungroup
Arrange Menu

Separates objects that have been grouped with the Group command, leaving them selected in their 
original stacking order. After you use the Ungroup command, the objects can be moved, resized, and 
formatted individually.

If a grouped object consists of a collection groups, ungrouping the first object leaves the other groups 
intact.

See Also

Arranging a Layout 

Working with Layouts 



Lock
Arrange Menu

Prevents objects from being moved, cut, cleared, resized, or formatted. You can select, copy, or group
locked objects, but you must use the Unlock command before you can manipulate them in any other 
way. 

When you group a locked object with unlocked objects, the entire group becomes locked. When you 
create a copy of a locked object, the copy is not locked.

Locked objects appear with gray handles instead of black handles.

See Also

Arranging a Layout 

Working with Layouts 



Unlock
Arrange Menu

Unlocks selected objects that have been locked with the Lock command. You must unlock objects 
before you can move or edit them.

Unlocked objects appear with black handles instead of gray handles.

See Also

Arranging a Layout 

Working with Layouts 



Bring to Front
Arrange Menu

Moves selected objects in front of all other objects in the stacking order.

See Also

Arranging a Layout 

Working with Layouts 



Bring Forward
Arrange Menu

Moves selected objects one layer closer to the top of the stacking order.

See Also

Arranging a Layout 

Working with Layouts 



Send to Back
Arrange Menu

Moves selected objects in back of all other objects in the stacking order.

See Also
Arranging a Layout 

Working with Layouts 



Send Backward
Arrange Menu

Moves selected objects one layer closer to the bottom of the stacking order.

See Also

Arranging a Layout 

Working with Layouts 



Align Objects
Arrange Menu

Applies the alignment specifications set in the Alignment dialog box to selected text, objects, and 
fields.

If you align along tops, bottoms, or sides, the objects move into alignment with the object farthest in 
the chosen direction.

See Also

Arranging a Layout 

Working with Layouts 



Alignment...
Arrange Menu

Specifies how objects should be aligned when you use the Align Objects command. You can align the
tops, bottoms, sides, or centers of objects or you can distribute space equally between objects.

 
Alignment Dialog Box

See Also

Arranging a Layout 

Working with Layouts 



Alignment Dialog Box

Option Action

Top to Bottom Click an option for no alignment (None), align objects 
horizontally (Align Top Edges, Align Centers, or Align 
Bottom Edges), or evenly distribute the space between 
objects (Distribute Space)

Left to Right Click an option for no alignment (None), align objects 
vertically (Align Left Edges, Align Centers, or Align Right 
Edges), or evenly distribute the space between objects 
(Distribute Space)

Sample View the results of your alignment selections



Slide Objects...
Arrange Menu

Specifies how to remove blank space from selected fields when you print. 

If some records have blank fields or a short piece of text in a long field, sliding objects removes the 
extra space as necessary.

 
Slide Objects Dialog Box

See Also

Closing Up Space for Printing

Arranging a Layout 

Working with Layouts 



Slide Objects Dialog Box

Option Action

When printing, 
remove blank space 
from within the 
selected objects by:

Sliding left Click to move the object on the right to the left, so 
it is next to the field made smaller

Sliding up based on: Click All Above to raise an object so it is next to all
fields above. Click Directly Above to raise an 
object so it is next to the field directly above

Also reduce the size of 
the enclosing part

Click to reduce the size of the field's part if it 
slides vertically

Do not print the 
selected objects

Click to prevent the selected objects from printing



Tab Order...
Arrange Menu

Changes the sequence of movement with the Tab key. Unless you change the order with this 
command, you tab through fields from left to right and top to bottom.

You see the Tab Order dialog box along with arrows that point to each field on the layout, except 
summary fields. You can change the number on each arrow to change the field position in the tab 
order, or leave the arrow blank to leave the field out of the tab order.

 
Tab Order Dialog Box

See Also

Changing the Tab Order 



Tab Order Dialog Box

Option Action

Edit tab order Click to change the tab order by typing the numbers in 
the arrows

<n> of <n> items set View the number of fields you've included in the new tab 
order

Create new tab order Click to remove the numbers and set the order by 
clicking the arrows in the order you want

Revert To Default Click to return to the default order (left to right and top to 
bottom)



Commands
FileMaker Pro has nine pull-down menus on the menu bar. 

File 

Edit 

Select 

Layout 

Arrange 

Format 

Scripts 

Window 

Help 



Customer Support
Customer Relations

For warranty replacement, upgrades, registration status, change of address, and all nontechnical 
questions, contact Customer Relations.

(408) 727-8227

Hours (Pacific time): 

8:00 AM - 5:00 PM      Monday - Thursday

8:00 AM - 2:00 PM      Friday

Address:

Customer Relations

Claris Corp.; MS    C-11 

5201 Patrick Henry Dr.

Box 58168

Santa Clara, CA    95052-8168

AppleLink: CLARIS.CR

America On-Line: Claris

Technical Support Hotline
As a registered customer, you are entitled to help on our Technical Support Hotline. If you have 
technical questions or encounter a problem operating your software, call our team of Technical 
Support Specialists at:

(408) 727-9004

Hours    (Pacific time):

6:00 AM - 6:00 PM    Monday - Thursday

6:00 AM - 2:00 PM      Friday

AppleLink:    CLARIS.TECH

CompuServe:    

Modem Settings: 8 Data Bits; No Parity; 1 Stop bit

After logging on, type GO APPVEN. At the menu, choose 14, Claris.

America On-Line: Claris



About FileMaker Pro Help
Writer: Jill Holdaway

Design: Jill Holdaway, Ken Broadhurst

Programming: Carlos Garcia, Kathy Yokota

Management: Ken Broadhurst

© 1990, 1992 Claris Corporation. All Rights Reserved.

Claris Corporation

5201 Patrick Henry Drive

Santa Clara, CA 95052-8168    USA

(408) 987-7000

Claris, FileMaker, the FileMaker design, the FileMaker Pro design, and MacPaint are trademarks of 
Claris Corporation. ScriptMaker is a trademark of Claris Corporation.

AppleWorks is a registered trademark of Apple computer, Inc., licensed to Claris Corporation.

All other company and product names are trademarks or registered trademarks of their respective 
owners.

All persons and companies listed in the examples here are purely fictitious and any resemblance to 
existing companies and persons is purely coincidental.

Copyright © 1985-1992 Microsoft Corporation. 

Portions of this program © 1983-1990 Novell, Inc. All Rights Reserved. 



Edit Menu
Use Edit menu commands to create new records, layouts, and find requests, to undo actions, and to 
cut, copy, paste, clear, and select FileMaker Pro data and objects.

The commands in the middle section of the Edit menu (the New, Duplicate, and Delete commands) 
change in each mode. For example, New Record in Browse becomes New Request in Find, and New
Layout in Layout.

Undo 

Cut 

Copy

Paste 

Clear 

Select All 

New Record 

New Request 

New Layout... 

Duplicate Record 

Duplicate Request 

Duplicate Layout    

Duplicate Selection 

Delete Record 

Delete Request 

Delete Found Set 

Delete Layout 

Paste Special 

Replace... 

Relookup 

Spelling 



Undo
Edit Menu

Reverses the last action. Immediately after you choose Undo, the command becomes Redo so that 
you can reverse the undo action. The Undo command appears dimmed if the action can't be undone.



Cut
Edit Menu

Removes selected data and layout objects and places them on the Clipboard, replacing the 
Clipboard's previous contents. You can paste the cut selection in a new location with the Paste 
command in the Edit menu.

See Also

Deleting Data 



Copy
Edit Menu

Copies selected data and layout objects onto the Clipboard, replacing the Clipboard's previous 
contents. You can paste the copied selection in a new location with the Paste command in the Edit 
menu.

You can copy: when you: and use the 
Copy command
or these keys:

field data select it Ctrl+C
Ctrl+Ins

all data in a record
in tab delimited 
format, except 
picture and sound 
data

are in Browse 
and the insertion 
point isn't in any 
field

Ctrl+C
Ctrl+Ins

all data in a found 
set in tab 
delimited format, 
except picture and
sound data

are in Browse 
and the insertion 
point isn't in any 
field 

Ctrl+Shift+C

See Also

Selecting and Copying Data 

Entering Data 

Looking Up Data in Other Files 



Paste
Edit Menu

Places a copy of the Clipboard contents at the insertion point.

In Browse, the item you paste must match the field type. For example, you can paste a picture in a 
picture/sound field, but not in a text field.

In Layout, you can paste:

- text and graphics

- field objects into other layouts in a file

- field objects into another FileMaker Pro file with a matching field name

- field objects into a file in another application

The Windows Clipboard may contain pictures in both a bitmap and metafile format. To paste the 
picture in metafile format, choose Paste. To paste the picture in bitmap format, press Shift and choose
Paste. 

See Also

Entering Data 

Looking Up Data in Other Files 



Clear
Edit Menu

Removes selected field data or layout objects without placing them on the Clipboard. Clear does not 
delete entire records, find requests, or layouts.

See Also

Deleting Data 



Select All
Edit Menu

Selects the contents of the current field in Browse or Find, or all objects in Layout.

See Also

Selecting and Copying Data 

Entering Data 



New Record
Edit Menu

Makes a new, blank record when you're in Browse. Each record has the set of fields that are included 
in the current layout and any automatically entered values you've set up with entry options. 

See Also

Adding and Deleting Records 

Duplicate Record 

Entry Options 



New Request
Edit Menu

Displays a new, blank find request when you're in Find. Use a find request to enter search criteria for 
finding matching records.

See Also

Making a Find Request 

Using Find Mode 



New Layout...
Edit Menu

Starts a new layout when you're in Layout. Each layout can have a different arrangement of fields and
layout parts.

You can create your own layout or choose one of the layouts listed in the New Layout dialog box.

      
New Layout Dialog Box

When you select Columnar Report, Extended Columnar, or Envelope from the New Layout dialog 
box, set how fields appear in the layout in the Set Field Order dialog box.

 
Set Field Order Dialog Box

When you select Labels from the New Layout dialog box, set dimensions and positions for Avery and 
custom labels in the Label Setup dialog box.

 
Label Setup Dialog Box

See Also

Working with Layouts 

Using Layout Mode 



New Layout Dialog Box

Option Action

Name Type a name for the layout

Click: to define a layout that:

Standard Displays fields in the order listed in the Define Fields 
dialog box

Columnar report Displays fields in columns and wraps long records to a 
new line

Select fields for the columnar report in the Set Field 
Order dialog box

Extended columnar Displays fields in columns when the fields fit across the 
page on one line

Select fields for the extended columnar report in the Set 
Field Order dialog box 

Single page form Stacks all fields in the order listed in the Define Fields 
dialog box, without a header or footer

The page size for a single page form is set in the Print 
Setup dialog box

Labels Displays labels across the page

Select label measurements for Avery and custom labels 
in the Label Setup dialog box and select fields for the 
label in the Set Field Order dialog box

Envelope Displays fields positioned for a business envelope

Select fields for the envelope in the Set Field Order 
dialog box

Blank Displays a blank layout

Customize the layout by using the tools in the status 
area to add the fields, layout text, graphics, and parts 
you want 

Label Setup Dialog Box

Option Action

Use label 
measurements for

Click the button and select an Avery label type from the 
pop-up list

The layout conforms to the size of the selected label

Use custom 
measurements:

Click the button and type custom label measurements in 
the box below

Labels across the page Type the number of custom labels you want to fit across 
the page

Width Type the custom label width (the distance from the left 
edge of one label to the left edge of the label on the 
right)

Current Print Setup View the page measurements as set in the Print Setup 
dialog box

Height Type the custom label height (the distance from the top 
edge of one label to the top edge of the label below)

Set Field Order Dialog Box

Option Action



Field List Select a field to move into the Field Order list

Once in the Field Order list, drag the double arrow next 
to the field names to change the field order in the layout

Clear All Click to remove all fields from the Field Order list

Move Click to move a selected field from the Field List to the 
Field Order list

You can move more than one copy of a field into the 
Field Order list

Field Order View the order of fields for your layout or select fields 
you want to remove from the list with the Clear button

Duplicate Record
Edit Menu

In Browse, makes an exact copy of the current record. You can use Duplicate Record to simplify data 
entry when there are only minor differences between records. If you've set up fields to automatically 
enter data, FileMaker Pro enters the values in those fields for you.

See Also
Adding and Deleting Records 



Duplicate Request
Edit Menu

In Find, makes an exact copy of the current find request. Use Duplicate Request to quickly create a 
new find request based on an existing one.

See Also

Making a Find Request 

Modifying a Find Request 



Duplicate Layout
Edit Menu

In Layout, makes an exact copy of the current layout. Use Duplicate Layout to quickly create a new 
layout based on an existing one.

See Also

Creating, Duplicating, and Deleting Layouts 

Using Layout Mode 



Duplicate Selection
Edit Menu

In Layout, makes a copy of the selected object and offsets the copy down and to the left. You can also
duplicate a selection by holding down the Alt key while dragging an object.

See Also

Arranging a Layout 

Working with Layouts    



Delete Record
Edit Menu

In Browse, deletes the current record and all its data.

See Also

Deleting Data 

Omitting Records 



Delete Request
Edit Menu

In Find, deletes the current find request.

See Also

Making a Find Request 

Modifying a Find Request 

Deleting Data 



Delete Found Set
Edit Menu

In Browse, deletes the current found set.

Note: You can't undo a Delete Found Set command.

See Also

Deleting Data 

Omitting Records 



Delete Layout
Edit Menu

In Layout, deletes the current layout.

See Also

Creating, Duplicating, and Deleting Layouts 

Arranging a Layout 



Paste Special
Edit Menu

Use Paste Special submenu commands to paste specific types of information into fields when 
working in Browse and Find.

The Paste Special submenu contains these commands:

From Index... 

From Last Record 

Current Date 

Current Time 

Current User Name 

Date Symbol 

Time Symbol 

User Name Symbol 

Page Number 

Record Number 

See Also

Entering Data 

Field Types 



From Index...
Edit Menu
Paste Special Submenu

Shows all data in all the records for the selected field. To make sure you enter a value accurately, you
can select it from the index list instead of typing it into a field.

 
View Index Dialog Box 



View Index Dialog Box
Select a word, number, date, or time in the View Index dialog box and click Paste to paste the item into the current field at the 
insertion point.



From Last Record
Edit Menu
Paste Special Submenu

With the insertion point in a record or find request field, pastes data from the corresponding field in 
the last record you tabbed into or edited. 



Current Date
Edit Menu
Paste Special Submenu

In Browse, pastes the current date into the selected field. The date value appears in the system 
format of mm/dd/yy, but if the field has been formatted with the Date Format command, the selected 
format appears when you click outside of the fields.

In Layout, adds a text object that contains the current date in the system format.

Note: Current Date pastes an unchanging date. To paste a date that's always current, paste the Date 
Symbol from the Paste Special submenu.



Current Time
Edit Menu
Paste Special Submenu

In Browse, pastes the current time into the selected field. The time value appears in the system 
format of hh:mm:ss, but if the field has been formatted with the Time Format command, the selected 
format appears when you click outside the fields.

In Layout, adds a text object that contains the current time in the system format.

Note: Current Time pastes an unchanging time. To paste a time that's always current, paste the Time 
Symbol from the Paste Special submenu.



Current User Name
Edit Menu
Paste Special Submenu

In Browse, pastes the current user name in the selected field. 

In Layout, adds a text object containing the current user name.

FileMaker Pro gets the name from General Preferences Options.



Date Symbol
Edit Menu
Paste Special Submenu

Pastes a date symbol (//) into any layout part.

When you paste the date symbol into a layout, the current value for the symbol appears in other 
modes and when you print records. In Layout, you can change the date format (for example, from 
1/4/93 to January 4, 1993 with the Date Format command in the Format menu.

See Also

Date Format 

Working with Layout Parts 



Time Symbol
Edit Menu
Paste Special Submenu

Pastes a time symbol (::) into any layout part.

When you paste the time symbol into a layout, the current time appears in other modes and when you
print records. 

In Layout, you can format the date with the Time Format command in the Format menu.

See Also

Time Format 

Working with Layout Parts 



User Name Symbol
Edit Menu
Paste Special Submenu

Pastes a user name symbol (||) into any layout part.

When you paste the user name symbol into a layout, the current user name appears in other modes 
and when you print records.



Page Number
Edit Menu
Paste Special Submenu

Pastes a page number symbol (##) into any layout part.

When you paste the page number symbol into a layout, the current page number appears in other 
modes and when you print records. 



Record Number
Edit Menu
Paste Special Submenu

Pastes a record number symbol (@@) into any layout part.

When you paste the record symbol into a layout, the current record number appears in other modes 
and when you print records. 



Replace...
Edit Menu

Copies the contents of the current field into the same field for all the records you are browsing or 
inserts serial numbers into all records in the found set.

 
Replace Dialog Box

See Also

Entering Data 

Selecting and Copying Data 



Replace Dialog Box

Option Action

In the <n> records that
you are browsing, 
permanently replace 
the contents of "field 
name"?

Replace with "currently 
selected data?"

Click to replace data in the same field in all records with the 
current data selection

Replace with serial 
numbers?

Click to replace data in the same field in all records with 
serial numbers

Type the starting value in Initial Value and an increment 
value in Increment By

Update serial numbers 
in Entry Options?

If you have set up serial numbers in the Entry Options dialog
box and then change serial number values with the Replace 
with Serial Numbers option, click this option to update the 
values 

Replace Click to replace the field data with your selected replacement

Relookup
Edit Menu

Updates lookup fields after you change values in the lookup file.

See Also

Looking Up Data in Other Files 

Entry Options Dialog Box



Spelling
Edit Menu

Use Spelling submenu commands to check spelling, set spelling options, and work with dictionaries.

The Spelling submenu contains these commands:

Check Selection... 

Check Record... 

Check Layout... 

Check Found Set... 

Spell Word... 

Spelling Options... 

Install Dictionaries... 

User Dictionary... 



Check Selection...
Edit Menu
Spelling Submenu

In Browse, checks the spelling of the current selection.

 
Spelling Dialog Box

See Also

Checking Spelling 

Entering Data 



Check Record...
Edit Menu
Spelling Submenu

In Browse, checks the spelling of text and number data in the current record.

 
Spelling Dialog Box

See Also

Checking Spelling 

Entering Data 



Check Layout...
Edit Menu
Spelling Submenu

In Layout, checks the spelling of layout text (including field name labels).

 
Spelling Dialog Box

See Also

Checking Spelling 

Adding Layout Text 



Check Found Set...
Edit Menu
Spelling Submenu

In Browse, checks the spelling of text and number field data in the found set.

 
Spelling Dialog Box

See Also

Checking Spelling 

Entering Data 



Spell Word...
Edit Menu
Spelling Submenu

If you type a questionable word and you've selected Spell as You Type in the Spelling Options dialog 
box, you can choose this command to correct the word in the Spelling dialog box.

 
Spelling Dialog Box

See Also

Checking Spelling 

Entering Data 



Spelling Dialog Box

Option Action

Word Edit the questionable word if you don't want to use any 
of the suggestions

1, 2, 3, 4, 5, 6, 7 Press Alt and type the number of the suggestion you 
want to use

Replace Click to replace the questionable word with the 
alternative in the Word box

Check Click to check a word you've edited in the Word box

Skip Click to ignore the questionable word

Learn Click to add the questionable word to the user dictionary

Double arrow button Click to open or close a box that shows the questionable 
with the surrounding text

Spelling Options...
Edit Menu
Spelling Submenu

Sets the Spell as You Type and Dialog Placement options.

    
Spelling Options Dialog Box

See Also

Checking Spelling 

Entering Data 



Spelling Options Dialog Box

Option Actions

Spell as you type: Click Beep on Questionable Spellings or Flash Menu 
Bar on Questionable Spellings to be notified of 
questionable spellings as you type, or click Off to check 
your spelling later

Dialog Placement: Click Automatic if you want FileMaker Pro to position the
Spelling dialog box on your screen or User Defined to 
place the dialog box where you last left it

Install Dictionaries...
Edit Menu
Spelling Submenu

Selects the Main or User dictionary you want to use when you check words.

 
Install Dictionaries Dialog Box

See Also

Checking Spelling 



Install Dictionaries Dialog Box

Option Action

Select Dictionary Click Main to install a main dictionary or User to install a 
dictionary of user-defined words

File Name Type or select the name of the dictionary file from the list

List Files of Type Select an .NDX file for a main dictionary or an .SPL file 
for a user dictionary

Directories Select the dictionary file directory from the list

Drives Select the dictionary file drive from the pop-up list

None Click to ignore the user dictionary when you check 
spelling 

The None option doesn't appear if you've clicked the 
Main option

New Click to install a different user dictionary

The New option doesn't appear if you've clicked the 
Main option

Currently Installed 
Dictionary

Click Main to view the name of the currently installed 
main dictionary or User to view the name of the currently
installed user dictionary

User Dictionary...
Edit Menu
Spelling Submenu

Adds words to the user dictionary.

 
User Dictionary Dialog Box

See Also

Checking Spelling 



User Dictionary Dialog Box

Option Action

User Dictionary View the name of the currently installed user dictionary

List View the words in your user dictionary or select a word 
to remove

Entry: Type a word you want to add to your user dictionary

Add Click to add the word in the Entry box

Remove Click to remove the word selected in the word list

Text File Click the double arrow button to show Import and Export
buttons 

Click Import to use the Open dialog box to use a text file 
for a user dictionary, or Export to use the Save As dialog
box to save the user dictionary as a text file you can use 
with other applications



Defining Fields and Entering Data
Define your database fields to accept the type of data you want them to store. You can define fields 
for storing text, date, time, picture, sound, or numerical information, and information from other 
FileMaker Pro files.

Creating a New Field 

Field Types 

Using Calculation Fields 

Introduction to Operators 

Introduction to Functions 

Summary Formulas 

Setting Up Fields 

Selecting Entry Options 

Moving to Fields 

Entering Data 

Selecting and Copying Data 

Working with Sound Fields 

Adding a QuickTime Movie 

Playing a QuickTime Movie 

Looking Up Data in Other Files 

Deleting Data 

Adding and Deleting Records 

Checking Spelling 

Working with Dictionaries 



Creating a New Field
Once you decide on the categories of information you want in your database, you can create fields to 
hold different types of data. 

Each field has a name and a field type, which you can change at any time.

To create a new field:

1. Start a new file by choosing New from the File menu or choosing Define Fields from the Select 
menu. You see the Define Fields dialog box.

2. Enter a name for the field in the Name box.

3. Click a field type: Text, Number, Date, Time, Picture/Sound, Calculation, or Summary.

4. Click Create.

If you select Calculation or Summary, a dialog box appears so you can define a calculation or 
summary formula. The result of a calculation field formula appears in the field when you enter 
data; the result of a summary field appears when you move to another record and click out of all 
fields.

For other field types, you can click the Options button to customize the field definition.

5. Click Done.

To change a field definition:

1. Choose Define Fields from the Select menu.

2. Select the field name in the list.

3. Click a different field type or type a new field name in the Name box.

4. Click Change. If you've changed the field type, FileMaker Pro displays a message that either 
explains how the new field type will change the data or warns that the contents of the field will be 
lost. 

5. Click the Options button if you want to make more changes for this field. Make changes in the 
Options for Field dialog box and click OK.

6. Click Done to proceed with the changes or Cancel to prevent the changes.

See Also

Field Types 

Using Calculation Fields 

Summary Formulas 



Field Types
The field type determines the type and amount of data you can enter in a field and the kinds of 
operations FileMaker Pro can perform on that data.

FileMaker Pro keeps an index of values in text, number, date, time, and calculation fields. When you 
sort records or make find requests, FileMaker Pro uses these values for the operation. To help you 
accurately enter data, you can paste the indexed values into fields with the From Index command in 
the Paste Special submenu (Edit menu). 

The following table lists the field types, the number of characters you can enter for each type, and 
how characters are indexed.

Field Type Limitation How Indexed

Text Up to 64,000 
characters

Each word separately

Punctuation and special 
characters aren't indexed

Number Up to 255 characters Numbers only

If a number contains a mix of 
numbers and text, FileMaker 
Pro indexes the numbers only 
for find requests and sorts

Date Eight characters in a 
format such as 
MM/DD/YY

Define the date format 
with the International 
option in the Windows 
Control Panel or in the 
Date Format dialog 
box

Each date separately

Time Up to eight characters 
in the format 
HH:MM:SS

Each time separately

Picture/Sound A picture you import 
with the Import Picture 
command or paste 
from the Clipboard

A QuickTime for 
Windows movie you 
import with the Import 
QuickTime command 
or paste from the 
Clipboard

A sound you record or 
paste from the 
Clipboard

Not indexed

Calculation Depends on result

Create a formula for a 
calculation field in the 
Options for Field dialog
box using functions, 
constants, or 
information from other 
fields in the same 
record 

The results of the calculation 
expressed as text or a number, 
date, or time

Summary Depends on result

Create a summary 

Not indexed



formula in the Options 
for Summary Fields 
dialog box 

See Also

Display Values Dialog Box 

Creating a New Field 

Using Calculation Fields 

Summary Formulas 

Working with Sound Fields 

Importing Pictures 



Using Calculation Fields
The data in a calculation field is the result of the formula you define for that field. The formula for a 
calculation field can use functions, constants, or information from other fields in the same record. 

For example, you can create a formula for a calculation field called Total Price that multiplies Quantity 
by Unit Price and enters the result in the field.

To create a formula:

1. Choose Define Fields from the Select menu. You see the Define Fields dialog box.

2. Type a name for the field in the Name box.

3. Click Calculation.

4. Click Create.

5. In the Options for Field dialog box, create the formula by double-clicking a field name, operator, 
function, symbol, or number to copy it into the calculation formula box. You can also type the 
formula in entry box.

6. Choose the type of result you want from the Calculation Result Is pop-up list.

7. Click OK.

See Also

Creating a New Field 

Introduction to Operators 

Introduction to Functions 



Introduction to Operators
Operators are the symbols you use in calculations to indicate how you want FileMaker Pro to 
compute a formula. There are four types of operators:

Arithmetic Operators    

Comparison Operators 

Logical Operators 

Text Operators 

When you use the Define Fields command to define a calculation field, you select operators for the 
calculation in the Options for Field dialog box. To add an operator to the formula, click an operator in 
the symbols keypad or double-click an operator in the Operators list.

See Also

Creating a New Field 

Using Calculation Fields



Arithmetic Operators
An arithmetic operator determines what arithmetic operation is performed with the values on either 
side of the operator. Values used for arithmetic operations can be field names, numbers, or 
expressions.

Operator Action Location Example

+ (Plus) Adds the two 
values

Symbols 
keypad

Subtotal + Sales Tax

- (Minus) Subtracts the 
second value from 
the first

Symbols 
keypad

Invoice Total - Discount

* (Multiplied By) Multiplies the first 
value by the 
second

Symbols 
keypad

Subtotal * Sales Tax

/ (Divided By) Divides the first 
value by the 
second

Symbols 
keypad

Miles Driven / Gallons 

^ (Power Of) Raises the first 
value to the power 
of the second value
or takes a root of 
the value

Operators list Radius ^ 2

Volume ^ (1/3)

( ) Precedence FileMaker Pro 
performs 
operations left to 
right, performing 
multiplication and 
division before 
addition and 
subtraction.

You can change the
order by using 
parentheses: 
FileMaker Pro 
evaluates 
expressions 
between 
parentheses first

Operators list (2 + 3) * 2



Comparison Operators
A comparison operator determines what kind of comparison to perform with the two values on either 
side of the operator. Values that are compared are represented by field names, numbers, or 
expressions. The result of a comparison is either 1 or 0. The result is 1 if the expression is true, or 0 if 
it is false. For example, 38 = 39 (false; result is 0) or 38 = 38 (true; result is 1). 

Based on the results of the comparison, FileMaker Pro can perform a calculation, such as calculating 
sales tax or reporting an overdue bill.

Operator Location Example

= (Equals) Symbols keypad Today's Date = Due Date

Result 1 (True): Payment 
on this invoice is due today

Result 0 (False): This 
invoice is not overdue

<> (Does Not Equal) Symbols keypad Pay <>    (Hours Worked * 
Hourly Pay)

Result 1 (True): This 
employee made an error 
on their time card

Result 0 (False): This time 
card was correct

> (Greater Than) Symbols keypad Today's Date > Due Date

Result 1 (True): This 
account is overdue

Result 0 (False): This 
account is not overdue

< (Less Than) Symbols keypad Today's Date < Due Date

Result 1 (True): This 
account is current

Result 0 (False): This 
account is overdue

>= (Greater Than or 
Equal To)

Operators list Number in Stock >=  
Number Ordered

Result 1 (True): There are 
enough items in stock to fill
the orders

Result 0 (False): There are 
not enough items in stock 
to fill the orders

<= (Less Than or 
Equal To)

Operators list Actual Income <=  
Budgeted Income

Result 1 (True): Actual 
income fell below or 
equaled the budgeted 
amount 

Result 0 (False): Actual 
income did not equal the 
budgeted amount



Logical Operators
A logical operator specifies how FileMaker Pro combines operands to determine if an expression is 
true or false. The result of a logical operation is either 1 (true) or 0 (false).

You can select logical operators from the Operators list in the Options for Field dialog box.

Operator Action Example

AND Expressions on both 
sides of the AND 
operator must be true to 
return 1 (true). If either 
expression is false, 
FileMaker Pro returns 0 
(false).

(Balance Due >= 500) AND (Days 
Overdue > 10)

Result 1 (True): The balance is 
greater than or equal to 500, and it is 
also more than 10 days overdue

Result 0 (False): Either the balance 
due is less than 500 or the account is 
fewer than 10 days overdue

OR Expressions on either or 
both sides of OR must be
true for a result of 1 
(true); otherwise, the 
result is 0 (false)

(Balance Due > 1500) OR (Days 
Overdue > 30)

Result 1 (True): Either the balance 
due exceeds 1500 or the balance is 
more than 30 days overdue or both

Result 0 (False): The balance due 
does not exceed 1500 and the days 
overdue are fewer than 30

NOT The expression that 
follows NOT must be 
false to return 1 (true) or 
true to return 0 (false)

Due Date = NOT (Date > Today)

Result 1 (True): The due date is not 
later than today's date

Result 0 (False): The due date is later
than today's date

Text Operators
Text operators are used in calculations that involve text results. For example, you can use text 
operators to combine two or more text items into one, or to represent special characters in the 
formula.

You can select text operators from the symbols keypad in the Options for Field dialog box.

Operator Action Example

& (Concatenate) Concatenates, or 
strings together, the 
contents of the 
specified fields, 
without separating the
information with 
spaces. You must use
a text constant to 
insert a space or other
text characters

Phone = Area Code & Phone 
Number & Extension 

Result: 800555-12127545

The area code is 800, the 
phone number is 555-1212, 
and the extension is 7545

" " (Text Constant) Treats the value 
within quotation marks
as a constant

City & ", " & State &", " 
Country

Result: Guadalajara, Jalisco, 
Mexico

The concatenation symbol (&)
joins the City, State, and 
Country fields. FileMaker Pro 
treats the comma and space 
character within quotation 



marks (",") as constants and 
places them between the 
fields

¶ (Return Marker) Inserts a return 
marker

Invoice Number & "¶" & 
Vendor

Result: 
96578-08
Townside Landscape

The concatenation symbols 
(&'s) join the two fields. 
FileMaker Pro adds a return 
marker where indicated and 
presents the result in two 
lines



Introduction to Functions
A function is a built-in calculation that performs routine conversion, date, time, financial, logical, 
mathematical, text, and trigonometric operations.

For example, FileMaker Pro has a built-in calculation for the pi function. Instead of typing Radius * 
3.14159, you type Radius * pi.

FileMaker Pro functions contain three basic components: the function name, a set of parentheses, 
and the function's parameters. This example shows a typical FileMaker function:

Function
name Parameters in parentheses

Position (FirstName, "Mc",1)
Commas separate

              each parameter

There are nine types of functions:

Conversion Functions 

Date & Time Functions 

Financial Functions 

Logical Functions 

Mathematical Functions 

Repeating Field Functions 

Summary Field Functions 

Text Functions 

Trigonometric Functions 

See Also

Creating a New Field 

Using Calculation Fields 



Conversion Functions
Use conversion functions to convert values from one field type to another (for example, a number field
to a date field). The value can be:

- a text, date, time, or number field

- the result of an expression or calculation

- a numeric constant (in some cases)

Most conversion functions have names consisting of two or three words. To clarify the word elements,
multiword functions are shown in the function list in capital and lowercase letters (DateToText rather 
than datetotext). FileMaker Pro ignores capitalization in functions. You can type a function name in 
uppercase letters, lowercase, or any combination of both.

Function Purpose Result

DateToText (date) Converts a date to text Text, in the format 
MM/DD/YY

NumToText 
(number)

Converts a number to text Text

TextToDate (text) Converts text to a date

Text must be in the format 
of MM/DD/YY, MM.DD.YY, 
or MM-DD-YY

A date

TextToNum (text) Converts text to a number A number

TextToTime (text) Converts text to a time

Text must be in the format 
HH:MM:SS (seconds are 
optional and you can add 
am or pm to the end of the 
time value)

A time

TimeToText (time) Converts a time to text Text, in the format 
HH:MM:SS

Date & Time Functions
Use date and time functions to perform calculations on date, time, and numeric values. These values 
can be:

- a date, time, or number field

- the result of an expression or calculation

- a numeric constant 

Function Purpose Result

Date (month, day, 
year)

Calculates a date value 
from the numbers supplied

A date

Day (date) Determines the number of 
the day, from 1 through 
31, from a date field or 
from an expression with a 
date result

A number

DayName (date) Converts the date 
supplied to the name of 
the day of the week

Text



DayofYear (date) Calculates the actual day 
of the year, counting from 
January 1 of the year 
supplied

A number in the range 1 
through 366

Hour (time) Calculates the hour in the 
time supplied

A number in the range 0 
through 24

Minute (time) Calculates the minutes in 
the time supplied

A number in the range 0 
through 60

Month (date) Determines the number of 
the month, from 1 through 
12, from a date field or 
from an expression with a 
date result

A number

MonthName (date) Determines the name of 
the month in the date 
supplied

Text

Seconds (time) Calculates the number of 
seconds in the time 
supplied

A number in the range 0 
through 60, with a 0 
result if the time is 
expressed in HH:MM 
format

Time (hours, 
minutes, seconds)

Converts the numbers 
supplied into a valid time

A time (for example, 
12:31:33)

Today Supplies the current date, 
according to the 
computer's internal 
calendar

Does not accept values

Updates the value each 
time you open a file on a 
different day

A date

WeekofYear (date) Calculates the number of 
weeks in the year since 
January 1

A number in the range 1 
through 54

Monday is defined as 
the first day of the week.
The number 54 allows 
for partial weeks at the 
beginning and end of the
year

Year (date) Determines the year 
number from a date field 
or from an expression with
a date result

A four-digit number 
(1993, even if the date is
entered as 3/5/93)

Financial Functions
Use financial functions to operate on number values and return financial information. These values 
can be:

- a number field

- the numeric result of an expression or calculation

- a numeric constant 

Function Purpose Result

FV (payment, 
interest rate, 
number of periods)

Calculates the future value 
of an investment with 
constant payments over a 

A number



specified number of 
periods, yielding a constant 
interest rate

Interest rate must be 
expressed as decimals

NPV (interest rate, 
payments)

Calculates the net present 
value of a series of unequal
payments, made at fixed 
intervals at a fixed interest 
rate

Payments is a repeating 
field

A number

PMT (principal, 
interest rate, 
number of periods)

Calculates the payment 
needed to cover the 
specified principal, at the 
interest rate supplied, over 
the number of periods 
supplied

Payments are assumed to 
be at equal intervals and to 
be made at the end of each
period 

Interest rate must be in 
decimal form

A number

PV (payment, 
interest rate, 
number of periods)

Calculates the present 
value of a series of equal 
payments paid at fixed 
intervals, at a fixed interest 
rate

Interest rate must be in 
decimals

A number

Logical Functions
Use the logical If function to operate on numbers and return numeric or Boolean values. The numeric 
values can be: 

- a number field

- the numeric result of an expression or calculation

- a number constant 

Function Purpose Result

If (test, result 1, 
result two)

Evaluates whether the 
expression in test is true or 
false.

Result 1 can be any 
expression including 
additional If statements

Numeric or Boolean 
values



Mathematical Functions
Use mathematical functions to operate on numbers and return number values. A number value can 
be:

- a number field

- the numeric result of an expression or calculation

- a number constant 

Function Purpose Result

Abs (number) Calculates the absolute 
value of a field or 
expression

A positive number or 0

Exp (number) Raises the value of the 
natural logarithmic base 
(2.7182818...) to the power 
of the number supplied

A number

Int (number) Returns a whole number 
(an integer) without 
rounding; everything to the 
right of the decimal is 
dropped

A whole number

In (number) Computes the base-e 
(natural) logarithm of a 
number

A number

Log (number) Calculates the base 10 
logarithm of the number 
supplied

Number must be positive

A number

Mod (number, 
divisor)

Calculates the remainder 
(modulo) when the number 
is divided by the divisor

A number

Pi Returns the value of the 
constant pi (3.14159)

A number

Random Generates a random 
number between 0 and 1, 
but not including 0 or 1

A number

Round (number, 
precision)

Rounds a number to the 
number of decimal places 
specified by precision

Rounds up at 0.5

If precision is 0 or negative,
all digits to the right of the 
decimal point are dropped 
and the number is rounded 
to the nearest 10s, 100s, 
and so on

A number

Sign (number) Determines whether a 
number is positive, zero, or 
negative

1, 0, or -1

Result is 1 if the field 
value is positive, 0 if 0, 
and -1 if negative

Sqrt (number) Computes the square root 
of the number provided

A number



Repeating Field Functions
Use repeating field functions to calculate values in repeating fields. The value within the parentheses 
must be a repeating field unless otherwise noted. To mix repeating and non-repeating fields in the 
same formula, use the Extend function described later in this topic.

Function Purpose Result

Average (repeating field) Calculates the arithmetic 
mean (average) for all values
in a repeating field

Empty values are excluded 
from the calculation

A number

Count (repeating field) Counts entries as they're 
made

Counts entries of number, 
date, time, or text types

Excludes empty values and 
invalid entries

A number

Extend (non-repeating 
field)

Treats a non-repeating field 
(a field with one value) as a 
repeating field

Applies the single value in a 
non-repeating field to each 
individual value in the 
repeating field. Use Extend 
in formulas that contain 
repeating fields and at least 
one non-repeating field

Last (repeating field) Returns the last value in a 
repeating field

Excludes empty values and 
nonvalid entries

A repeating 
field value

Max (repeating field) Finds the maximum value 
(the highest number or the 
latest date or time) in a 
repeating field

A number, 
date, or time

Min (repeating field) Finds the minimum value 
(the lowest number or the 
earliest date or time) in a 
repeating field

A number, 
date, or time

StDev (field name) Calculates the standard 
deviation of a population 
represented by a series of 
entries in a repeating field

(The standard deviation of a 
population is the average 
amount of deviation from the 
population mean)

A number

Sum (repeating field) Totals all values in a 
repeating field

To total a field for a group of   
records, use a summary field

A number



Summary Field Functions
Use the summary field function to combine data for a group of records.

Function Purpose Results

Summary 
(summary field, 
break field)

Extracts the value of the 
specified summary field for 
the current range of records
when the database is 
sorted by break field

If the database is not sorted
by break field the result is 
blank

A number



Text Functions
Use text functions to operate on text and numeric values and return text or number results. These 
values can be:

- a text field

- the text result of an expression or calculation

- a text constant 

- a numeric constant

Note: In all calculations that refer to the position of characters, FileMaker Pro refers to the first 
character as position 1.

Function Purpose Results

Exact (original text,
comparison text)

Makes a case-sensitive 
comparison of two text 
values

1 if the values match 
exactly

0 if the values do not 
match exactly

Left (text, number 
of characters)

Returns the specified 
number of characters, 
counting from the left

Text

Length (text) Counts the number of 
characters in a text field, 
including all spaces, 
numbers, and special 
characters

Treats numeric values as 
text 

A number

Lower (text) Converts all letters to 
lowercase

Text

Middle (text, 
number of starting 
character, number 
of characters)

Returns the specified 
number of characters from 
the text, beginning at the 
specified starting character

Text

Position (text, 
search text, 
number of starting 
character)

Searches for the first 
occurrence of search text 
starting at the position 
specified by the starting 
character number

A number identifying 
the character position 
where the search text is
found

If the search text is not 
found, the result is zero

Proper (text) Converts the first letter of 
each word to uppercase 
and all following letters to 
lowercase

Text

Replace (text, 
start, size, 
replacement text)

Replaces the characters in 
text, starting at the position 
indicated by start, 
continuing for the number 
of characters specified by 
size, and inserting the text 
in the replacement text

The replacement text can 
be any length

Text for text and 
replacement text, and 
numbers for start and 
size

Right (text, number
of characters)

Returns text that contains 
only the specified number 
of characters, counting from

Text



the right

Trim (text) Removes all leading and 
trailing spaces from the 
specified text

Text

Upper (text) Converts all letters in the 
specified text to uppercase 

Text



Trigonometric Functions
Use trigonometric functions to operate on numeric values expressed in radians and return numeric 
values. The numeric value can be:

- a number field

- the numeric result of an expression or calculation

- a number constant

Function Purpose Results

Atan (number) Computes the arc tangent 
of the number supplied

A number between -90 
and 90

Cos (number) Computes the cosine of the
number supplied 

A value between -1 and 
1

Degrees (number) Converts a number from 
radians to degrees

A number

Radians (number) Converts a number from 
degrees to radians

A number

Sin (number) Computes the sine of an 
angle in radians

A number between -1 
and 1

Tan (number) Computes the tangent of an
angle in radians

A number



Summary Formulas
When you define a summary field, you select a function that operates on your selected field for a 
group of records. 

To select a formula for a summary field:

1. Choose Define Fields from the Select menu.

2. Type a name for the field, click Summary, and then click Create. You see the Options for Summary
Field dialog box.

3. Select a function from the pop-up list on the left and select any option that applies. (See the table 
below.)

4. Select a field from the pop-up list on the right.

5. Click OK.

Summary Formula Option Purpose

Total Running Total Totals the contents of the specified 
field in the found set 

With Running Total selected, shows 
the cumulative total for this and all 
previous records 

Average Weighted By Computes the arithmetic mean of all
numeric data in the specified field in
the found set

With Weighted By selected, the 
average is weighted by the field you
select from the pop-up list

Count Running count Counts the number of records that 
contain a value in the specified field 
in the found set

With Running Count selected, 
shows the cumulative count of this 
and all previous records

Minimum Finds the lowest number or earliest 
date or time in the specified field in 
the found set

Maximum Finds the highest number or latest 
date or time in the specified field in 
the found set

Standard 
Deviation

Computes the standard deviation 
from the mean of the values in the 
specified field in the found set

Fraction of Total Subtotaled 
When Sorted By

Divides the value in the specified 
field by the total of all values of the 
field in the found set

With Subtotaled When Sorted By 
selected, select the field you will 
sort by from the pop-up list

See Also
Field Types 

Setting Up Fields 



Setting Up Fields
You can set up fields to enter data automatically, verify field data, set up repeating fields, select data 
from a predefined list, or lookup data from another file.

To set up all field types except summary and calculation:

1. Choose Define Fields from the Select menu.

2. In the Define Fields dialog box, select a field or define a new one.

3. Click Options.

4. In the Entry Options dialog box, click the entry options you want and click OK.

See Selecting Entry Options for information on these options.

See Also

Creating a New Field 

Tab Order... 



Selecting Entry Options
When you click Options in the Define Fields dialog box, you can set field options for entering data 
automatically and verifying the field contents.

To: Select:

Enter the date or time the 
record was created or 
modified, or the creator or 
modifier name

A date, time, creator, or modifier option from the
pop-up list as available for the type of field 
you're defining

Enter a serial number The Serial Number option and type the starting 
number in the Next Value box and the 
increment of increase in the Increment By box

Serial numbers that consist of both letters and 
numbers are incremented 

If a serial number contains letters and numbers,
FileMaker Pro increments the last numeric 
portion of the serial number

For example, when you increment 123L456 by 
one, the number becomes 123L457

Automatically enter data in
a field

Data and type the data in the box (data must 
match the field type, such as text in a text field)

Verify that a field contains 
a value and is not left 
blank

Not Empty

Verify that the value in the 
field does not duplicate a 
value in the same field in 
another record 

Unique

Verify that the value 
matches another value in 
the same field in any other 
record

An Existing Value

Verify that the value is a 
number, date, or time

Number, Date, or Time from the Of Type pop-up
list

Verify that the value is 
within a specific range of 
numbers, dates, or times

From and enter the range in the From and To 
boxes

To correctly check for a numerical range, the 
field must be a Number, Date, or Time field

Prevent changes to 
predefined values

Prohibit Modification of Auto-entered Values

Define a field that can take
multiple entries

Repeating Field with a Maximum of n Values 
and type the number of repetitions in the box

Enter predefined data from
the field's value list

Use a Pre-Defined Value List and select the 
values from the Display Values dialog box

Copy the field to another 
file

Look Up Values from a File and then select 
values to look up in the Lookup Value dialog 
box and the lookup file you want to use the in 
Open File dialog box 

To ensure that you get the result you want, the 
field types for the fields in each file should be 
the same



Moving to Fields
When you finish entering data in a field, you can move to the next field in the following ways:

- Click in the field where you want to enter data.

- Press Tab to move to the next field in the tab order.

- Press Shift+Tab to move to the previous field in the tab order.

When you use the Tab key, FileMaker Pro moves through the fields from left to right and from top to 
bottom. When you use the Shift+Tab keys, FileMaker Pro moves through fields from right to left and 
bottom to top.

You can change this order with the Tab Order command in the Arrange menu. 

See Also

Tab Order... 

Entering Data 



Entering Data
You can enter data in a field by moving to the field and:

- typing the data in the field

- selecting the data from a value list if the field is formatted to display values with a pop-
up list, pop-up menu, check boxes, or radio buttons

You can also enter data automatically with Auto-Enter a Value That Is option in the Entry Options 
dialog box.

See Also
Moving to Fields 

Setting Up Fields 

Formatting Fields 

Entry Options Dialog Box 



Selecting and Copying Data
You can select data to copy into the same or a different field, copy data from the same field in the 
previously modified record, or copy a record or the found set into another application.

To select data:

- Drag through the text.

- Double-click to select a word.

- Triple-click to select a line.

- Quadruple-click to select an entire text block.

- Extend a selection with text selection keys.

To copy data into another field:

1. Select the field contents you want to copy.

2. Choose Copy from the Edit menu.

3. Tab to the destination field. Place the insertion point where you want to add the Clipboard 
contents, or select the contents of the destination field to replace all of the field's contents with the 
contents of the Clipboard.

4. Choose Paste from the Edit menu.

To copy data from fields formatted as radio buttons, check boxes, or a pop-up menu or list: 

1. Tab or click the field you want to copy. A rectangle appears around the field.

2. Choose Copy from the Edit menu. 

3. Click in the field where you want to paste data. 

4. Choose Paste from the Edit menu.

FileMaker Pro replaces the field's contents instead of appending the pasted data.

To copy the field contents from the previously modified record:

1. Tab into the field you want to copy into.

2. Click where you want to paste the field contents or select the information you want to replace. To 
replace all data in the field, choose Select All from the Edit menu.

3. Choose Paste Special from the Edit menu and From Last Record from the submenu.

To copy all data in the current record to another application:

1. In Browse with no field selected , choose Copy from the Edit menu. All data except picture/sound 
fields are copied to the Clipboard in tab-delimited format, without text styles.

2. Open the destination document in the other application.

3. Paste the data with the application's Paste command.

To copy all data in the current found set, follow the steps above, but press Shift when you choose 
Copy.

Notes:



- You can copy the contents of a calculation or summary field, but you cannot paste into 
either field.

- Before you can paste data into a field, you must have access privileges to that field.

See Also

Tab Order... 

Entering Data 



Working with Sound Fields
You can add and play sounds in picture/sound fields if you have:

- Windows 3.1 or Windows 3.0 with multi-media extensions software

- a compatible sound board

- a sound driver file

- a microphone or other input device (if you want to record sounds)

To copy a sound into a picture/sound field:

1. Using the Microsoft Windows Sound Recorder application (soundrec.exe) or other application that 
uses sounds in *.wav format, copy the sound you want for your field. 

2. Choose Define Fields from the Select menu, define a picture/sound field in the Define Fields dialog
box, and click OK. 

3. Choose Browse with the mode selector at the bottom of the screen and move to the record you 
want.

4. Move to a picture/sound field and choose Paste from the Edit menu. A small speaker icon appears 
in the field to show that the field stores a sound.

Note: You can also use sounds in the Macintosh 1 or 2 'snd' format. These sounds will play in both
the Windows and Macintosh versions of FileMaker Pro 2.0.

To record a sound:

1. Double-click an empty sound/picture field. You see the Sound Record dialog box.

2. Click Record to begin recording. You can click Stop or Pause during recording.

To play a sound:

- In Browse, double-click a field that stores a sound.

- In the Sound Record dialog box, click the Play button.

To delete a sound, click in the sound/picture field and press the Delete or Backspace key.

See Also
Creating a New Field 

Field Types 

Entering Data 



Adding a QuickTime Movie
You can add QuickTime for Windows movies to the picture/sound fields in your layout by using the 
Import QuickTime command or pasting them from the Clipboard.

Note:    The movie in a picture/sound field is actually a reference to a QuickTime for Windows movie 
file. If you move the database to another computer, you should also move the movie file. If you move 
or rename the movie file, FileMaker Pro prompts you for the filename when you try to play the movie.

To import a QuickTime movie:

1. In Browse, select the picture/sound field you want to import to.

2. Choose Import/Export from the File menu and Import QuickTime from the submenu. You see the 
Import QuickTime dialog box.

3. If necessary, select QuickTime File (*.MOV) from the Import File of Type list.

4. Select the movie file you want to import. If necessary, scroll through the list, or change the 
directory or drive to find the file you want.

5. Click OK. The first frame of the movie appears in the field.

To paste a QuickTime movie from the Clipboard:

1. Copy the QuickTime movie you want to paste from FileMaker Pro. 

2. Open the FileMaker Pro file where you want to paste the QuickTime movie.

3. In Browse, display the record you want to paste into, or add a new record.

4. Click or tab into the picture/sound field to select it. 

5. Choose Paste from the Edit menu to store the movie in the field.

Important: To use a Macintosh QuickTime movie with FileMaker Pro for Windows, you must first use 
Movie Converter on the Macintosh to save the movie in a self-contained format playable on non-
Apple computers. 

To save a QuickTime movie in a self-contained format playable on non-Apple computers:

1. On the Macintosh, start Movie Converter.

2. Open the QuickTime movie you want to convert.

3. Choose Save As from the File menu.

4. In the Save As dialog box, give the converted movie a Windows-standard name.    The    name can 
be up to eight characters plus the .MOV extension.

5. Click Make movie self-contained.

6. Click Make playable on non-Apple computers.

The first time you play a movie from the other platform, FileMaker Pro prompts you for the location 
of the movie.

See Also

Playing a QuickTime Movie 

Formatting Fields 



Playing a QuickTime Movie
To play a QuickTime movie, click or tab in the picture/sound field to display the controls. Then use 
the controls as follows.

- Click the play button to start or stop the movie.

- Drag the scroll bar to go to a specific frame of the movie.

- Click the frame backward button or the frame forward button to cycle through the 
frames.

- Click the sound button to adjust the sound volume.

See Also

Adding a QuickTime Movie 

Field Types 

Entering Data 



Looking Up Data in Other Files
As you add or edit records, you can look up information in one FileMaker Pro file (the lookup file) and 
copy it into a specified field. If the data changes in the lookup file, you can update your files without 
re-entering the data.

To look up data in another file:

Part 1: Define a lookup field

1. Choose Define Fields from the Select menu.

2. In the Define Fields dialog box, select a field or create a new one.

Note: You can use a calculation field to trigger a lookup but you can't look up information in a 
calculation field.

Part 2: Select a lookup file

1. Click Options.

2. Click Look Up Values from a File. You see the Open File dialog box.

3. Select a file where you want FileMaker Pro to look for information and click OK. You see the 
Lookup Value dialog box. The name of the file you selected appears on the left, under Lookup File.
The name of the file you're setting a lookup for--the current file--appears on the right.

Part 3: Select field values to copy

1. Open the Copy the Contents Of pop-up list and select the field in the lookup file that has the values
you want to copy. The contents of this field will be copied into the field shown under Into the Field 
when FileMaker Pro performs the lookup.

2. In the When the Value In pop-up list, select the field name in the lookup file that will match value in 
the field in the current file.

3. In the Matches a New Entry In pop-up list, select a field name from the current file. When you type 
a new value in this field in the current file, FileMaker Pro looks for a matching entry in the lookup 
file.

Part 4: Select an option if there isn't a match

1. Select an option telling FileMaker Pro what to do if those values aren't found in the lookup file:

- To leave the field unchanged if there isn't a match, click Don't Copy.

- To copy the next lower value, click Copy Next Lower Value.

- To copy the next higher value, click Copy Next Higher Value.

- To specify substitution data if values don't match, click Use and type a value.

- To prevent copying the value if the field is empty, click Don't Copy Contents If Empty.

2. Click OK. 

To update lookup data, choose Relookup from the Edit menu.

See Also

Relookup 

Entering Data 





Deleting Data
You can delete field entries in Browse, find request criteria in Find, and objects in Layout. 

To delete data or objects and place them on the Clipboard:

1. Choose the mode you want with the mode selector at the bottom of the screen.

2. Select the data or object you want to remove.

3. Choose Cut from the Edit menu. FileMaker Pro places the cut selection on the Clipboard. (You can
paste it in another location.)

To delete data or objects without placing them on the Clipboard, choose Clear from the Edit 
menu .

Note: You cannot delete locked items or items for which you don't have access.

See Also

Text Selection and Insertion Point Actions 

Edit Actions 

Setting Access Privileges for a Group 



Adding and Deleting Records
You can add and delete records in Browse. 

To add a new record, choose New Record from the Edit menu.

To duplicate a record, go to the record you want to duplicate and choose Duplicate Record from the 
Edit menu.

New and duplicate records appear in the currently selected layout.

To delete the current record, choose Delete Record from the Edit menu.

To delete the found set, choose Delete Found Set from the Edit menu.

Caution: Deleting records permanently erases all data in those records. You might want to make a 
copy of your file before deleting records.

See Also

Importing Records 

Making a Find Request 



Checking Spelling
You can check the spelling of record and layout text against the FileMaker Pro 100,000-word 
dictionary and your own user dictionary.

To check data entries:

1. If necessary, choose Browse with the mode selector at the bottom of the screen.

2. Choose Spelling from the Edit menu and a command from the Spelling submenu:

- To check all data in the current record, choose Check Record.

- To check all data in the found set, choose Check Found Set.

You see the Spelling dialog box and FileMaker Pro starts checking for questionable words.

3. If a questionable word appears in the Word box, you can:

- Correct the word by selecting a suggestion from the list and clicking Replace. (To see 
the word in its surrounding text, click the double arrow button in the bottom right corner 
of the dialog box.)

- Correct the word by typing a revision in the Word box and clicking Replace. You can 
check the spelling of your revision by clicking Check.

- Ignore the word by clicking Skip.

- Add the word to your user dictionary by clicking Learn. Once added to your user 
dictionary, FileMaker Pro considers the spelling valid.

To check layout text, follow the same steps in Layout and choose Check Layout from the Spelling 
submenu.

To check spelling as you type:

1. Choose Spelling from the Edit menu and Spelling Options from the submenu. You see the Spelling
Options dialog box.

2. Click Beep on Questionable Spellings or Flash Menu Bar on Questionable Spellings to show how 
you want to be alerted to questionable spellings.

FileMaker Pro alerts you each time you type a questionable word. To correct the last word you 
typed, choose Spell Word from the Spelling submenu and make changes as needed in the 
Spelling dialog box.

See Also

Working with Dictionaries 



Working with Dictionaries
You can change, create, or edit the dictionaries FileMaker Pro uses when you check spelling.

FileMaker Pro has two dictionaries, a 100,000-word main dictionary that is installed when you install 
the product, and the user dictionary you create. You can have multiple versions of either dictionary, 
but you can only install and use one of each at any given time.

Note: To avoid telling FileMaker Pro where the dictionaries are located each time you do a spell 
check, store all dictionary files in the Fmpro or Claris directories.

To select a different main or user dictionary:

1. Choose Spelling from the Edit menu and Install Dictionaries from the submenu. You see the Install 
Dictionaries dialog box.

2. Click Main or User. 

3. Select the dictionary file drive from the Drives pop-up list and the directory from the Directory list. 
Main dictionaries have an .NDX extension; user dictionaries have an .SPL extension.

4. Select the name of the dictionary file from the File Name list.

5. Click OK.

To create a new user dictionary:

1. Choose Spelling from the Edit menu and Install Dictionaries from the submenu. You see the Install 
Dictionary dialog box.

2. Click User.

3. Select a directory for the file in the Directories list and a drive for the file from the Drives pop-up 
list.

4. Type a name for the new dictionary in the File Name box.

5. Click New.

To edit the current user dictionary:

1. Choose Spelling from the Edit menu and User Dictionary from the submenu. You see the User 
Dictionary dialog box.

2. To add a word, type it in the Entry box and click Add. To remove a word, select it in the list and 
click Remove.

There are two other ways to add words to the user dictionary:

- You can import a text file. Click the double arrow button in the User Dictionary dialog 
box, click Import, and select the file you want to import.

- During a spell check, you can type the new word in the Word box (or accept a 
questionable word) and click the Learn button.

See Also

Checking Spelling 



File Menu
Use File menu commands to manage, print, copy, and recover files, set preferences, work with files 
on a network, and exit FileMaker Pro.

New... 

Open... 

Close 

Preferences... 

Access Privileges 

Change Password... 

Single-User 

Multi-User 

Print Setup...    

Print... 

Import/Export 

Save a Copy As... 

Recover... 

Exit 



New...
File Menu

Opens the Create New File dialog box so you can start a new, empty database file with the name and
path you specify.

 
Create New File Dialog Box

After you name the new file, you see the Define Fields dialog box. In this dialog box you begin 
defining fields for the database.

 
Define Fields Dialog Box

See Also
Creating a New File 

Defining Fields and Entering Data 



Create New File Dialog Box

Option Action

File Name Type a name for the new file

List Files of Type Select FileMaker Pro (*.FM) files or All Files (*.*) from the 
pop-up list

Directories Select a directory from the list

Drives Select a drive from the pop-up list

Open...
File Menu

Opens a FileMaker Pro database created with FileMaker Pro 2.0 for Windows or FileMaker Pro 2.0 
for Macintosh.

 
Open File Dialog Box

From the Open File dialog box, you can use the Hosts button to open files available on your network.

 
Hosts Dialog Box

See Also

Opening Existing Files 

Sharing Files Across a Network 



Open File Dialog Box

Option Action

File Name Type the name of the file you want to open or select it 
from the list

List Files of Type Select FileMaker Pro (*.FM) files or All Files (*.*) from 
the pop-up list

Drives Select the drive that contains the file from the pop-up list

Directories Select the file's directory from the list

Network Opens the Hosts dialog box so you can open multi-user 
files available on your network



Hosts Dialog Box
Select a multiuser file from the list.



Close
File Menu
Saves all changes to the active file and then closes it. 

See Also

Saving Files  

Working with Files as a Host 



Preferences...
File Menu

Sets general, document, and memory preferences.

Click the icons for more information about the three types of options in the Preferences dialog box.

- General options are settings that affect all FileMaker Pro files.

 
General Preferences Options

- Document options affect the current open file.

 
Document Preferences Options

- Memory options specify how FileMaker Pro will use your computer's memory.

 
Memory Preferences Options

See Also

Setting Preferences 



General Preferences Options

Option Action

Always lock layout tools Select to keep the current tool active until you choose 
another tool

Add newly defined fields
to current layout

Deselect to define new fields without changing the 
current layout

Show Macintosh 
accelerators in menus

Select to display both Windows and Macintosh keyboard
shortcuts (the Ctrl key replaces the Macintosh command
key)

User name Type the name you want FileMaker Pro to insert into a 
field with the Current User Name command 

The preset name is the name you typed in the 
registration screen when you installed FileMaker Pro

Done Click when you finish setting general, document, and 
memory options



Document Preferences Options

Option Action

Use smart quotes Click to insert curved quotation and apostrophe marks 
when you use the apostrophe/quote key

Smart quotes are not available in some fonts

Store Macintosh picture 
format

Click to store picture data in both Macintosh (PICT) and 
Windows Metafile (WMF) formats

When this option is on, you see the picture data when 
you open the file in either FileMaker Pro 2.0 for Windows
and FileMaker Pro 2.0 for Macintosh

When this option is off, you see the picture data when 
you open the file in FileMaker Pro 2.0 for Windows and 
only the rectangular boundary of the picture when you 
open the file in FileMaker Pro 2.0 for Macintosh

If you don't expect to open the file in FileMaker 2.0 for 
Macintosh, you can save space by setting this option to 
off

When opening 
"current file":

Switch to layout: Select the layout you want to appear each time you 
open the file

Status area: Select Show from the pop-up list to display the status 
area or Hide to conceal it

Maximize window Click to enlarge the document window to full screen size 
when you open the file

Perform script: Select the script you want FileMaker Pro to perform 
each time you open the file

Done Click when you are finished setting general, document, 
and memory options



Memory Preferences Options

Option Action

File cache is always 
on. Current size is 
<cache size> K

View file cache information

Save changes to 
disk:

during idle time Click to save changes when the computer is inactive

every <10, 15, or 30 
minutes or every 
hour> 

Click and select a time interval from the pop-up list

Done Click when you finish setting general, document, and 
memory options

Access Privileges
File Menu

Use Access Privileges submenu commands to control access to shared files. You can control who 
can open a file, which layouts and fields they can see, and what changes they can make. The Access 
Privileges submenu contains these commands:

Define Groups... 

Define Passwords... 

Overview... 

See Also
Networking and Access Privileges 



Define Groups...
File Menu
Access Privileges Submenu

Sets up groups of users who can access your files. You set up access privileges for each group by 
linking the group name to a password and selecting the layouts and fields they can access. 

 
Define Groups Dialog Box

See Also

Defining Groups 

Networking and Access Privileges 



Define Groups Dialog Box

Option Action

List of groups To change a group's privileges, select a group name 
from the list 

Group Name Type a name for the group

Access... Click the button and select permitted activities and 
passwords for the selected group from the Access 
Privileges for File dialog box

Passwords... Click the button and select passwords for a group from 
the Define Passwords dialog box 

Create Create a group with the name you typed in the Group 
Name box

Rename Type a different name for the selected group and click 
Rename

Delete Select a group name from the list and click Delete

Done Click when you're finished defining groups

Define Passwords...
File Menu
Access Privileges Submenu

Creates passwords that control access and activity privileges for a file. At least one password must 
grant access to the entire file.

 
Define Passwords Dialog Box

See Also

Defining Passwords 

Networking and Access Privileges 



Define Passwords Dialog Box

Option Action

List View a list of the passwords defined for the file

Password Type a password that grants the privileges selected in 
this dialog box

Privileges

Access the entire file Click to permit access to a file, including the ability to 
change passwords

This privilege grants all other privileges, and all layouts 
and fields are accessible

Browse records Click to permit the ability to view records

This basic privilege is always available

Print/Export records Click to permit the user to print and export records

Edit records Click to permit the user to change data in fields

Create new records Click to permit the user to add new records

Delete records Click to permit the user to delete records

Override data entry 
warning

Click to ignore entry warnings that restrict how you enter
data in a field

Design layouts Click to permit the user to design layouts

Edit scripts Click to permit the user to change scripts

Create Click to create the password with the privileges selected 

Access Click to select passwords and accessible layouts and 
fields for a group from the Access Privileges for File 
dialog box 

Change Select different privileges for the password and click 
Change

Groups Click to define a group that will use the password or to 
change group definitions in the Define Groups dialog 
box 

Delete Click to delete the selected password

Done Click when you're finished defining the password and 
then confirm the password

Overview...
File Menu
Access Privileges Submenu

Displays the passwords available for groups and the layout and field access granted with the 
password.

 
Access Privileges for File Dialog Box

See Also

Define Groups... 

Define Passwords...      



Access Privileges for File Dialog Box

Option Action

Groups Select a group name to view or to change its access 
privileges

Passwords Click the bullet in front of the password to assign it to a 
group

A solid bullet ( ) associates the password with the group
An open bullet ( ) disassociates it 
You cannot assign a password to a group if the password 
accesses the entire file 

Layouts Click the bullet in front of a layout to assign it to the 
selected group

A solid bullet ( ) grants access
A dimmed bullet ( ) denies access
An open bullet (  ) indicates the field can be read but not 
edited by the selected group

Fields Click the bullet in front of a field to assign it to the 
selected group

A solid bullet ( ) grants access
A dimmed bullet ( ) denies access
An open bullet ( ) indicates the field can be read but not 
edited by the selected group

Revert Click to return to the original settings for the group

Done Click to close the dialog box when you are finished 
making changes

Save Click to save the current access setup



Change Password...
File Menu

The Change Password command replaces the Access Privileges command when you have limited 
access to the file.

 
Change Password Dialog Box

See Also

Defining Passwords 

Networking and Access Privileges 



Change Password Dialog Box

Option Action

Old password Type the old password

New password Type a new password

Confirm new password Type the new password again to confirm



Single-User
File Menu

On a network, restricts access to the first user who opens a FileMaker Pro file. 

See Also

Networking and Access Privileges 



Multi-User
File Menu

On a network, gives multiple users on a network access to the file.

See Also

Networking and Access Privileges 

Working with Files as a Host 

Working with Files as a Guest 



Print Setup...
File Menu

Selects printer and page options. These settings control the printing of all records in the document. 

 
Print Setup Dialog Box

Note: The Printer Setup command is unavailable in Find.

See Also

Selecting a Printer 



Print Setup Dialog Box

Option Action

Printer Click Default to use the currently selected printer or click
Specific Printer and choose a printer from the pop-up list

Orientation Click Portrait for a vertical page orientation or 
Landscape for horizontal orientation.

Paper Select a size from the Size pop-up list to match the 
paper size loaded in your printer

Select a tray or bin from the Source list if your printer 
uses single sheets of paper

Options... If you open the Print dialog box through the Setup button
in the Print dialog box, you can click the Options button 
to select printer-specific options

These print options apply to the current print job only 

See the Microsoft Windows User's Guide and your 
printer documentation for more information about these 
options

Print...
File Menu

Prints the entire current file, selected records, or field and script definitions. Records print according to
the paper size and orientation settings in the Print Setup dialog box.

 
Print Dialog Box

Note: The Print command is unavailable in Find.

See Also
Selecting Print Options 

Selecting a Printer 



Print Dialog Box

Option Action

Print Range Click All to print the entire file or Pages to print a selected 
series of pages

If you select Pages, type the first and last page numbers in 
the From and To boxes

Print Quality Select a print quality option from the pop-up list

For laser printers, the largest dpi (dots per inch) options 
represent higher print quality

For dot-matrix printers, select options such as Draft or 
Proof, High, Medium, or Low, or Low or Draft

Copies Type the number of copies you want to print

Print to File Click to create a print job file which you can use to print the 
file later or to print it from a different computer

Collate Copies Click to print complete collated copies instead of printing all 
copies of one page before printing the next page

Number pages from If your layout shows page numbers, type the starting page 
number in the box

Print Click the option you want:

Records Being Browsed to print all records in the found set 

Current Record to print the current record only

Blank Record, Showing Fields to print fields without data. 
From the pop-up list, select As Formatted to print the fields 
as formatted in the Field Borders dialog box, With Boxes to 
print each field in a box, or With Underlines to print each 
field with an underline 

Field Definitions to print a list of field definitions

Script Definition For to print scripts. From the pop-up list, 
select All Scripts to print all scripts defined for the file or 
select a script name to print a specific script

Setup Click to select printer setup options in the Print Setup dialog
box

Import/Export
File Menu

Use Import/Export submenu commands to exchange data between FileMaker Pro files or FileMaker 
Pro and other applications.

The Import/Export submenu contains these commands:

Import Records.. 

Import Picture... 

Import QuickTime... 

Export Records...

Note: Import/Export commands are unavailable in Find.

See Also
Importing Records 

Importing Pictures 



Importing QuickTime Movies 

Exporting Records to Other Applications 

Import/Export File Formats 

Import Picture File Formats 



Import Records...
File Menu
Import/Export Submenu

Imports records from another file into the current FileMaker Pro database. You can import records 
from other FileMaker Pro files or files from other applications.

Select a file with the records you want in the Import Records dialog box.

 
Import Records From File Dialog Box

Once you select a file, select the records you want and specify their import order.

 
Specify Field Order for Import Dialog Box

See Also
Importing Records 

Importing Pictures 

Importing QuickTime Movies 

Exporting Records to Other Applications 

Import/Export File Formats 



Import Records From File Dialog Box

Option Action

Import File of Type Select the format of the file you want to import from the 
pop-up list: *.FM, *.TAB, *.TXT, *.CSV, *.SLK, *.DBF, 
*.DIF, *.WK1, *.WKS, *.BAS, or *.MER

You can also select *.* to display all available files in the 
files list

File Name Select the name of the file you want to import from the 
list

Directories Select the directory of the file you want to import from 
the list

Drives Select the drive of the file you want to import from the 
pop-up list

OK Displays the Specify Field Order for Import dialog box 
where you select the fields you want to import and 
specify how they will be imported



Specify Field Order for Import Dialog Box

Option Action

Data in <imported file> View the current mapping order-- data from the field 
name on the left is imported into the field on the right

Fields in <current file> Drag FileMaker Pro fields to rearrange the mapping 
order

Scan Data Click the Scan Data arrows to move backward and 
forward through records in the source file

The status information next to the scan arrows show the 
current record number

Character Set If the source file uses a character set above ASCII 127, 
click to select the source platform or application-- 
Windows (ANSI), DOS, Macintosh, or Lotus (LICS)

Add new records Click to import the records into a new found set 

Replace data in current 
found set

Click to replace data in the found set 

Import Picture...
File Menu
Import/Export Submenu

Imports pictures into FileMaker Pro that come from other applications. FileMaker Pro stores the 
imported pictures in both Macintosh (PICT) and Windows Metafile (WMF) formats.

In Layout, you import picture objects to design your layout. In Browse, you import pictures into 
picture/sound fields.

Select the file type and file you want to import from the Import Pictures dialog box.

 
Import Picture Dialog Box

Once you select a file, a dialog box appears if the file is a .cgm, .drw, .pcx, .pic, or .plt file type.

 
.CGM Picture Import Filter 1.0 Dialog Box

 
.DRW Picture Import Filter 1.0 Dialog Box

 
.PCX Picture Import Filter 1.0 Dialog Box

 
.PIC Picture Import Filter 1.0 Dialog Box

 
.PLT Picture Import Filter 1.0 Dialog Box

See Also

Importing Pictures 

Import Picture File Formats 



Importing QuickTime Movies 

Importing Records 

Exporting Records to Other Applications 

Import/Export File Formats 

Document Preferences Options 



Import Picture Dialog Box

Option Action

File Name Select the name of the file you want to import from the 
pop-up list

Directories Select the directory of the file you want to import from 
the list

Import File of Type Select the format of the file you want to import from the 
pop-up list: All available (pictures), *.CGM, *.BMP, *.TIF, 
*.GIF, *.PCX, *.WMF, *.DRW, *.PLT, *.PIC, *.SLD, *.PCT, 
*.MAC, or *.EPS

Drives Select the drive of the file you want to import from the 
pop-up list

OK Imports the picture

With some picture formats, you see a dialog box for 
customizing how the picture will be imported



.CGM Picture Import Filter 1.0 Dialog Box

Option Action

Force Vector Fonts Click to convert the picture's non-scalable raster fonts to 
scalable vector fonts

Ignore Background Click to make the picture background transparent

Default Color Table If you're converting a Harvard Graphics .CGM file, click 
to use the file's default color table

Maintain Dotted Lines Click to keep the picture's dotted lines instead of 
converting them to solid lines

(Solid lines may print better than dotted lines)



.DRW Picture Import Filter 1.0 Dialog Box

Option Action

Force Vector Fonts Click to convert the picture's non-scalable raster fonts to 
scalable vector fonts

Ignore Background Click to make the picture background transparent



.PCX Picture Import Filter 1.0 Dialog Box
Click Invert Colors to reverse the picture's colors.



.PIC Picture Import Filter 1.0 Dialog Box
Click to convert the picture's non-scalable raster fonts to scalable vector fonts.



.PLT Picture Import Filter 1.0 Dialog Box

Option Action

Dimensions Click to select the picture's original page size:

A (8.5 x 11 in.)

B (11 x 17 in.)

A4 (210 x 297 mm)

A3 (297 x 420 mm)

Colors... Click to select the color of each pen used in the source 
picture

Click a number (1 through 6) to select a pen, and for 
each pen, change the Red, Green, and Blue values

Click Defaults to revert to the default colors

Defaults Click to revert to the default colors and page size 



Import QuickTime...
File Menu
Import/Export Submenu

Imports QuickTime for Windows movies into FileMaker Pro.

In Browse, you import QuickTime movies into picture/sound fields. Select the file you want to import 
from the Import QuickTime dialog box.

Import QuickTime Dialog Box

See Also

Importing Pictures 

Importing QuickTime Movies 

Importing Records 

Exporting Records to Other Applications 

Import/Export File Formats 



Import QuickTime Dialog Box

Option Action

File Name Select the name of the file you want to import from the 
pop-up list

Directories Select the directory of the file you want to import from 
the list

Import File of Type Select the format of the file you want to import from the 
pop-up list: QuickTime Files (*.MOV) or All files (*.*)

Drives Select the drive of the file you want to import from the 
pop-up list

OK Import the QuickTime movie



Export Records...
File Menu
Import/Export Submenu

Saves the records you select in a format that can be used by other applications. You select a 
destination file for the records in the Export Records to File dialog box.

 
Export Records to File Dialog Box

After you select a destination file, specify the export order of the fields you're exporting in the Specify 
Field Order for Export dialog box.

 
Specify Field Order for Export Dialog Box

See Also
Exporting Records to Other Applications 

Importing Records 

Importing Pictures 

Import/Export File Formats 



Export Records to File Dialog Box

Option Action

Export File of Type Select a format for the exported file from the pop-up list: 
*.TAB, *.CSV, *.SLK, *.DBF, *.DIF, *.WK1, *. BAS, or 
*.MER

File Name Type a name for the export file

Directories Select a directory for the export file

Drives Select a drive for the export file

OK Displays the Specify Field Order for Export dialog box 
where you select the fields you want to export and 
specify how they will be exported



Specify Field Order for Export Dialog Box

Option Action

Field list Select the fields you want to export from this list

You can also drag fields to change the order in which 
they are exported

Summarize by... If you select a summary field to export in a sorted 
database, you can click Summarize by to select a field to
summarize by

Character Set If the exported version of the file uses a character set 
above ASCII 127, click to select the source platform or 
application: Windows (ANSI), DOS, Macintosh, or Lotus 
(LICS)

Don't format output Click to export values without retaining the original 
number, date, time, and currency formats

Format output using 
current layout

Click to export values with the original number, date, 
time, and currency formats

Save a Copy As...
File Menu

Saves a copy of the file with the name, directory, drive, and copy option you specify. 

 
Save a Copy Dialog Box

See Also

Saving Files 

Exit 



Save a Copy Dialog Box

Option Action

Save a: Select a copy option from the pop-up list: Copy of 
Current File to save a duplicate of the file, Compressed 
Copy (Smaller) to save a duplicate that uses less disk 
space, or Clone (No Records) to save a copy as a 
template

File Name Type a different name for the file

List Files of Type Select FileMaker Pro Files (*.FM) from the list

Directories Select a directory for the file copy from the list

Drives Select a drive for the file copy from the pop-up list

Save Click to make the file copy

Recover...
File Menu

Creates a repaired copy of a damaged file. The repaired copy of the file is named r <file name>.fm.

Open the damaged file in the Open Damaged File dialog box.

 
Open Damaged File Dialog Box

Once you open the file, name the repaired copy of the file in the Name Recovered File dialog box.

 
Name Recovered File Dialog Box

See Also

Recovering Files 

Troubleshooting 



Open Damaged File Dialog Box

Option Action

File Name Select the name of the file you want to recover

List Files of Type Select FileMaker Pro Files (*.FM) from the pop-up list

Directories Select the directory of the damaged file from the list

Drives Select the drive of the damaged file from the pop-up list



Name Recovered File Dialog Box

Option Action

File Name Accept r <file name>.fm as the name of the recovered 
copy of the file, or type a name 

List Files of Type Select FileMaker Files (*.FM) from the pop-up list

Directories Select a directory for the recovered file from the list

Drives Select a drive for the recovered file from the pop-up list

Exit
File Menu

Saves all files and quits FileMaker Pro.

See Also

Saving Files 



Finding and Sorting Information
You can create find requests to search for records that contain specific data. You can also sort 
records based on the data in one or more fields.

Using Find Mode 

Making a Find Request 

Updating a Find Request 

Modifying a Find Request 

Using Wildcards in Find Requests

Finding Literal Text 

Finding Dates 

Finding a Range of Values 

Finding All Records 

Finding Boolean Numbers 

Finding Numbers 

Finding Times 

Finding Words 

Finding Records that Match All the Criteria 

Finding Records that Match Either One Criterion or Another 

Finding Records that Don't Match a Request

Omitting Records 

Basic Sorts 

Sorting on a Summary Field 

Custom Sorts 

International Sorts 

Changing the Sort Order 



Using Find Mode
Use Find mode to work with find requests--blank records into which you type or paste search criteria. 
FileMaker Pro maintains a field-by-field index of the values in a file. When you run a find request, 
FileMaker Pro looks through the index to find entries that match the search criteria.

Records that match the criteria are called the found set. Once you have a found set, those are the 
only records available for browsing, sorting, previewing, and printing.

To switch to Find, select Find with the mode selector at the bottom of your screen or choose Find from
the Select menu. 

See Also

Making a Find Request 

Find Status Area    



Making a Find Request
Use a find request to locate records based on your search criteria. You can use a new request when 
you want to search for different values in the same field (an AND request), add new sets of criteria by 
making multiple requests (an OR request), or find some records and omit others.

To make a find request:

1. Open the layout you want to use to find records.

2. Choose Find with the mode selector at the bottom of the screen. You see a blank find request that 
looks like a record without data.

3. Type values in the appropriate fields. You can also choose Paste Special from the Edit menu and 
From Index from the submenu to paste values from the index.

4. Click Find.

FileMaker Pro finds the matching records (ignoring capitalization), returns to Browse, and shows 
the number of records found.

See Also

Updating a Find Request 

Modifying a Find Request 



Updating a Find Request
When you add or delete records after making a find request, you can update the found set by 
repeating the find request. If you delete records or the records you've added match the search 
criteria, you'll get a different found set.

To repeat a find request:

1. Switch to the layout you used for the find request.

2. Choose Refind from the Select menu.

3. Click Find.

See Also

Making a Find Request 

Modifying a Find Request 



Modifying a Find Request
To make minor changes to a find request, you can modify the request instead of entering the criteria 
in a new request.

To edit a find request:

1. Switch to the layout you used for the find request.

2. Choose Refind from the Select menu. You see the previous find request.

3. Edit the search criteria.

4. Click Find.

FileMaker Pro searches all records in the file for records that match the changed request.

See Also

Making a Find Request 

Updating a Find Request 



Using Wildcards in Find Requests
When making a find request, you can use wildcards to find words when you're not sure of all the 
characters. FileMaker Pro looks for the words in text fields and in calculation fields with a text result.

- Choose the @ wildcard when you know the number of unknown characters in a field 
but are not sure what they are.

For example, to find Gray and Grey, type Gr@y.

- Choose the * wildcard to substitute for any number of unknown characters.

For example, to find McKineh and McKenneh, type McK*. 

See Also
Making a Find Request 

Finding Words 

Finding Literal Text 



Finding Literal Text
You can find whole words in a specific order by searching for literal text. Searching for whole words is 
much faster than using wildcards to search for a text string that contains part of a word.

To find literal text, type the words within double quotation marks (" "). In the find request, you must 
type the words, spaces, and punctuation in the order that they appear in the records you're searching 
for. FileMaker Pro ignores capitalization.

For example, to find Marten and Jones Interiors, in that order, type "Marten and Jones Interiors" in the
field.

See Also

Making a Find Request 

Finding Words 

Using Wildcards in a Find Request 



Finding Dates
You can find all records in your file that match a specific date. FileMaker Pro looks for the date in date
fields and calculation fields with a date result. 

You can search for invalid date values that aren't in the standard format of mm/dd/yy by using the ? 
wildcard.

To find dates in date and calculation fields:

1. In a date or calculation field of a find request, type the date as digits separated by a nonnumeric 
character.

To find records with today's date, choose // (today's date) from the Symbols list in the status area 
or type two slashes (//).

2. Click Find.

To find an invalid date:

1. Select the date field.

2. Type ? or choose ? from the Symbols list in the status area.

3. Click Find.

See Also

Making a Find Request 

Finding Times 

Finding Numbers 

Finding Words 



Finding a Range of Values
Using the range symbol (...), you can search for ranges in fields that contain:

- text and calculations with text results

- numbers and calculations with number results

- dates, times, and calculations with date or time results

To find a range of values:

1. In a find request field, type the first value of the range you want to find. From the Symbols list in 
the Find status area, choose ... (range) to insert the operator. Then type the last value in the range.
For example, 12:30...17:30 finds records that contain times from 12:30 through 17:30, inclusive, in 
the corresponding field.

2. Click Find.

See Also
Making a Find Request 

Finding Dates 

Finding Numbers 

Finding Times 



Finding All Records
When you're working with a found set, you can find all the records in a file by choosing Find All from 
the Select menu. Find All makes all records available for browsing, editing, or sorting.

See Also

Finding Records that Match All the Criteria 

Finding Records that Match Either One Criterion or Another 



Finding Boolean Numbers
You can find records with Boolean numbers if your file contains number fields that have been 
formatted for Boolean values.

To find Boolean numbers:

1. To find records with a zero or non-zero Boolean value, type the value you want to search for in the 
field.

The value you type depends on how you've formatted Boolean values with the Number Format 
command in the Format menu. For example, if you use the preset values of Yes for non-zeros and 
No for zeros, type No to find false values.

2. Click Find.

See Also

Making a Find Request 

Finding a Range of Values 

Finding Numbers 



Finding Numbers
You can find all records in your file that match a specific number in a number or calculation field.

To find numbers in a number or calculation field:

1. Type the unformatted number in the appropriate field of the find request. For example, to find the 
number .50 in a field that is formatted to display it as 50%, type .50.

2. Click Find.

See Also

Making a Find Request 

Finding a Range of Values 

Finding Boolean Numbers 



Finding Times
You can find all records in your file that contain an exact time value or calculation. FileMaker Pro 
looks for the time data in time or calculation fields with a time result. 

You can search for time values that aren't in the standard format hh:mm:ss by using the ? wildcard.

To find times in a time or calculation field:

1. Type the time you want to find in the appropriate field of the find request. Use the standard time 
format (hh:mm:ss).

2. Click Find.

To find times that aren't in the standard time format:

1. Select the time field.

2. Type ? or choose ? from the Symbols list in the status area.

3. Click Find.

See Also

Using Find Mode 

Making a Find Request 

Finding Dates 



Finding Words
You can find all records in your file that start with specific characters or exactly match words within a 
field. FileMaker Pro looks for the words in text fields or calculation fields with a text result.

If your search criteria consists of multiple words, FileMaker Pro will look for words in any order. For 
example, if you type John Martin, you might also find Martin John. To find words in a specific order, 
type the words within quotation marks (" ").

To find words that start with specific characters, type those characters in the field.

To find exact words:

1. Click inside a text field or calculation field with a text result.

2. From the Symbols list, select = (exact match).

3. Type the text you want to match.

4. Click Find.

See Also

Making a Find Request 

Finding Literal Text 

Using Wildcards in Find Requests



Finding Records that Match
All the Criteria

You can find all records in your file that match all the search criteria you enter in separate fields in 
your find request. This is called a logical AND search, because FileMaker Pro finds records that 
match one search criterion AND another.

To find records that match all search criteria:

1. Enter search criteria into as many fields as needed to make your request specific.

2. Click Find.

See Also
Making a Find Request 

Finding Records that Match Either One Criterion or Another 

Finding All Records 

Finding Records that Don't Match a Request



Finding Records that Match
Either One Criterion or Another

You can find all records in your file that match either one search criterion or another by filling out 
separate find requests. This is called a logical OR search.

To find records that match either one criterion or another:

1. Choose New Request from the Edit menu and enter the search criteria in the appropriate fields.

2. Make additional find requests as necessary.

3. Click Find.

FileMaker Pro adds the newly requested records to the set you found with the first request

See Also

Making a Find Request 

Finding Records that Match All the Criteria 

Finding All Records 

Finding Records that Don't Match a Request



Finding Records that Don't Match a Request
You can find all records in your file that don't match any of the search criteria you've entered in your 
find request. 

For example, to find all records except those for the state of California, you can type California in the 
find request and then omit those records.

To find records that don't match the request:

1. In the appropriate fields of the find request, enter the values you don't want to include in the found 
set.

2. In the Find status area, click Omit.

3. Click Find.

See Also

Making a Find Request 

Omitting Records 



Omitting Records
Omitting a group of consecutive records makes them unavailable for the moment, but does not delete
the records from the file. Omitted records are not included in summaries, and they are not sorted, 
printed, or exported.

When you click Omit in the Find status area, you omit a record or records for a find request based on 
the contents of certain fields. The Omit command (on the Select menu) omits records without regard 
to content.

For example, after finding all records for customers in a specific state, you could omit the records for 
those who have already placed an order with the Omit command.

To omit the current record:

1. Make the record you want to omit the current record.

2. Choose Omit from the Select menu.

To omit a group of records:

1. Make the first record you want to omit the current record.

2. Choose Omit Multiple from the Select menu.

3. In the dialog box, type the number of records you want to omit and click OK.

To restore all omitted records choose Find All from the Select menu.

To switch between the found set and the omitted set choose Find Omitted from the Select menu.

See Also

Finding Records that Match All the Criteria 

Finding Records that Match Either One Criterion or Another 

Finding Records that Don't Match a Request 

Finding All Records 



Basic Sorts
Sorting rearranges records according to the entries in a field or a set of fields. FileMaker Pro stores 
records in the order you add them. You can sort all records or a group of found records and then 
browse, update, or print those records in the new sequence. The sort order instructs FileMaker Pro to 
arrange records in ascending, descending, or custom order. FileMaker Pro sorts by the first field in 
the sort order, then by the second, and so on.

You can sort records in any mode except Find.

To sort records:

1. Find the records you want to sort, or choose Find All from the Select menu to sort all records.

2. In any mode except Find, choose Sort from the Select menu. You see the Sort Records dialog box.

3. In the Field List, select the name of the field you want to sort by and click Move to put the field 
name in the Sort Order list.

4. Add any additional sort fields in the same way.

5. Click Sort.

See Also

Sorting on a Summary Field 

Custom Sorts 

International Sorts 

Changing the Sort Order 



Sorting on a Summary Field
You can include a summary field in your sort order. For example, in a summary report of sales, you 
could sort on a field named Sales Regions and on a summary field named Monthly Sales Totals to 
show the monthly sales totals for different sales regions.

To sort on a summary field:

1. In any mode except Find, choose Sort from the Select menu. You see the Sort Records dialog box.

2. Check Include Summary Fields in the Sort Order dialog box.

When a summary field is selected in the field list and moved to the Sort Order list, it is moved to 
the bottom of the sort order. Summary fields can't be sorted in a custom sort order.

3. In the Field List, select the name of the summary field you want to sort by and click Move to put the
field name in the Sort Order list.

4. Click Sort.

The sort order will be apparent when you preview or print a report. The data is first sorted by the 
criteria and then the summary sort is applied to the result. The summary fields become the highest
level of the sort.

If your data is already sorted appropriately for the summary report, you do not have to sort again 
when adding or removing summary fields in the sort order. You can add the summary field in the 
usual way and click Done.

To exclude summary fields from the sort, make sure that Include Summary Fields is deselected.

See Also

Basic Sorts 

Custom Sorts 

International Sorts 

Changing the Sort Order 



Custom Sorts
If a field uses a value list as a field entry option, you can sort records in custom order according to the
values you placed in the value list when you defined the field.

To sort records in custom order:

1. Find the records you want to sort, or choose Find All from the Select menu to sort all records.

2. From any mode except Find, choose Sort from the Select menu. You see the Sort Records dialog 
box.

3. Select a field in the Sort Order list, then click Custom Order.

4. Click Sort. FileMaker Pro sorts the records by the first value in the values list, then by the second 
value, and so on.

See Also

Basic Sorts 

International Sorts 

Changing the Sort Order



International Sorts
You can sort records based on the standards of another country.

To sort records by another country's standards:

1. Find the records you want to sort, or choose Find All from the Select menu to sort all records.

2. In any mode except Find, choose Sort from the Select menu. You see the Sort Records dialog box.

3. Choose the language whose sort order you want to use from the pop-up list.

4. Click Sort.

See Also

Basic Sorts 

Custom Sorts 

Changing the Sort Order



Changing the Sort Order
You can change the sort order of your records at any time.

To change the sort order:

1. Choose Sort from the Select menu. You see the Sort Records dialog box.

2. Make changes to the Sort Order list.

- To change the order of fields, use the double arrow next to the field name to drag a 
field to a new position in the list.

- To remove a field from the sort, select it and click Clear.

- To change if a field is sorted in ascending, descending, or custom order, click the field 
name, and click the order you want.

- To add fields to the Sort Order list, select the field in the Field List. Click Ascending, 
Descending, or Custom Order, and then click Move.

3. Click Sort.

To restore records to the original order, choose Sort from the Select menu and click Unsort in the 
Sort Records dialog box. Your records are restored to the order in which they were created.

See Also

Basic Sorts 

Custom Sorts 

International Sorts 



The following FileMaker Pro topics are available:

Using FileMaker Pro Help    

FileMaker Pro Overview 

Step-by-step instructions

Setting Preferences 

Managing Files    

Defining Fields and Entering Data 

Working with Layouts 

Finding and Sorting Information 

Using Scripts and Buttons 

Previewing and Printing    

Networking and Access Privileges 

Importing and Exporting Data 

Reference

Commands 

Screen Elements 

Keys 

Troubleshooting 

Customer Support 

About FileMaker Pro Help 



Using FileMaker Pro Help
Select these topics for information about getting help from FileMaker Pro and selecting topics in the 
Help window.

Selecting Help Topics in FileMaker Pro 

Finding Topics in the Help Window 

Returning to a Topic 

Using Hotspot Pictures 

For information on Windows Help features, including keeping the Help window on top of the 
application window, using bookmarks, and adding annotations, choose How to Use Help from the 
FileMaker Pro Help menu.



Selecting Help Topics in FileMaker Pro
In FileMaker Pro, you can get help on a specific command, status area, or control.

To get help on a specific command:

- select an active or dimmed command and press F1

- press Shift+F1 and select an active command with the question mark pointer

- select Quick Info from the Help menu and select an active command with the question 
mark pointer

If a command has a submenu, you can also use these methods to get help on specific submenu 
commands.

To get help on the status area and other controls, press Shift+F1 and click the question mark 
cursor on the status area or a control in any mode.



Finding Topics in the Help Window
You can find topics by starting with an overview of Help topics or by searching for topics associated 
with a specific word or phrase.

To see an overview of FileMaker Pro Help topics, click the Contents button in the Help window 
button bar, or type c to display the FileMaker Pro Help Contents topic. From there you can move to 
help topics on step-by-step procedures, commands, screen elements, and keyboard shortcuts.

To search for specific help topics:

1. In the Help window button bar, click the Search button or type s. You see the Search dialog box.

2. Select a word or phrase from the list or type the words you want to use for the search.

As you type, the list box scrolls to the words that most closely match what you type. 

3. Click the Show Topics button. 

4. Select a topic you want to view. If necessary, use the scroll bar to see more topics. 

5. Click the Go To button to jump to the selected topic.



Returning to a Topic
As you jump from topic to topic, you might want to return to a previously viewed topic.

- To return to the last topic you viewed, click the Back button or type b. 

- To return to the last topic in sequence, click the button with two left arrows.

- To return to any Help topic you viewed during the current Windows session, click the 
History button and double-click on a topic name.



Using Hot-Spot Pictures
You can click on some pictures in the FileMaker Pro Help file to jump to other topics or to display pop-
up boxes of explanatory text. Pictures with hot-spots always appear with a caption below or to the 
right of the picture.

For example, when you see this dialog box picture, you can click it to see a list of the options for a 
particular dialog box. (After clicking this picture, click the Back button to return to this topic.)

 
Create New File Dialog Box



Format Menu
Use Format menu commands to change the appearance of text and field entries. Commands are 
available based on the current mode and selection.

In Layout, all formatting changes apply to the current selection or to subsequent layouts if nothing is 
selected. In Browse, formatting changes apply to the current selection only and you can mix fonts, 
font sizes, and styles in a single field entry. Format menu commands are not available in Find or 
Preview.

Font 

Size 

Style 

Align Text 

Line Spacing    

Text Color 

Text Format... 

Number Format... 

Date Format... 

Time Format... 

Picture Format... 

Field Format... 

Field Borders... 

Use System Formats 



Font
Format Menu

Shows the fonts installed on your system. Fonts appear in alphabetical order in their native typeface. 
You can configure the Font menu to include only the fonts you want and to display all fonts in the 
system-specified typeface by choosing Configure/More Fonts from the Font menu.

 
Configure Font Menu Dialog Box

Change fonts for selected field text in Browse, and for selected layout text and fields in Layout. 
FileMaker Pro uses the default font if none is selected.

See Also

Adding Layout Text 

Customizing the Font Menu 



Configure Font Menu Dialog Box

Option Action

Available Fonts List all installed fonts on your computer. Click to select a 
font or Control-click to select multiple fonts to move to 
the Font menu.

Menu List all fonts in the Font menu. Click to select a font or 
Control-click to select multiple fonts to remove from the 
Font menu.

Clear All Remove all fonts from the Menu list and the Font menu

Move All Move all fonts listed in the Available Fonts list to the Font
menu

Clear Remove the selected font or fonts from the Menu list and
the Font menu

Move Move the selected font or fonts from the Available Fonts 
list to the Font menu

Show Fonts in Typeface Display all fonts in their native typeface in the Menu list 
and the Font menu

Apply Font Apply a font highlighted in the Configure Font Menu 
dialog box to the selected text on the layout



Size
Format Menu

The Size command submenu shows type sizes you can apply to selected field entry text in Browse, 
and to selected layout objects in Layout.

In addition to the sizes listed in the menu, you can add any font size to the bottom of the Size 
submenu by choosing Custom. 

 
Custom Size Dialog Box

See Also

Adding Layout Text 



Custom Size Dialog Box
Type the custom font size and click OK.



Style
Format Menu

The Style command submenu shows styles you can apply to selected field entry text in Browse, and 
to selected layout objects in Layout.

Select Plain Text, Bold, Italic, Underline, Word Underline, Double Underline, Condense, Extend, 
Strikeout, Small Caps, Uppercase, Lowercase, Title Case (capitalizes the first letter of each word), 
Superscript, or Subscript.

You can combine styles except superscript and subscript, underline variations (Underline, Word 
Underline, and Double Underline), and case variations (Uppercase, Lowercase, and Title Case.)

If you select text that has one or more styles, you can choose Plain Text from the Style submenu to 
remove all styles.

See Also

Adding Layout Text 



Align Text
Format Menu

The Align Text command submenu shows alignment styles you can apply to selected text and fields in
Layout.

- Left aligns objects by their left boundary.

- Center positions text in the middle of the field.

- Right aligns objects by their right boundary.

- Full aligns objects evenly with the left and right boundaries.

See Also

Adding Layout Text    



Line Spacing
Format Menu

Use the Line Spacing submenu commands to set the amount of space between lines. You can 
change line spacing for selected text and fields in Layout.

In addition to the sizes listed in the menu, you can choose Custom from the Line Spacing submenu to
add any line spacing value to the bottom of the submenu. 

 
Custom Line Spacing Dialog Box

See Also

Adding Layout Text      



Custom Line Spacing Dialog Box
Type a custom line spacing value and click OK.



Text Color
Format Menu

The Text Color command shows a palette of colors you can apply to selected text in Browse, and to 
selected layout objects in Layout . 

When you apply a color in Browse, it affects the current record only. When you apply a color in 
Layout, it affects the field in every record in the current layout.

The number of colors in the palette depends on the video mode, video driver software, and video 
memory configuration. For example, if you have a VGA system with 16 colors, the palette has 16 
colors. If you have a VGA system with 256 colors, the palette has 88 colors.

On a monochrome monitor, or when less than 16 colors are supported, the palette becomes a menu 
with the color names Black, Yellow, Magenta, Red, Cyan, Green, Blue, and White. 

See Also

Adding Layout Text 



Text Format...
Format Menu

Applies fonts, font sizes, styles, alignment, line spacing, and text color changes all at once to text and 
fields in Layout. The Text Format dialog box options are the same as the commands in the Font, Size,
Style, Alignment, Line Spacing, and Text Color submenus.

 
Text Format Dialog Box

See Also

Adding Layout Text 

Field Types 



Text Format Dialog Box

Option Action

Font Select a font from the pop-up list (a TrueType icon 
appears next to a TrueType font name, an ATM icon 
appears next to an Adobe Type1 font name, and a 
printer icon appears next to a font that resides in the 
printer. Screen fonts without matching printer fonts 
appear without an icon.)

Size Select a font size from the pop-up list or enter a font size
in the Custom Size dialog box 

Alignment Select an option from the pop-up list to position text 
within a field: left, center, right, or full

Line Spacing Select Single or Double from the pop-up list or choose 
Custom and enter a line spacing value in the Custom 
Line Spacing dialog box

Color Select a text color from the pop-up palette

Sample View an example of how text appears with the currently 
selected text format options

Style Click one or more styles as listed in the Style topic

Number Format...
Format Menu

Changes the way a number is displayed and printed in number and summary fields, and in calculation
fields with a numerical result. 

You can change the format for separators, Boolean numbers, decimal, percentage, and currency 
notation, and text formatting in the Number Format dialog box.

    
Number Format Dialog Box

From the Number Format dialog box, you can use the Decimal Options button to set decimal formats 
in the Decimal Options dialog box.

 
Decimal Options Dialog Box

From the Number Format dialog box, you can use the Text Format button to set text formats for your 
numbers in the Text Format dialog box.

 
Text Format Dialog Box

See Also

Adding Layout Text 

Field Types 



Number Format Dialog Box

Option Action

Leave data formatted as
entered

Click to leave numbers in their original format

Format as decimal 
number

Click to format as a decimal number and select decimal 
options:

Use thousands 
separator

Click to insert a comma in numbers of 1,000 or more

Notations: Click Percentage or Currency to display decimal numbers 
with percentage or currency notation

Fixed number of decimal
digits

Click and type the number of digits that you want to 
appear after the decimal point

Decimal Options... Click to set additional decimal specifications in the 
Decimal Options dialog box 

Format as Boolean Click to display numbers as Boolean values

Type the characters you want to use (such as 0 and 1 or 
True and False) in the Show Non-Zeroes As and Show 
Zeroes As boxes

Text Format... Click to open the Text Format dialog box and set font, font
size, style, and other text attributes for numerical entries

Sample View an example of numbers with the selected number 
format options



Decimal Options Dialog Box 

Option Action

Symbols Type the symbols you want to use in the Currency 
Symbol, Thousands Separator, and Decimal Point text 
boxes

The preset currency symbol comes from the Control 
Panel International settings

Negative Values Select a negative value format:    -, ( ), < >, or CR from 
the Format As pop-up list

To display negative values in color, click Use Color and 
select a color from the pop-up palette

Currency symbol 
position

Click Leading to place the currency symbol before the 
number, or Trailing to place it after

Date Format...
Format Menu

Changes the way a date is displayed and printed in date fields and calculation fields with a date 
result, and how the date symbol (//) appears in layout text. Set Date Format options in the Date 
Format dialog box.

      
Date Format Dialog Box

In the Date Format dialog box, you can select Custom from the Format As pop-up list, and set the 
format you want in the Custom Date Format dialog box.

 
Custom Date Format Dialog Box

In the Date Format dialog box, you can click the Text Format button to set text formats for dates in the
Text Format dialog box.

 
Text Format Dialog Box

See Also

Adding Layout Text 

Field Types 



Date Format Dialog Box

Option Action

Leave date formatted 
as entered

Click to leave dates in their original format

Format as: Click and select a date format from the list or select 
Custom to individually select words, numbers, and 
separators in the sequence you want from the Custom 
Date Format dialog box 

Separator character for 
numeric dates

Select the separator you want to use from the list: 
slashes (01/04/93), dashes (01-04-93), periods 
(01.04.93), or spaces (01 04 93)

Show day and month 
numbers with leading 
zeroes

Click to add a zero before single digit months and days; 
for example, January 4, 1993 would display as 01-04-93

Sample View an example of dates with the selected date and 
text format options

Text Format... Click to open the Text Format dialog box and set the 
font, font size, style, and other text attributes for date 
entries



Custom Date Format Dialog Box

Option Action

Lists Select words and separators from each list to position 
date elements

Sample View an example of custom dates with the selected date
and text format options

Time Format...
Format Menu

Changes the way times are displayed and printed in time fields and calculation fields with a time 
result, and how the time symbol (::) is displayed in layout text.

 
Time Format Dialog Box

By clicking the Text Format button, you can set text formats for your times in the Text Format dialog 
box.

 
Text Format Dialog Box

See Also

Adding Layout Text 

Field Types 



Time Format Dialog Box

Option Action

Leave data formatted 
as entered

Click to leave dates in their original format

Format as: Click and select a specific time format from the pop-up 
list

Unit separator Type the character you want to use to separate hours, 
minutes, and seconds

The default is a colon (:)

24 hour time with suffix Click and type AM or PM or other text (or nothing) in the 
box

12 hour time with suffix Click and type AM and PM or other text (or nothing) in 
the Before Noon and After Noon boxes

Text Format... Click to open the Text Format dialog box where you can 
set the font, font size, style, and other text attributes for 
time entries

Sample View times with the selected time and text format 
options

Picture Format...
Format Menu

Changes the way pictures are sized, aligned, and proportioned in picture/sound fields.

 
Picture Format Dialog Box

See Also

Adding Layout Pictures 

Field Types 



Picture Format Dialog Box

Option Action

... picture to fit frame Select an option from the pop-up list to specify how 
FileMaker Pro sizes pictures to fit in the field: Crop, 
Reduce, Enlarge, or Reduce or Enlarge to size the 
picture to fit the field

Maintain original 
proportions

If you select Reduce, Enlarge, or Reduce or Enlarge, 
you can click this option to scale the picture 
proportionally when it's resized

Alignment Select options from the alignment pop-up lists to specify 
how to position the picture in the field

Select Left, Center, or Right from the first alignment list 
to specify how to position the picture horizontally

Select Top, Center, or Bottom from the second alignment
list to specify how to position the picture vertically

Sample View examples of how pictures are sized and 
positioned--the left box shows the horizontal position 
and the right box shows the vertical position

Field Format...
Format Menu

For a selected field, sets how the value list is displayed, the number of repeating values that can be 
entered, and whether or not the field contents are selected when you move the insertion point to the 
field.

 
Field Format Dialog Box

Note: The value list and the number of repeating fields are set with the Define Fields  command.

See Also

Setting Up Fields 

Creating a New Field



Field Format Dialog Box

Option Action

Display standard field Click to format the field for a single value

Click Include Vertical Scroll Bar to include a scroll bar for
long field entries

Display <selector type> 
using field's value list

Select Pop-up List, Pop-up Menu, Check Boxes, or 
Radio Buttons to determine how you will select values 
for the field

Include "Other..." item Click to include an "Other" choice in the field's pop-up 
menu or list, check boxes, or radio buttons, which allows
you to type an entry not on the value list

Show <number> of 
field's <total number> 
defined repetitions

If the selected field is defined to have two or more 
repetitions, type the number of repetitions you want to 
display in the box

Use <vertical or 
horizontal> orientation

For a repeating field, select Vertical to display the entries
in a column or Horizontal to display them in a row

Select entire contents of 
field on entry

Click to select the field contents when you tab to the field

With the contents selected, you can type over the 
previous entry

Field Borders...
Format Menu

Sets field borders, baselines, and fill attributes to help visually separate fields. You can change the 
color, line width, and pattern of borders and field baselines, and the color and pattern of fills.

Once you define borders for a selected field, you can change the border color, pattern, and line width 
with the pen and line width controls in the Layout status area.

 
Field Borders Dialog Box

See Also

Setting Up Fields 

Creating a New Field

Working with Layouts 



Field Borders Dialog Box

Option Action

Field Borders Click the field edges where you want borders to appear: Top, 
Bottom, Left, and/or Right

Select Text Baselines to display the baseline of field text

Select Between Repeating Values if you want borders between 
these fields

... format: Select Borders, Baselines, or Fill from the pop-up list

Select a color for the border, baseline, or fill

Select a pattern for the border, baseline, or fill

Select a line width for the border or baseline

View a sample of the selected color, pattern, and line width

Sample View how the field will look with your selections

Use System Formats
Format Menu

Reformats a file's date, time, currency, and number formats if they are in another language.

Use System Formats appears in the Format menu if a file's formats don't match the country selected 
with Windows Control Panel International options.

See Also
Date Format... 

Time Format... 

Number Format... 



access privileges
Permission to view and work with certain layouts and fields and perform selected activities in a file.



body
A layout part that contains individual records from a file.



book
A status area tool you use to move from one record, layout, request, or page to another.



constant
A value you enter into a formula that doesn't change from record to record.



expression
A logical sequence of functions, values, constants, and operators that comprise a formula and return 
a single result. 



field baseline
The line that appears under the filed name and extends across the width of the window when you 
move a field.



field border
A border that visually separates one field from another.



field boundary
In Layout, an outline showing the size of a field. The field boundary doesn't appear in the other modes
or when you print the report unless the field is formatted with field borders.



field label
A layout text object that corresponds to a field name. FileMaker Pro automatically uses the field name
for the field label when you define a field, but you can edit or delete the field label as needed.



field name
The name you assign to a field when you define it.



field type
The part of a field definition that determines what kind of data you can enter in a field and the kinds of 
operations FileMaker Pro can perform with that data. 



field
The basic unit of data entry. Depending on its field type, a field can contain text, pictures, sounds, 
numbers, dates, times, or calculation or summary results.



find request
A blank facsimile record based on the current layout. You type or paste search criteria into appropriate
fields in a request and then find records based on those criteria.



found set
The set of records made active by a find request. When you find all records, the complete file is the 
current found set.



guest
The second or any subsequent user to open a file on a network.



host
The first user to open a file. Once opened by the host, other users (guests) can access and change 
the file. If the host opens the file on a network, all changes are saved to the host's hard disk.



invisible grid
A snap-to grid that automatically aligns new objects. The invisible grid differs from ruler lines, which 
can be viewed and are not snap-to. 



layout
A visual arrangement of fields, objects, pictures, and parts that represents the way information is 
organized and presented when you browse, preview, or print the records.



layout part
A section of a layout that organizes information.



lookup file
The file from which FileMaker Pro copies information when you specify a lookup field.



operators
Symbols that indicate how to combine two or more expressions. These include the standard 
arithmetic operators (+, -, /, *) and logical operators that set up conditions that must be met to make a 
value true or false (AND, OR, and NOT).



operands
Components of a formula. For example, in the formula Quantity * Price, Quantity and Price are the 
operands.



record
A collection of information stored in fields. Not all fields may be shown on each layout.



script
A series of steps that FileMaker Pro runs in a sequence. Scripts can be used to automate repetitive 
tasks such as generating routine reports and invoices.



search criteria
In Find, the values and operators you type into fields to find matching records. For example, if you 
type the word Eric Lindsay in the Vendor field, FileMaker would look for all records that have this 
name in the Vendor field. You can add search criteria by creating another find request.



sliding objects
Objects that slide together to close gaps left by entries in neighboring fields. 



sort order
The sequence FileMaker Pro uses to rearrange records. Records are sorted first by the first field in 
the sort order list, then by the second, and so on. Values within each field are sorted according to the 
order specified (ascending, descending, or custom).



stacking order
The order of overlapping layout objects. You can change this order by cutting and pasting objects or 
using the Send to Front, Send Forward, Send to Back, and Send Backward commands.



summary field
A field that contains the result of a summary calculation of values across a group of records.



tab order
The order in which you move from field to field in a record. You can change the order with the Tab 
Order command.



Help Menu
Use Help menu commands to access the FileMaker Pro Help file and get information on using 
FileMaker Pro.

Contents...
Displays the opening topic of the FileMaker Pro Help file. From this topic you can jump to step-by-
step instructions for performing FileMaker Pro operations or reference topics to learn about specific 
commands, screen elements, and keyboard equivalents.

Keys...
Displays a list of FileMaker Pro keyboard actions. From here, you can jump to topics covering 
different categories of keyboard actions. 

Quick Info
Displays the question mark pointer. With this pointer, you can click a command name or screen 
element to display a relevant help topic. 

How to Use Help...
Displays the Microsoft How to Use Help file. This file explains how to use the Windows help 
application. 

About FileMaker Pro...
Displays FileMaker Pro copyright, memory, version, system, and credits information.

You can click these buttons from the About FileMaker Pro screens:

- Info shows the FileMaker Pro version number, general system information, and your 
FileMaker Pro serial number

- Credits shows a list of the people on the FileMaker Pro team

- About shows copyright information

See Also

Using FileMaker Pro Help 



Importing and Exporting Data
Import text, picture, and sound data from other files to replace existing data or to add new records 
and field entries. You can import records from other FileMaker Pro files or files created in other 
applications by using Import/Export commands or a script. 

The data you import will be available when you open the file in either FileMaker Pro 2.0 for Windows 
or FileMaker Pro 2.0 for Macintosh. 

Export FileMaker Pro records in the field order you specify to create files that can be opened in other 
applications.

Importing Records 

Import/Export File Formats 

Importing Pictures 

Import Picture File Formats 

Importing QuickTime Movies 

Exporting Records to Other Applications 



Importing Records
You can import records from other FileMaker Pro 2.0 for Windows or FileMaker Pro 2.0 for Macintosh 
files or from files created in other applications.

To import records from a FileMaker Pro file or files from other applications:

1. Open the destination file. This is the file that will receive the imported records.

2. If necessary, choose Browse, Layout, or Preview with mode selector at the bottom of the screen.

3. Choose Import/Export in the File menu and Import Records from the submenu. You see the Import 
Records From File dialog box.

4. Select the file type of the source file from the List Files of Type list. See Import/Export File Formats
for a list of these files and their source applications.

5. Locate the source file in the files list and click OK. You see the Specify Field Order for Import 
dialog box.

6. The source file's fields map to the destination file's fields as shown in the list. You can drag the 
field names in the Fields In list to change where FileMaker Pro maps data. Click the Scan Data 
buttons to view data in the source file.

7. If the source file uses characters above ASCII 127, click to select the source platform or 
application: Windows (ANSI), DOS, Macintosh, or Lotus (LICS).

8. Click Add New Records to append the imported records to the end of the destination file or 
Replace Data in Current Found Set to overwrite any existing records with the imported records. 

9. Click OK.

See Also

Import Records... 

Import/Export File Formats 

Exporting Records to Other Applications 

Looking Up Data in Other Files 



Import/Export File Formats
You can import and export records between FileMaker Pro and these applications:

Application 
Type

Application 
Examples

Formats

Database dBASE III Plus, 
dBASE IV, FoxPro

*.DBF

Borland Reflex 2.0
Borland Paradox

Tab and comma separated text:
*.DBF, *.DIF, *.WKS

Symantec Q&A 4.0 Tab and comma separated text:
*.DBF, *.DIF

Object Vision *.DBF

Spreadsheet Lotus 1-2-3
Borland Quattro

*.WKS, *.WK1

Microsoft Excel *.SLK

Integrated Microsoft Works Tab and comma separated text 
(database):
*.WKS (spreadsheet)

AppleWorks *.DIF

Word 
processing

Microsoft Word and 
WordPerfect text 
files

Tab separated text:
*.TAB, *.TXT

Comma separated text:
*.CSV, *.TXT

Mail merge files:
*.MER

Programming Microsoft BASIC *.BAS

See Also

Importing Records 

Exporting Records to Other Applications 

Importing Pictures 

Importing QuickTime Movies 



Importing Pictures
You can import pictures from other applications into picture/sound fields. Pictures can be stored in 
both Macintosh (PICT) and Windows Metafile (WMF) formats (as set with the Preference command 
Document options) so they can be used in both the Windows and Macintosh versions of FileMaker 
Pro 2.0.

In addition, Encapsulated PostScript is saved with every EPSF picture.

To import a picture:

1. Open the file that will receive the imported picture.

2. In Browse, move to the appropriate field in the specific record.

3. Choose Import/Export from the File menu and Import Picture from the submenu.

4. Select a source file format from the Import File of Type list.

5. Locate the picture you want to import and click OK. 

6. If the picture is a .cgm, .drw, .pcx, .pic, or .plt file type, you see a dialog box that asks you how you 
want to import the file. Make the selections you want and click OK.

The imported picture is sized according to the formatting specified in the layout with the Picture 
Formats command.

Note: You can also use the Import Records command to import pictures from other FileMaker Pro 
files into picture fields.

Tip: If you don't expect to use a file with an imported picture in FileMaker Pro 2.0 for Macintosh, you 
can reduce the size of your database by deselecting Store Macintosh Picture Format in the Document
Preferences dialog box. With this option turned off, the picture will display and print as a rectangular 
boundary in FileMaker 2.0 on the Macintosh.

See Also

Document Preferences Options 

Import Picture... 

Import Picture File Formats 

Defining Fields and Entering Data 



Import Picture File Formats
You can import picture files into FileMaker Pro picture/sound fields in these formats:

Application or 
Standard

Format

ISO and ANSI *.cgm

Windows 3.x and 
IBM OS/2

*.bmp

Tagged Image File 
Format

*.tif

CompuServe *.gif

ZSoft Paintbrush *.pcx

Windows Metafile *.wmf

Micrografx Designer *.drw

Hewlett-Packard 
Graphics Language 
(HPGL)

*.plt

Lotus Picture (graph) *.pic

Autocad Slide *.sld

Macintosh PICT *.pct

MacPaint *.mac

Adobe PostScript *.eps

See Also

Importing Pictures 



Importing QuickTime Movies
You can import QuickTime for Windows movies into picture/sound fields. The movie in a 
picture/sound field is actually a reference to a QuickTime movie file. If you move the database to 
another computer, you should also move the movie file.

To import a QuickTime movie:

1. Open the file that you want the movie to be in.

2. In Browse, select the picture/sound field in the record you want to import to.

3. Choose Import/Export from the File menu and Import QuickTime from the submenu.

4. If necessary, select QuickTime Files (*.MOV) from the Import File of Type list.

5. Select the movie file you want to import and click OK. 

Use the controls on the movie playbar to play the QuickTime movie.

Note: You can also paste a QuickTime movie from the Clipboard into FileMaker Pro.

Important: To use a Macintosh QuickTime movie with FileMaker Pro for Windows, you must first use 
Movie Converter on the Macintosh to save the movie in a self-contained format playable on non-
Apple computers. 

To do this:

1. On the Macintosh, start Movie Converter.

2. Open the QuickTime movie you want to convert.

3. Choose Save As from the File menu.

4. In the Save As dialog box, give the converted movie a Windows-standard name.    The name can 
be up to eight characters plus the .MOV extension.

5. Click Make movie self-contained.

6. Click Make playable on non-Apple computers.

The first time you play a movie from the other platform (that is, a Macintosh movie on Windows or 
a Windows movie on the Macintosh), FileMaker Pro prompts you for the location of the movie.

See Also

Defining Fields and Entering Data 

Import QuickTime... 

Playing a QuickTime Movie 



Exporting Records to Other Applications
Export FileMaker Pro records to use them in other applications. When you export, FileMaker Pro 
makes a copy of the file with the format and name you select.

To export summary fields sorted by different fields, select just the summary fields you want so 
FileMaker Pro will know exactly which summary data to export.

To export records:

1. Open the file you want to export.

2. Choose Import/Export from the File menu and Export Records from the submenu. You see the 
Export Records dialog box.

3. Select a file format from the Export Files of Type list. These formats are listed in Import/Export File 
Formats. 

4. Type a name for the export file and specify the directory and disk where you want it saved.

5. Click OK. You see the Specify Field Order for Export dialog box.

6. To change the order of fields for exporting, drag the field names in the list.

7. To exclude fields from the export list, click the check mark next to field name.

8. If the destination file uses characters above ASCII 127, click to select the destination platform or 
application: Windows (ANSI), DOS, Macintosh or Lotus (LICS).

9. To export unformatted values, click Don't Format Output. To format the exported data with the 
number, date, and time format in the current layout, click Format Output Using Current Layout.

10. Click OK.

To export sub-summary field data that has been sorted by multiple fields:

1. Follow steps 1 through 5 above.

2. Select the summary field in the Specify Field Order for Export dialog box.

3. Click Summarize By and select the sub-summary fields you want to export. For example, if you've 
sorted by year and month, you can select either or both of these fields.

4. Click OK. The selected sub-summary choices appear in the list. 

5. In the Specify Field Order for Export dialog box, you can drag the sub-summary choices to 
different positions in the list, or click the check mark next to a field name to exclude it from the 
export.

6. Select any other export options. (See step 9 above.)

7. Click OK.

See Also

Export Records... 

Importing Records 

Import/Export File Formats 



Keys
You can choose FileMaker Pro commands and initiate other actions with keyboard shortcuts.

Layout Actions 

Browse Actions 

Text Formatting Actions 

Text Selection and Insertion Point Actions 

Window Actions 

File Actions 

Mode Selection Actions 

Define Fields Actions 

Edit Actions 

Other Actions 

Macintosh Key Equivalents 



Layout Actions
Use these keys in Layout.

Layout Action Keyboard Shortcut

Align Objects Ctrl+K

Align to Grid on/off Ctrl+Y

Alignment dialog box Ctrl+Shift+K

Bring Forward Ctrl+Shift+F

Constrain line tool to 
horizontal or vertical

Shift+Drag

Constrain movement to 
vertical or horizontal

Shift+Drag

Constrain oval tool to a 
circle

Alt+Drag

Constrain rectangle tool to a
square

Alt+Drag

Constrain resizing to vertical
or horizontal

Shift+Resize

Display object's format Double Click

Drag selected layout part 
past object

Alt+Drag

Duplicate selection Ctrl+D

Duplicate by dragging Alt+Drag

Group Ctrl+G

Lock Ctrl+H

Move selected object one 
pixel at a time

Arrow keys

Redefine a field in a layout Alt+Double-Click

Re-orient part labels Ctrl+Click part label

Reorder selected part Shift+Drag

Reset preset format based 
on the selected object

Ctrl+Click

Send Backward Ctrl+Shift+J

Square object being resized Alt+Resize

T-squares on/off Ctrl+T

Ungroup Ctrl+Shift+G

Unlock Ctrl+Shift+H



Browse Actions
Use these keys in Browse.

Browse Action Keyboard Shortcut

Find All Ctrl+J

Omit current 
record

Ctrl+M

Omit multiple 
records

Ctrl+Shift+M

Refind Ctrl+R

Text Formatting Actions
Use these keys in Layout or Browse.

Text Formatting 
Action

Mode Keyboard 
Shortcut

Align Center Layout Ctrl+\ 
Ctrl+Shift+C

Align Left Layout Ctrl+[

Ctrl+Shift+L

Align Right Layout Ctrl+]
Ctrl+Shift+R

Bold Layout, Browse Ctrl+Shift+B

Italic Layout, Browse Ctrl+Shift+I

Next point size 
down on menu

Layout, Browse Ctrl+,

Next point size up 
on menu

Layout, Browse Ctrl+.

Nonbreaking space Layout, Browse Ctrl+Space

One point larger Layout, Browse Ctrl+Shift+>

One point smaller Layout, Browse Ctrl+Shift+<

Plain Text Layout, Browse Ctrl+Shift+P

Underline Layout, Browse Ctrl+Shift+U



Text Selection and
Insertion Point Actions

Use these keys to select text in any mode and position the insertion point.

Text Selecting Action Keyboard Shortcut

Extend selection to end of line Shift+End

Extend selection to end of text Ctrl+Shift+End

Extend selection to next character Shift+Right Arrow

Extend selection to next line Shift+Down Arrow

Extend selection to previous 
character

Shift+Left Arrow

Extend selection to previous line Shift+Up Arrow

Extend selection to start of line Shift+Home

Extend selection to start of text Ctrl+Shift+Home

Extend selection to the end of the 
next word

Ctrl+Shift+Right 
Arrow

Extend selection to the start of 
previous word

Ctrl+Shift+Left Arrow

Move to next character Right Arrow

Move to next line Down Arrow

Move to previous character Left Arrow

Move to previous line Up Arrow

Move to the end of line End

Move to the end of text Ctrl+End

Move to the end of the next word Ctrl+Right Arrow

Move to the start of text Ctrl+Home

Move to the start of the line Home

Move to the start of the previous 
word

Ctrl+Left Arrow



Window Actions
Use these keys to arrange windows in any mode.

FileMaker Pro 
Window Action

Keyboard 
Shortcut

Cascade document 
windows

Shift+F5

Maximize window Ctrl+Shift+Z

Scroll document 
window down

PgDn

Scroll document 
window left

Ctrl+PgDn

Scroll document 
window right

Ctrl+PgUp

Scroll document 
window up

PgUp

Show/hide status 
area

Ctrl+Shift+S

Tile document 
windows

Shift+F4

Zoom document 
larger

F3

Zoom document 
smaller

Shift+F3

File Actions
Use these keys in any mode to manage files.

File Action Keyboard Shortcut

Cancel printing Esc

Close Ctrl+W
Ctrl+F4

Exit Alt+F4
Ctrl+Q

Open Ctrl+O

Open network file Ctrl+Shift+O

Print Ctrl+P

Print without 
displaying the 
dialog box

Ctrl+Shift+T



Mode Selection Actions
Use these keys at any time to select modes.

Select 
Action

Keyboard Shortcut

Browse Ctrl+B

Find Ctrl+F

Layout Ctrl+L

Preview Ctrl+U

Define Fields Actions
Use these keys to define fields in any mode.

Define Fields Action Keyboard Shortcut

Define Fields Ctrl+Shift+D

Within the Define 
Fields dialog box:

Calculation field Alt+C

Date field Alt+D

Number field Alt+N

Picture/sound field Alt+P

Summary field Alt+S

Text field Alt+T

Time field Alt+I

Edit Actions
Use these keys to edit field and layout text and to work with records and find requests.

Edit Action Mode Keyboard Shortcut

Clear All Del

Copy Browse, Find, Layout Ctrl+Ins
Ctrl+C

Copy found set Browse Ctrl+Shift+C

Cut All Shift+Del
Ctrl+X

Delete 
Record/Request/
Layout

Browse, Find, Layout Ctrl+E

Delete without 
confirmation

All Ctrl+Shift+E

Duplicate 
Record/Request/
Layout

Browse, Find, Layout Ctrl+D

Move to previous
record, request, 
or layout

Browse, Find, Layout Ctrl+UpArrow
Shift+PgUp



Move to previous
field

Browse, Find Shift+Tab

New 
Record/Request/
Layout

Browse, Find, Layout Ctrl+N

Next field Browse, Find Tab

Next record, 
request, or 
layout

Browse, Find, Layout Ctrl+Down Arrow,
Shift+PgDn

Paste In Browse with an 
appropriate field 
selected, pastes all 
Clipboard contents 
into the field

You can paste text 
and numbers into 
text and number 
fields, and pictures 
or sounds into 
picture/sound fields

In Layout, pastes the
selected object(s)

Shift+Ins
Ctrl+V

Paste Current 
Date

Browse, Find Ctrl+ -

Paste Current 
Time

Browse, Find Ctrl+;

Paste Current 
User Name

Browse, Find Ctrl+Shift+N

Paste From 
Index

Browse, Find Ctrl+I

Paste From Last 
Record

Browse, Find Ctrl+'

Paste From Last 
Record and 
move to next 
field

Browse, Find Ctrl+Shift+'

Paste text 
without style

All Ctrl+Shift+V

Paste bitmap 
when both 
bitmap and 
metafile formats 
are on the 
Clipboard

Browse, Layout Ctrl+Shift+V

Replace Browse Ctrl+=

Select All All Ctrl+A

Spell Word Browse, Find, Layout Ctrl+Shift+Y

Undo All Alt+Backspace
Ctrl+Z



Other Actions
Use these keys to move to records and fields, cancel an operation, or scroll a document window.

Action Mode Keyboard 
Shortcut

Cancel operation 
or dialog box, or 
switch to the 
status area book 
when nothing is 
selected

All Esc

Display layout 
pop-up menu

All F2

Help All F1 to display 
Help contents

Shift+F1 to 
select help on a 
specific 
command, 
status area, or 
program control

Play or edit a 
sound when in a 
sound field

Browse Spacebar

Sort Browse, Layout, 
Preview

Ctrl+S

Macintosh Key Equivalents
If you have been using FileMaker Pro on the Macintosh, you can use equivalents of Macintosh 
keyboard shortcuts for many operations. With these equivalents, the Ctrl key is used in place of the 
Macintosh Command key. 

Both Windows and Macintosh keyboard shortcuts are always available, but you can choose to add 
the Macintosh keyboard shortcuts to the FileMaker Pro menus.

Note: The keyboard shortcuts topics listed in See Also include both the Windows and Macintosh 
keyboard shortcuts.

To show Macintosh key equivalents in the menus:

1. Choose Preferences from the File menu.

2. Click General.

3. Click Show Macintosh Accelerators in Menus.

See Also
Layout Actions 

Browse Actions 

Text Formatting Actions 

Text Selection and Insertion Point Actions 

Window Actions 

File Actions 

Mode Selection Actions 



Define Fields Actions 

Edit Actions 

Other Actions 



Layout Menu
Use Layout menu commands along with the Layout status area tools to work with layouts. The Layout
menu is available only in Layout.

Align to Grid 

Ruler Lines 

Rulers 

T-Squares 

Size 

Sample Data 

Show 

Define Parts... 

Layout Options... 

Ruler Settings... 



Align to Grid
Layout Menu

Aligns new objects to the nearest intersection on an invisible grid. You can change the grid spacing 
and unit of measure with the Ruler Settings command, and you can temporarily turn off the grid by 
pressing the Ctrl key while dragging an object.

See Also

Ruler Settings... 

Arranging a Layout 



Ruler Lines
Layout Menu

Shows or hides a grid of ruler lines to help you align layout objects. The lines correspond to the unit of
measure on the horizontal and vertical rulers, and unlike the invisible grid, are not snap-to.

 
See Also

Ruler Settings... 

Arranging a Layout 



Rulers
Layout Menu

Shows or hides horizontal and vertical rulers. As you move the pointer or drag an object around a 
layout, dotted lines appear on each ruler to indicate your position.

You can change the unit of measure on the ruler by clicking the square where the two rulers meet or 
by using the Ruler Settings command.

See Also

Ruler Settings... 

Arranging a Layout 



T-Squares
Layout Menu

Shows or hides moveable, snap-to horizontal and vertical lines that you can use for positioning 
objects on a layout. Drag either line of the T-square to reposition it.

See Also

Arranging a Layout



Size
Layout Menu

Sets the exact position and size of the selected object or layout part. When the Size window is open, 
you can click the intersection of the T-square lines to check the T-square placement. 

As you work, the Size window stays open on your layout.

 
Size Window

See Also
Arranging a Layout 



Size Window

Option Action

Type a value to change the object's distance from the 
left edge of the layout

Type a value to change the object's distance from the 
top edge of the layout

Type a value to change the object's distance from the 
right edge of the layout

Type a value to change the object's distance from the 
bottom edge of the layout

Type a value to change the width of the object

Type a value to change the height of the object

Sample Data
Layout Menu

Shows or hides sample data in the layout so you can check field types and text formatting.

See Also
Working with Layouts 



Show
Layout Menu

Use Show submenu commands to specify how objects are displayed in Layout. The Show submenu 
contains these commands:

Buttons 

Text Boundaries 

Field Boundaries 

Sliding Objects 

Non-Printing Objects 

Non-Printable Area 

See Also

Working with Layouts 



Buttons
Layout Menu
Show Submenu

Shows or hides a gray border around pictures and text objects defined as buttons.

See Also

Working with Layouts 



Text Boundaries
Layout Menu
Show Submenu

Shows or hides the boundaries around text objects to help you align layout text with other objects. 
These boundaries do not appear when you browse, preview, or print records.

See Also

Working with Layouts 



Field Boundaries
Layout Menu
Show Submenu

Shows or hides field boundaries and field baselines to help you line up fields with other objects. 
These boundaries do not appear when you browse, preview, or print records.

See Also
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Sliding Objects
Layout Menu
Show Submenu

Shows or hides arrows that identify sliding objects and the sliding direction.

See Also

Slide Objects 
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Non-Printing Objects
Layout Menu
Show Submenu

Shows or hides the boundaries of non-printing objects defined in the Slide Objects dialog box.

See Also

Working with Layouts 

Closing Up Space for Printing 



Non-Printable Area
Layout Menu
Show Submenu

Shows or hides the non-printing page margin areas.

See Also

Working with Layouts 



Define Parts...
Layout Menu

Creates, defines, reorders, and deletes layout parts in the current layout.

You define, reorder, or delete available parts in the Define Parts dialog box.

 
Define Parts Dialog Box

You can add or change a layout part in the Part Definition dialog box. You see this dialog box when 
you:

- click Create or Change in the Define Parts dialog box 

- drag a part from the Part tool onto the layout

- double-click an existing part label

 
Part Definition Dialog Box

See Also

Working with Layout Parts 

Working with Summary Parts 



Define Parts Dialog Box

Option Action

List Drag a part to a new location in the list or select a part to
change its definition

Create Click to add a new part in the Part Definition dialog box 
which shows the layout parts still available

Change Click to change the selected part into any other available
part type listed in the Part Definition dialog box 

Delete Click to delete the selected part

Done Click when you finish defining parts

Part Definition Dialog Box

Option Action

Title Header Click to create a part that appears at the top of the first 
page

Header Click to create a part that appears at the top of every 
page

Leading Grand 
Summary

Click to create summary of all the values in a summary 
field for all records begin browsed 

Shows summary data if it contains a summary field, or 
field data from the first record in the report if it contains a
regular field

The leading grand summary appear above the body

Body Click to create a part that contains a record 

Sub-summary when 
sorted by:

Click to create a part that displays a summary of the field
you select in the list

Trailing Grand Summary Click to create a part that displays a summary of records
between the footer and body. 

Shows summary data if it contains a summary field, or 
field data from the first record in the report if it contains a
regular field

Footer Click to create a part that appears at the bottom of every
page

Title Footer Click to create a part that appears at the bottom of the 
first page

Fields list Select a field if you have clicked Sub-Summary When 
Sorted By

Page break before each 
occurrence

For leading sub-summary, body, trailing sub-summary, 
and trailing grand summary parts:

Click to start a new page before printing the contents of 
the part

Page break after every 
<value> occurrences

For leading grand summary, leading sub-summary, body,
trailing sub-summary, and trailing grand summary parts:

Click to start a new page after printing the contents of 
the specified occurrences of the part

Restart page numbers 
after each occurrence

For title header, header, leading grand summary, leading
sub-summary, body, trailing sub-summary, footer parts:

Click to restart page numbering from the beginning after 
printing the part

Allow part to break For leading grand summary, leading sub-summary, body,



across page boundaries trailing sub-summary, and trailing grand summary parts:

Print the entire contents of the part even if it doesn't fit 
on one page (for example, divide and print the body 
across two pages if it doesn't fit on a single page with 
the other parts)

Discard remainder of 
part before new page

For leading grand summary, leading sub-summary, body,
trailing sub-summary, and trailing grand summary parts:

Print as much of the contents of a part as can fit on the 
page

Layout Options...
Layout Menu

Renames a layout and sets the number of records that print across a page and whether they will be 
displayed in rows or columns.

Select layout options in the Layout Options dialog box.

 
Layout Options Dialog Box

From the Layout Options dialog box, click the Reorder button to display the Reorder dialog box. From 
this dialog box, you change the order of layout names in the layout pop-up menu in the status area.

 
Reorder Layouts Dialog Box

See Also
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Layout Options Dialog Box

Option Action

Name Type a name to rename the current layout

Display in <number> 
columns

Type a number to specify how many records will print 
across the page

Across first Click to print labels in rows across the page

Down first Click to print labels in columns down the page

Reorder... Click to change the order of layout names in the layout 
pop-up menu

Make changes in the Reorder Layouts dialog box



Reorder Layouts Dialog Box
Drag the layout names to a different position in the list. The layout names appear in the new order when you next click the layout 
pop-up menu in the status area.



Ruler Settings...
Layout Menu

Sets ruler and invisible grid measurement units. You can display the Ruler Setting dialog box by 
choosing the Ruler Settings command or change the ruler unit of measure by clicking the corner 
where the horizontal and vertical rulers meet.

    
Ruler Settings Dialog Box

See Also

Rulers 



Ruler Settings Dialog Box

Option Action

Units Select a ruler measurement unit (inches, centimeters, or 
pixels)

Grid Spacing Type a value to set the grid size and select a grid unit of 
measurement (Inches, Centimeters, or Pixels) from the 
pop-up list

Grid spacing affects the invisible grid used by the Align 
to Grid command



 Working with Layouts
You can change how you arrange and format your data by using different formats called layouts. Each
layout can display some or all of the fields in your file, and you can apply more than one layout to a 
database file. 

You can edit a layout or a select a different layout without affecting your data.

Using Layout Mode 

Creating, Duplicating, and Deleting Layouts 

Working with Layout Parts 

Working with Summary Parts 

Arranging a Layout 

Adding and Deleting Fields 

Formatting Fields 

Adding Layout Text 

Customizing the Font Menu 

Adding Layout Pictures 

Changing the Tab Order 

Closing Up Space for Printing 

Selecting a Layout 

Reordering the Layout Pop-Up Menu 



Using Layout Mode
In Layout, you create and customize layouts with Layout status area tools and with Layout, Edit, 
Format, and other menu commands. In Layout, you work with objects instead of field data or find 
requests.

To switch to Layout, select Layout with the mode selector at the bottom of your screen or choose 
Layout from the Select menu. 

You can use or modify the FileMaker Pro predefined layouts or design your own. Layouts consist of 
the following elements:

- parts to organize information into special purpose areas (You can include header, 
footer, body, and summary parts. Every layout includes at least one part.)

- fields to enter and display data

- layout text for titles, column headings, field labels, instructions, and form letters

- pictures (such as logos or other design elements) that appear in every record

See Also

Layout Status Area 

Working with Layout Parts 

Working with Summary Parts 

Arranging a Layout 



Creating, Duplicating, and Deleting Layouts
You can select a predefined layout, create a custom layout, duplicate an existing layout, rename a 
layout, and delete layouts you don't need.

Before you follow these procedures, choose Layout with the mode selector at the bottom of the 
screen.

To select a predefined layout:

1. Choose New Layout from the Edit menu. You see the New Layout dialog box.

2. Type a name for the layout in the Name box.

3. Select a layout type: Standard, Columnar Report, Extended Columnar Report, Single Page Form, 
Labels, Envelopes, or Blank.

4. Click OK. 

5. If you selected Columnar Report, Extended Columnar Report, or Envelope, you see the Set Field 
Order dialog box. Specify fields for this layout by selecting each field from the Field List and 
clicking Move.

If you select Labels, you see the Label Setup dialog box. To set up standard Avery labels, click 
Use Label Measurements For and select an Avery label size from the pop-up list. To set up a 
custom-sized label, click Use Custom Measurements and enter values in the Labels Across the 
Page, Width, and Height boxes.

Note: You can also set up columns for labels by choosing Layout Options from the Layout menu.

To duplicate a layout:

1. Choose the layout from the pop-up list at the top of the status area.

2. Choose Duplicate Layout from the Edit menu.

To customize a layout, follow the steps for duplicating a layout. You can then change the layout as 
explained in the topics listed in the See Also section.

To rename a layout:

1. Select the layout you want to rename from the layout pop-up menu at the top of the status area.

2. Choose Layout Options from the Layout menu.

3. Type a new name in the Name box.

4. Click OK.

To delete a layout:

1. Select the layout you want to delete from the layout pop-up menu at the top of the status area.

2. Choose Delete Layout from the Edit menu. You see a message asking if you want to delete the 
layout.

3. Click Delete.

Note: Deleting a layout does not erase the data in your records. 

See Also

Using Layout Mode 

Working with Layout Parts 



Arranging a Layout 
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Working with Layout Parts
Use layout parts to organize data on the page or to summarize data within the document. All layouts 
must have at least one part. You decide which fields, field labels, and objects to place in each part 
based on where you want them to appear.

You can add, change, and delete parts in any layout. 

Before you follow these procedures, choose Layout with the mode selector at the bottom of the 
screen and select the layout you want to change from the Layout pop-up menu.

To add a part:

1. Choose Define Parts from the Layout menu.

2. In the Define Parts dialog box, click Create. You see the Part Definition dialog box.

3. Select the part you want to add. For descriptions of layout parts, see Part Definition Dialog Box. 

Note: Parts that are already used in the current layout appear dimmed. 

4. Click OK.

5. Click Done.

You can also add a part by dragging from the Part tool to the layout and selecting a part type in the 
Part Definition dialog box.

To change a part:

1. Choose Define Parts from the Layout menu.

2. Select the part you want to change.

3. Click Change.

4. Select an available part from the list.

5. Click OK.

6. Click Done.

To delete a part, click to select the part label and press Delete, or select the part in the Define Parts 
dialog box and click the Delete button. Each layout must have at least one part, so you can delete all 
parts except the last one.

When you delete a part, you delete all the objects it contains. If the part contains fields, deleting the 
part deletes that copy of the field, but not the field itself.

See Also

Using Layout Mode 
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Working with Summary Parts
Use summary parts to view information calculated from one or more records in a summary field.

Before you follow these procedures, choose Layout with the mode selector at the bottom of the 
screen and select the layout you want to change from the Layout pop-up menu.

To add a summary part:

1. Choose Define Parts from the Layout menu.

2. Click Create.

3. In the Part Definition dialog box, click a summary option. If you choose Sub-Summary When 
Sorted By, select the field you will sort by. (To get the correct summary information, be sure to sort 
the records according to the field you select.)

For descriptions of summary parts, see Part Definition Dialog Box.

4. Click OK.

5. Click Done.

6. Place summary fields and other objects in the summary part.

See Also
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Working with Layout Parts 

Arranging a Layout 

Adding and Deleting Fields 



Arranging a Layout
When customizing a layout, you can reposition fields, field labels, and objects and resize and reorder 
parts.

To work with a layout, choose Layout with the mode selector at the bottom of the screen and select a 
layout from the Layout pop-up menu.

Moving and positioning objects
You can move fields and objects to reposition them on your layout.

- To move a field, field label, or other object, click and drag the object with the pointer.

- To move multiple objects at one time, press the Shift key while you select each object. 

- To move objects as a group, select multiple objects and then choose Group from the 
Arrange menu.

To arrange objects with precision, use the Rulers, Ruler Lines, T-squares, Size, Alignment, and Align 
Objects commands.

- Choose Rulers from the Layout menu to display or hide rulers at the top and left edge 
of the layout.

- Choose Ruler Lines from the Layout menu to display or hide non-printing ruler lines as 
a dotted grid that corresponds to the ruler settings.

- Choose T-squares from the Layout menu to display or hide T-square lines. You can 
move each T-square line independently by dragging it with the pointer.

- Choose Size from the Layout menu to position selected objects precisely. Type 
measurements for the placement distance from the left edge and top of the page in the 
first two boxes. You can also check the positioning of an object as you drag it by 
keeping the Size dialog box open.

- Choose Alignment from the Arrange menu to specify how you want to arrange objects 
when you align them (left to right and top to bottom). Once you've made these settings, 
you can use the Align Objects command in the Arrange menu to align selected objects 
to these specifications.

Reordering and resizing layout parts
Change the order of layout parts by choosing Define Parts from the Layout menu and dragging part 
names to different positions in the list. Parts that can't be reordered appear with a lock.

Resize a part by dragging the part label or dotted line that extends from the part label. To drag over 
on object, press Alt while dragging.

See Also
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Adding and Deleting Fields
You can choose to use some or all fields in a layout, include multiple copies of a field, or delete fields.

To add a field, you must first define it with the Define Fields command in the Select menu.

Before you follow these procedures, choose Layout with the mode selector at the bottom of the 
screen and select the layout you want to change from the Layout pop-up menu.

To add a copy of the field to the layout:

1. Drag a field from the Field tool in the status area to a position in the layout. As you drag, the field's 
baseline appears to help you align the field.

When you release the mouse button, you see the New Field dialog box with a list of all defined 
fields in your file.

2. Select a field name from the list. You can select a field that already appears in the layout to include
multiple copies of the field.

3. Click OK.

To delete a copy of the field from a layout, select the field and press Delete. 

See Also
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Formatting Fields
You can format fields by adding borders, text baselines, and a fill pattern. You can also change how 
you enter data in a field by adding scroll bars or repeating values, specifying that the field contents 
are selected when you move to the field, or displaying a value list (a list of entry choices) as check 
boxes, radio buttons, or a pop-up menu or list.

Before you follow these procedures, choose Layout with the mode selector at the bottom of the 
screen and select the layout you want to change from the Layout pop-up menu.

To add borders, text baselines, or a fill pattern:

1. Select the fields you want to format and choose Field Borders from the Format menu.

2. From the pop-up list in the Field Borders dialog box, choose Borders, Baselines, or Fill. 

3. If you select Borders, click the borders you want: Top, Bottom, Left, Right, and Between Repeating
Values. If you select Baselines, click Text Baselines.

4. Select the color, pattern, or line width from the pop-up menus:

to choose a color

to choose a pattern

to choose a line width

5. Click OK.

To change how you display and enter data:

1. Select a field in your layout.

2. Choose Field Format from the Format menu. You see the Field Format dialog box.

3. Click a field format option.

To: You can:

Work with text entries that are 
sometimes larger than the field

Add a scroll bar by clicking Include Vertical Scroll Bar

Use check boxes, radio buttons, 
or a pop-up menu or list to select
values

Click Display <option> and select the option you want 
from the Using Field's Value List pop-up list

Select the "Other" Item if you want to be able to enter a 
value other than the ones in the list

Include multiple values for a field Type the number of repetitions you want in Show 
<value> of Field's <n> Defined Repetitions and select an
orientation for the values

(You set the number of times a field can repeat in the 
Entry Options dialog box)

Select the field contents each 
time you tab to the field in 
Browse 

Click Select Entire Contents of Field on Entry

4. Click OK.



See Also
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Adding Layout Text
In addition to fields and field labels, you can add text to a layout for titles, instructions, page or record 
numbers, or other text related to your records. Using Format commands, you can change the font, 
font size, style, alignment, line spacing, and color of layout text.

Before you follow these procedures, choose Layout with the mode selector at the bottom of the 
screen and select the layout you want to change from the Layout pop-up menu.

To type layout text:

1. Click the text tool  in the tool palette.

2. Click where you want to add text or drag to add a bounding box.
3. Type the text. 

To format layout text:

1. Select the text you want to change. Or to change the format for subsequently typed text, click in 
the layout to deselect all objects.

2. Choose commands from the Font, Size, Style, Align Text, Line Spacing, and Text Color submenus 
in the Format menu. 

To change all formats at once: Choose Text Format from the Format menu and select the options 
you want in the Text Format dialog box.

See Also
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Customizing the Font Menu
When you first run FileMaker Pro, you see all of your installed fonts in their native typefaces in the 
Font menu. You can configure the Font menu to include only the fonts you want and to display all 
fonts in the typeface used on the other FileMaker Pro menus.

To configure the Font menu:

1. In Layout or Browse, choose Font from the Format menu and Configure/More Fonts from the 
submenu. You see the Configure Font Menu dialog box.

2. Make the changes you want according to the following table.

To: Do this:

Remove a font from the Font menu Select the font in the Menu list and click 
Clear (or double-click the font). Shift-click 
to select more than one font.

Remove all fonts from the Font 
menu

Click Clear All

Add a font to the Font menu Select a font in the Available Fonts list and
click Move (or double-click the font). Shift-
click to select more than one font.

Add all available fonts to the Font 
menu

Click Move All

Display fonts in the Font menu and
the Menu list in their native 
typefaces

Click Show Fonts in Typeface

Apply a font to the current selection Select a font from either the Available 
Fonts list or the Menu list and click Apply 
Font. (This automatically closes the 
Configure Font Menu dialog box.)

3. When you finish, click OK.

See Also
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Adding Layout Pictures
In addition to the pictures you include in picture/sound fields, you can add pictures to a layout that 
appear in every record as part of the design.

You can add picture objects by using the Import Picture command, pasting them from the Clipboard, 
or designing them with the FileMaker Pro drawing tools. Once you add a picture object, you can move
or resize it as needed.

Before you follow these procedures, choose Layout with the mode selector at the bottom of the 
screen and select the layout you want to change from the Layout pop-up menu.

To import a picture:

1. Choose Import/Export from the File menu and Import Picture from the submenu. You see the 
Import Picture dialog box.

2. Select the file you want to import. If necessary, scroll through the list, or change the directory or 
drive to find the file you want. You can import any picture in 
the .cgm, .bmp, .tif, .gif, .pcx, .wmf, .drw, .plt, .pic, .sld, .pct, .mac, or .eps format.

3. Click OK. For some file format types, you see a dialog box with options for customizing the picture 
for importing.

4. Select the options you want and click OK.

To paste a picture from the Clipboard:

1. Copy the picture you want to paste from FileMaker Pro or another Windows application. 

2. Open the FileMaker Pro file where you want to paste the picture and select a layout. 

3. Choose Paste from the Edit menu and drag the picture to the position you want.

Note: The Windows Clipboard may contain pictures in both a bitmap and metafile format. To paste
the picture in metafile format, choose Paste. To paste the picture in bitmap format, press Shift and 
choose Paste. 

To draw picture objects with FileMaker Pro tools:

Use the tools in the Layout status area to draw picture objects in FileMaker Pro.

To draw a: Select: And then click to:

Line Start the line and drag to where you want the 
line to end

To constrain the line to a 45-degree angle, 
press Alt as you drag

Rectangle 
or rounded 
rectangle

Start a corner and drag diagonally until the 
rectangle is the shape you want

To create a square, hold down Alt as you drag

Circle or 
oval

Place the edge of the oval and drag in any 
direction until the oval is the size you want

To create a circle, press Alt as you drag

The colors and patterns you choose with the fill and pen controls apply to selected objects. If nothing 
is selected, the colors and patterns apply to subsequently created objects.

You select colors and patterns for the fill (background) and the pen (lines and borders) separately. 
The sample box to the left of the fill and pen icons shows the current selections.



To set the fill or pen: Select:

Color
A color from 

Fill pattern
A pattern from 

To move a picture object, click and drag it with the pointer tool .

See Also
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Changing the Tab Order
You can change the order in which you use the Tab key to move from field to field, or you can leave 
fields out of the tab order. If you leave the tab order unchanged, FileMaker Pro moves through fields 
from left to right and top to bottom.

Before you follow these procedures, choose Layout with the mode selector at the bottom of the 
screen and select the layout you want to change from the Layout pop-up menu.

To change the tab order:

1. Choose Tab Order from the Arrange menu. You see the Tab Order dialog box.

2. Click Create New Tab Order.

3. Click the arrows in the order you want.

4. Click OK. 

To leave fields out of the tab order:

1. Follow the steps above.

2. Click the arrows in the order you want, skipping the fields you want to leave out.

3. Click OK.

4. Click Omit to confirm that you are skipping fields.

Note: When you're entering data, you can still get to an omitted field by clicking in it.

See Also
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Closing Up Space for Printing
When you print, extra space appears between fields if the field size is larger than the data and extra 
space might appear between fields and objects. You can eliminate this space and move adjacent 
fields closer by sliding objects.

Before you follow this procedure, choose Layout with the mode selector at the bottom of the screen 
and select the layout you want to change from the Layout pop-up menu.

To slide objects:

1. Select the objects you want to slide. To select multiple objects to slide in the same direction, press 
Shift and click to select each object.

2. Choose Slide Objects from the Arrange menu. You see the Slide Objects dialog box.

3. Select sliding options:

- To close up space to the right of an object and slide objects left into the unused space, 
click Sliding Left.

- To close up space above an object based on the position of all objects above it (for 
example, to maintain consistent spacing in columns), click Sliding Up Based on All 
Above. 

- To close up space above an object based on the position of objects directly above it 
(for example, to adjust space in a column independently of other columns), click Sliding
Up Based on Only Directly Above.

- To reduce the size of the layout part relative to all objects that are sliding up, click Also 
Reduce the Size of the Enclosing Part. 

4. Click OK.

See Also 
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Selecting a Layout
To select a layout:

- In any mode, use the pop-up menu at the top of the status area.

- In Layout, flip through the pages of the book in the Layout status area 

See Also
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Reordering the Layout Pop-up Menu
You can change the order of names in the Layout pop-up menu. This is useful if you want to place the
layouts you use most at the top of the menu or if you want to list layouts in alphabetical order.

Before you follow this procedure, choose Layout with the mode selector at the bottom of the screen.

To reorder the layout pop-up menu:

1. Choose Layout Options from the Layout menu. You see the Layout Options dialog box.

2. Click Reorder. You see the Reorder Layouts dialog box.

3. Drag the names into the order you want and click OK to return to the Layout Options dialog box.

4. Click OK.

See Also
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Managing Files
These topics explain the basics about how to create, open, and save files.

Creating a New File 

Opening Existing Files 

Saving Files 



Creating a New File
Open a new file to start a FileMaker Pro database. You can create a new file when you open 
FileMaker Pro or after you begin working. Once you name the new file, the Define Fields dialog box 
appears so you can begin setting up fields for your database.

To create a new file when you start FileMaker Pro:

1. Start FileMaker Pro from the Windows Program Manager or File Manager. You see the Open File 
dialog box.

2. Select a drive for the file from the Drives list box and a directory for saving the file in the Directories
list box.

3. Type a name for the new file in the File Name box. The name can be up to eight characters long. 
(FileMaker Pro adds an .fm extension to the name.)

4. Click New.

To create a new file once you begin working:

1. Choose New from the File menu. You see the Create New File dialog box.

2. Select a drive for the file from the Drives list box and a directory for saving the file in the Directories
list box.

3. Type a name for the new file in the File Name box.

4. Click OK.

See Also
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Opening Existing Files
You can open FileMaker Pro 2.1 for Windows and FileMaker Pro 2.1 for Macintosh files from a disk on
your computer or from a network. Some files are protected by a password, and you need to enter the 
password to open the file.

Note: Files created in versions of FileMaker Pro for Macintosh prior to 2.0 can't be opened in 
FileMaker 2.1 for Windows without being converted. If you want to use a file from an earlier Macintosh
version, open it in FileMaker 2.0 or higher for Macintosh to convert it before opening it in FileMaker 
Pro 2.1 for Windows.

To open a file from a disk on your computer:

1. Choose Open from the File menu. You see the Open File dialog box.

2. Select the drive for the file from the Drives list box and the directory from the Directories list box.

3. Select the filename from the File Name list box.

4. Click OK.

To open a file from the network:

1. Make sure the file host has opened the file and made it available on the network with the Multi-
User command in the File menu.

2. Choose Open from the File menu. You see the Open File dialog box.

3. Click Hosts. You see the Hosts dialog box, with or without zones, depending on the type of network
you're using.

4. Select a file.

5. Click OK.

To open a password-protected file:

1. Choose Open from the File menu and open the file from your own disk or the network. If the file is 
password-protected, you see the Password dialog box.

2. Type the password in the Password box.

3. Click OK.

See Also
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Saving Files
FileMaker Pro automatically saves changes to your file while you work. You can also save a copy of 
the file with a different name in any of these copy formats:

- Copy of Current File creates an exact duplicate of the file.

- Compressed Copy (smaller) creates a copy of the file that takes up less space on a 
disk. This option is useful for making archive copies.

- Clone (no records) creates a copy of the file that contains the same field definitions, 
layouts, scripts, and print setup options as the original, but no data.

To save a copy of the file:

1. Choose Save a Copy As from the File menu. You see the Save a Copy dialog box.

2. Choose a format from the Save A pop-up list.

3. Select a drive for the file from the Drives list box and a directory for the file from the Directories list 
box.

4. Type a different name in the File Name box.

5. Click Save.

See Also
Opening Existing Files 



Networking and Access Privileges
If you're connected to a computer network, you can share FileMaker Pro files with other network 
users. 

This network Enables this type of file sharing

AppleTalk (Farallon Timbuktu, PhoneNET PC 3.0, 
PhoneNET Talk 2.0x, or AppleTalk Connection for 
DOS and Windows)

PC and Macintosh users can share files on the network 
from both FileMaker Pro 2.1 for Windows and FileMaker 
Pro 2.1 for Macintosh

IPX/SPX (Novell NetWare, NetWare Lite) PC users can share files on the network from FileMaker 
Pro 2.1 for Windows. (To share files with Macintosh 
users, install Farallon Timbuktu, PhoneNET PC 3.0, or 
AppleTalk Connection for DOS and Windows, or have 
the Macintosh users install MacIPX.)

NetBIOS (Microsoft LAN Manager, Artisoft LANtastic
for Windows, Banyan VINES, Microsoft Windows for 
Workgroups)

PC users can share files on the network from FileMaker 
Pro 2.1 for Windows.

For files shared on a network or used on a single computer, you can set up access privileges to 
determine who can open a file, what fields and layouts they can see, and which activities they can 
perform. These privileges are controlled by groups and passwords you define and assign. Access 
privileges are useful for controlling access to sensitive data in a file, whether or not the file is shared 
on a network.

If you are the first person to open a file, you are the host. Co-workers who open the file after you are 
guests. The host and guests assume different responsibilities when sharing a file.

Defining Passwords 

Defining Groups 

Setting Access Privileges for a Group 

Sharing Files Across a Network 

Working with Files as a Host 

Working with Files as a Guest 



Defining Passwords
Define passwords to control access privileges for a file. 

When associated with an access group on a network, a password limits which files a group can open 
and which layouts and fields in each file the group can access.

To create a password:

1. Open the file you want to define a password for.

2. Choose Access Privileges from the File menu and Define Passwords from the submenu. You see 
the Define Passwords dialog box.

3. Type the password in the Password box.

4. Select the privileges you want to associate with the password. When you create a password with 
limited access, you must also create a password that grants access to the entire file.

5. Click Create.

6. Click Done. FileMaker Pro asks you to type a password that grants access to the entire file and 
click OK.

To limit access without using a password:

You can limit access for users without a password by creating a blank password. Follow the steps for 
creating a password, but leave the Password box blank. When a user opens the file by pressing Enter
instead of typing a password, access is limited to the privileges you select.

To change the password if you have limited access to the file:

1. Choose Change Password from the File menu. You see the Change Password dialog box.

Note: The Change Password command appears in the File menu only if you have limited access. 
If you have complete access, the Access Privileges command appears instead.

2. Type the current password in the Old Password box and then type the new password in the New 
Password box.

3. Type the new password in the Confirm New Password dialog box and click OK.

Note: If you use a password to open the file as a guest and then change the password, you 
change the password for the file. All users must now use the new password.

To associate the password with an access group:

1. Choose Access Privileges from the File menu and Overview from the submenu. You see the 
Access Privileges dialog box. 

2 Select a group name.

3. Click the bullet in front of each password you want to associate with the group.

4. Click Done.

Note: A password defined to access the entire file can't be disassociated from a group.

To delete a password:

1. Choose Access Privileges in the File menu and Define Passwords from the submenu. You see the 
Define Password dialog box.

2. Select the password you want to delete.

3. Click Delete.



4. When asked to confirm the deletion, click Delete.

5. Click Done.

See Also

Defining Groups 

Setting Access Privileges for a Group 

Sharing Files Across a Network 



Defining Groups
By defining groups of users, you can keep track of who has access to specific layouts and fields. 
When you assign a password to the group, you limit the group's activities within the file.

To work with restricted files, each user in a group must know the passwords that permit access to 
these files.

To define a group:

1. Open the file you want to define groups for.

2. Make sure the Single-User command appears in the File menu. If Multi-User appears, choose it to 
switch to Single-User, or make sure all guests have closed the file.

3. Choose Access Privileges from the File menu and Define Groups from the submenu. The Define 
Groups dialog box appears.

4. Type a name for the group in the Group Name box.

5. Click Create.

You can select passwords, fields, and layouts for the group in the Overview dialog box by clicking 
Access, or create new passwords by clicking Passwords.

See Also

Setting Access Privileges for a Group 

Defining Passwords 



Setting Access Privileges for a Group
Set access privileges for a group by associating passwords with the group name. A password 
associated with a group defines what kind of work each user in the group can do with layouts and 
fields.

To set access privileges for a group:

1. Choose Access Privileges from the File menu and Overview from the submenu. The Access 
Privileges dialog box appears. 

Note: You can also open this dialog box by using the Access button in the Define Groups or Define
Passwords dialog box.

2. In the Groups list, click the group name. 

3. In the Passwords list, click the bullet next to a password you want to associate with the group. 

Clicking the bullet changes its setting: a solid bullet ( ) grants access to the group, a 
dimmed bullet (

) denies access.
4. In the Layouts and Fields lists, change the layouts and fields the group can use by clicking the 

bullet next to each layout and field name. A solid bullet ( ) grants access, a dimmed bullet (

) denies access, and an open bullet (

) grants viewing privileges only.
5. Click Save and then click Done.

See Also

Defining Passwords 

Defining Groups 



Sharing Files Across a Network
When sharing files across a network, all additions, deletions, and modifications made to a file appear 
in each user's window and are saved to the FileMaker Pro file on the host's disk. As FileMaker Pro 
processes data across the network to update each user's window, the network pointer (with arrows on
both ends) appears.

Sort order operations, find requests, and page setups are specific to each user and do not affect 
another person's work. While FileMaker Pro processes these, the pointer becomes a coffee cup.

For best performance, you should limit the frequency of the following activities when sharing a file:

- deleting multiple records

- replacing field contents

- relookup

- viewing or printing reports with several summary calculations

- importing or exporting large numbers of records or pictures

See Also

Working with Files as a Host 

Working with Files as a Guest 



Working with Files as a Host
As host--the first person to open a shared file--you should perform the following activities before you 
make the file accessible to the guests:

- define fields

- set up access privileges 

- open any lookup files associated with the shared file

- view or print files with several summary calculations

- import or export large numbers of records or pictures

- inform guests of their passwords if you've set up passwords for the file.

Once you begin sharing the file, all file changes (such as new data, layouts, or scripts) are saved to 
the hosted file.

When you close the file (or exit FileMaker Pro), FileMaker Pro asks the other users (guests) to close 
their versions of the file. If there is no response and the files can be closed safely, FileMaker Pro 
automatically closes all guest versions of the file.

To open a file as host:

1. Choose Open from the File menu. You must be the first person to open the file.

2. In the Open File dialog box, select the name of the file you want to share and click Open.

3. Make sure the Multi-User command appears in the File menu. If Single-User appears, choose it to 
switch to Multi-User.

To close a file and exit:

1. Choose Close or Exit from the File menu. If guests have the file open, the Network Ask dialog box 
appears.

2. Click Ask to notify guests that you would like to close the file.

FileMaker Pro sends a notice to current users, asking them to close the file. When all guests close 
the file, FileMaker Pro closes the file on the host's computer.

See Also

Sharing Files Across a Network 
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Working with Files as a Guest
A guest is the second or subsequent user to open a file. To enhance network performance, guests 
should routinely close any files that they are not actively using and close a shared file as soon as 
possible upon request.

To open a file as a guest:

1. Choose Open from the File menu.

2. In the Open File dialog box, click Hosts. You see the Hosts dialog box, which lists the hosted files 
available on the network.

3. If your network has zones, select the name of the host's zone from the list. 

4. Select the name of the file you want and click Open.

To close a file as a guest, choose Close from the File menu. Changes are saved to the host's disk.

See Also

Sharing Files Across a Network 

Working with Files as a Host 



FileMaker Pro Overview
A database is a collection of information or data. Examples of information you can collect and store in 
a database include a catalog of parts or products and a list of sales contacts. To organize a database,
you use a database management application like FileMaker Pro.

A FileMaker Pro database consists of records, fields, files, and layouts.

Record
A record contains the information you keep about one product, person, or transaction. A record 
corresponds to a paper form, such as a purchase order, which contains detailed information in many 
different categories.

Field
Within a record, you enter information into a field, which represents a category of information. A field 
can contain names or other text, numbers, pictures or sounds, dates, times, calculations, or 
summaries.

File
A file is a set of related records. A file also contains the layouts and scripts designed for the records.

Layout
You use a layout to organize information for display, data entry, and printing. You can create several 
layouts for the same information because a layout is completely separate from the information it 
contains. A layout determines how you present information--not how you store it.

Modes
FileMaker Pro has four different modes: Browse, Find, Layout, and Preview. You select a mode based
on the work you need to do.

- To enter data and view, add, change, omit, and delete records, use Browse .

- To work with a subset of records in your database that match the criteria you set, use 
Find. For example, in a customer database, you might want to find the customers who 
ordered a specific product or service.

- To design layouts that present your data for different tasks (such as invoice reports or 
order processing), use Layout.

- To see how records will look when printed, use Preview. After previewing your records, 
you can adjust the layout if needed.



Previewing and Printing
You can preview your records to see how they will look when printed. When you're ready to print, 
select the printer you want and then specify what you want to print.

Previewing a File 

Selecting a Printer 

Changing the Print Setup 

Selecting Print Options 



Previewing a File
In Preview, you can see how your records will look when printed and how many records will fit on a 
page.

To preview records:

1. Select a layout from the layout pop-up menu.

2. Choose Preview from the Select menu.

3. Click the pages of the book or drag the bookmark to flip through the pages of the file. Only the 
records in the found set appear.

You can hide the status area while previewing or examine the records more closely by using the 
zoom controls.

See Also

Status Area Control 

Zoom Controls 



Selecting a Printer
FileMaker Pro uses the default printer selected in the Control Panel as the current printer the first time
you start the program. You can change the default printer for all of your FileMaker Pro documents with
the Print Setup command, or temporarily change the printer when printing a specific document with 
the Print command. 

Note: If you later change the default printer in the Control Panel, it doesn't become the current printer 
unless you select the printer with the Print Setup command.

To select a default printer for FileMaker Pro documents:

1. Choose Print Setup from the File menu. You see the Print Setup dialog box.

2. To use the Windows default printer, click the Default Printer option. You can also use any other 
installed printer as the default printer by clicking Specific Printer and selecting a printer from the 
pop-up list.

3. Click OK.

To temporarily select a different printer:

1. Choose Print from the File menu.

2. Click the Setup button.

3. Click Specific Printer and select a printer from the list.

4. Click OK.

Note: For information about installing additional printers, see the Microsoft Windows User Guide.

See Also
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Changing the Print Setup
Select page orientation and paper size options to change the print setup. The page orientation 
controls whether pages are printed vertically or horizontally, and the paper size tells FileMaker Pro 
which paper is in the selected printer.

To change the print setup:

1. Choose Print Setup from the File menu. You see the Print Setup dialog box.

2. Click Portrait to print pages vertically or Landscape to print them horizontally.

3. Select the paper size of the paper loaded in your printer. 

4. Select a source. Use Upper Tray to feed paper automatically or Manual to feed paper by hand.

5. Click OK.

See Also

Previewing a File 

Selecting Print Options 



Selecting Print Options
In FileMaker Pro, you can print specific pages, control the print quality, print to a file, add page 
numbers, choose to print specific records, print field and script definitions, print a specific number of 
copies, and collate pages.

To select print options, choose Print from the File menu and select an option.

- To print all pages in a found set, click All.

- To print a range of pages, click Pages and type the first page in the From box and the 
last page in the To box.

- If your printer offers different print qualities, click Print Quality and select a print quality 
option such as a dpi value (dots per inch) or High, Medium, Low, or Draft.

- To store print jobs to print later or to print from a different computer, click Print to File.

- If you typed the page number symbols (##) in a layout, you can change the starting 
page number that prints at the bottom of each page by typing a number in the Number 
Pages From box.

- To print all records in the found set, click Records Being Browsed.

- To print the current record only, click Current Record.

- To print a blank record, click Blank Record and select one of the following options from 
the pop-up list.

· As Formatted to print fields as formatted in the Field Borders dialog box

· With Boxes to print each field in a box

· With Underlines to print each field with an underline.

- To print a list of field definitions, click Field Definitions.

- To print a script definition, click Script Definition For and select All Scripts or a specific 
script from the pop-up list.

- To set the number of copies you want to print, type a number in the Copies box.

- To print complete, collated copies instead of all copies of a page before going on to the 
next, click Collate copies.

Once you've selected your print options, click OK to begin printing.

See Also

Previewing a File 

Changing the Print Setup 
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Screen Elements
FileMaker Pro screen elements are the tools you use for working with records and layouts. You can 
select modes, use status area controls, change magnification, and work with layout parts, rulers, and 
T-squares.

Using the Status Area    

Browse Status Area    

Layout Status Area    

Find Status Area    

Preview Status Area 

Zoom Controls 

Status Area Control 

Part Label Control 

Mode Selector 

Layout Parts    

Rulers    

T-Squares    



Using the Status Area
The status area on the left side of your screen contains controls and status information for working 
with your FileMaker Pro database. When you change modes, the status area displays different 
controls and information.

In all modes, the status area contains the book:

Click each part of this graphic to 
see a description of that part of the
status area book

Hide or show the status area by clicking the status area control  at the bottom the screen.

See Also
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Layout Pop-up Menu
Click the layout pop-up menu to switch layouts.



Status Area Book
Use the book to move through records, layouts, find requests, and pages, depending on the selected mode. 



Upper Page
Click the upper page to move to the previous item.



Bookmark
Drag the bookmark up or down to quickly scroll through items.



Lower Page
Click the lower page to move to the next item.



Current Number
This is the number of the current item. Type a number over the current number and press Enter to move to a specific item.



Browse Status Area
In Browse, use the status area to select records for data entry, see the total number of records in the 
found set, and find out if records are sorted.

Click each part of this graphic to see a 
description of that part of the Browse 
status area

See Also
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Browse Book
Use the book to select records.

Click the upper page to move to the previous record.

Click the lower page to move to the next record.

Move the bookmark to scroll through records.

To move to a specific record, type the record number over the current number and press Enter.



Records
View the total number of records in the database.



Found
View the number of records you can browse in the found set.



Unsorted, Sorted, or Semi-Sorted
View the record sorting status: unsorted, sorted, or semi-sorted (if records have changed since last sorted).



Layout Status Area
In Layout mode, use the status area to select and work with layouts, and to see the total number of 
layouts in the file.

Click each part of this graphic to see 
a description of that part of the 
Layout status area

See Also
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Layout Book
Use the book to select a layout.

Click the upper page to move to the previous layout.

Click the lower page to move to the next layout.

Move the bookmark to scroll through layouts.

To move to a specific layout, type the layout number over the current number and press Enter.



Layouts
View the total number of layouts for the file.



Pointer Tool
Click the selection tool and then select an object you want to move or change.



Text Tool
Click the text tool and click where you want to add text or drag to add a text box. Begin typing.



Line Tool
Click the line tool and then click and drag to draw a straight line.



Rectangle Tools
Click the rectangle or rounded rectangle tool and then click and drag to draw a rectangle.

Press the Alt key as you drag to constrain the rectangle to a square.



Oval Tool
Click the oval tool and then click and drag to draw an oval. Press the Alt key as you drag to constrain the oval to a circle.



Field Tool
To place a field already defined in the Define Fields dialog box, drag the Field tool to the layout and position it where you want to
place the field. 

Select a field from the New Field dialog box.

You can place multiple copies of a defined field in your layout. 



Part Tool
To add a part to a layout, drag the Part tool to the layout and position it where you want to place the part. Select a part from the 
Part Definition dialog box.



Fill Color and Pattern Palettes
Select a fill color and pattern from the palettes for the selected object or new objects.



Pen Color and Pattern Palettes
Select a line color and pattern from the palettes for the lines that border the selected object or new objects.

You must add borders to the field in the Field Borders dialog box before you can apply a line color or pattern.



Line Width Menu
Select a line width from the menu for the lines around objects and field borders.



Find Status Area
In Find, use the status area to create find requests. Find requests locate the records that match your 
find criteria. Those records become the found set, and the only records available for browsing, 
sorting, previewing, and printing.

Click each part of this graphic to see 
a description of that part of the Find 
status area

Note: For descriptions of the find operators in the Symbols pop-up list, see Find Operators.

See Also
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Find Book
Use the book to select a find request.

Click the upper page to move to the previous find request.

Click the lower page to move to the next find request.

Move the bookmark to scroll through the find requests.

To move to a specific request, type the find request number over the current number and press Enter. The requests are 
numbered in the order you make them.



Requests
View the total number of requests.



Omit
Click Omit to exclude the records that match the find request.



Symbols
Choose a Find operator from the Symbols pop-up list. Click Find Operators in the note in this topic for descriptions of find 
operators.



Find Operators
These are the find operators that are available from the Symbols pop-up list:

Operator Purpose Example

< LESS THAN Finds all records 
containing numbers that 
are smaller, words that 
come earlier in 
alphabetical order, or 
dates or times that are 
earlier than the value you
type

<17:30

Finds records that contain times up 
to, but not including, 17:30, in the 
corresponding field

= < LESS THAN 
OR EQUAL TO

Finds all records that 
match the value you type
or contain numbers that 
are smaller, words that 
come earlier in 
alphabetical order, or 
dates or times that are 
earlier

= <Marshall 

Finds all records that contain Marshall
and all records that fall before 
Marshall in alphabetical order, in the 
same field .

> GREATER THAN Finds all records 
containing words that 
come later in alphabetical
order, numbers that are 
larger, or dates or times 
that are later than the 
value you type 

 >25

Finds records that contain numbers 
larger than 25 in the corresponding 
field, not including 25

= > GREATER 
THAN OR 
EQUAL TO

Finds all records that 
match the value you type
or contain numbers that 
are larger, words that 
come later in alphabetical
order, or dates or times 
that are later

= >17:30 

Finds all records that contain the time 
17:30 or a later time in the 
corresponding field

= EXACT MATCH Finds all records that 
contain an exact value 
somewhere in the field

FileMaker Pro ignores 
capitalization and word 
order, but observes word 
spacing

= richard jones 

Finds records that contain Richard 
Jones or Jones Richard, but does not 
find RichardJones

... RANGE Finds all values in a 
range between two 
values, including the first 
value and the last

6/30/92...12/31/92 

Finds records that contain dates from 
June 30, 1992 through December 
31,1992, inclusive, in the 
corresponding field

! DUPLICATES Finds all records that 
contain a value that is not
unique in a field

FileMaker Pro ignores 
capitalization and word 
order

!

With ! in the Name field, finds records 
with identical names in more than one
record, such as    Marilyn Smith and 
smith, marilyn.

// TODAY'S DATE Finds all records that 
contain today's date in 
the corresponding field

You can combine // with 
other search criteria

 >//

Finds all records that contain a date 
later than today's date in the 
corresponding field

? INVALID DATE Finds all records that ?



OR TIME contain an invalid date or
time

With ? in the Date field, finds records 
with a date not in the mm/dd/yy 
format

@ ONE 
CHARACTER

Choose the @ wildcard 
to substitute for each 
unknown character

You can use wildcards in 
text fields only

J@n

Finds Jon or Jan, but not Jean

* ZERO OR MORE 
CHARACTERS

Choose the * wildcard to 
substitute for any number
of unknown characters 

You can use wildcards in 
text fields only

D*n

Finds Don, Dan, Dean, or Dawn

" " LITERAL TEXT Choose the " " symbol 
and then type the text 
you want to find

 "Chris Lee" 

Finds only those records that contain 
Chris and Lee together in that order, 
in that field

"," finds all records that contain a 
comma



Find Button
Click Find to locate the records that match the search criteria.



Preview Status Area
Preview shows how a file will look when printed and gives an overview of margin size, headers and 
footers, and the number of records on a page.

Click each part of this graphic to see a 
description of that part of the Preview 
status area

See Also
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Preview Book
Use the book to select a page.

Click the upper page to move to the previous page.

Click the lower page to move to the next page.

Move the bookmark to scroll through the pages.

To move to a specific page, type the page number over the current number and press Enter.



Pages
View the number of pages that are available for preview.



Zoom Controls
Click the zoom controls to enlarge or reduce the image on the screen. 

 enlarges the image up to 400 percent.
 reduces the image down to 25 percent.

 shows the current percent of magnification.
The zoom controls are at the bottom left corner of the screen.

See Also

Previewing a File 



Status Area Control
 Click the status area control to show or hide the status area.

The status area control is at the bottom of the screen, next to the zoom controls.

See Also

Using the Status Area 

Zoom Controls 



Part Label Control
 In Layout, click the part label control to flip part labels to a vertical or horizontal position.

The part label control is at the bottom of the screen, next to the mode control.

See Also
Working with Layout Parts 

Mode Selector 



Mode Selector
 Use the mode control to select Browse, Find, Layout, or Preview mode. 

To change modes, click the mode control and select a mode from the pop-up menu.
This control is at the bottom of the screen, next to the horizontal scroll bar arrow.
Note: You can also select modes with the Browse, Find, Layout, and Preview commands in the Select 
menu.

See Also
Browse Status Area 
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Layout Parts
Parts are sections of a layout that organize information for printing. You decide which fields, objects, 
or buttons to place in each part, and you can resize or delete parts as necessary. Each part is 
identified with a label that appears on the left edge of the layout.

Standard Layout Parts
These are the three basic layout parts. When you select a Standard or Blank layout with the New 
Layout command, these parts appear. A layout can have only one each of these parts:

Part Prints Contains

Header At the top of 
every page

Information like the date, page 
number, report title, company title, or 
logo

Body Between the 
other part types

Records in the found set 

Footer At the bottom of 
every page

The same type of information as 
the header

Other Layout Parts
You can print any number of sub-summary fields and one each of these other fields:

Part Prints Contains

Title Header At the top of the 
first page in 
place of the 
header

Information like the date, page 
numbers, report title, company title, 
and logo

Leading 
Grand 
Summary

Above the body When a summary field is placed in 
this part, prints a summary of that 
field for the found set

When other field types are placed in 
this part, prints the value in that field 
in the first record in the found set

Sub-
Summary 
when Sorted 
By

Above or below 
the body

A summary for each group of records 
sorted by the field specified

Trailing 
Grand 
Summary

Below the body When a summary field is placed in 
this part, prints a summary of that 
field for all records in the found set

When other field types are placed in 
this part, prints the value in that field 
in the first record in the found set

Title Footer At the bottom of 
the first page in 
place of the 
footer

The same type of information as the 
title header

See Also
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Rulers
In Layout, choose Rulers from the Layout menu to display or hide rulers at the top and left side of the 
layout.

Use the Ruler Settings command to:

- change the ruler units to inches, centimeters, or pixels

- change the increment for the invisible snap-to grid spacing

See Also

Ruler Settings 

Arranging a Layout 



T-Squares
Choose T-Squares from the Layout menu to show or hide the snap-to t-square. 

The t-square is a pair of intersecting vertical and horizontal lines you can use to align objects. You can
reposition the t-square by dragging each of its lines independently or by using the Size window. 

Note: To override the snap-to effect of the t-squares, hold down Ctrl while dragging an object.

See Also

Arranging a Layout 

Size Window    



Using Scripts and Buttons
You can speed up your regular or repeated tasks by creating scripts with FileMaker Pro ScriptMaker 
(TM). A script instructs FileMaker Pro to carry out a sequence of specified tasks for a specific file. 
Scripts can have subscripts to perform additional tasks.

To build a script you define a set of steps you want the script to perform. When setting up a script, 
FileMaker Pro does not record your actions as you perform them. You choose steps and build the 
script based on the current state of the file.

To perform a script, you choose it from the Scripts menu or the Define Scripts dialog box. You can 
also create buttons in a layout to perform scripts or run specific commands.

Creating Scripts 

Script Steps Summary 

Running Scripts 

Creating Buttons 



Creating Scripts
You create new scripts with FileMaker Pro ScriptMaker. The steps you include in the script are based 
on the current state of the file for find requests, sorting, import order, export order, and page setup.

To define a new script:

1. Do the tasks you want to include in the script. 

For example, if the steps include finding and sorting, create find requests and use the Sort 
command to specify the sort order.

2. Choose ScriptMaker from the Scripts menu. You see the Define Scripts dialog box.

3. Type a name for the script in the Script Name box.

4. Click Create. You see the Script Definition dialog box with a preset script. (You can keep or remove
these steps as necessary.)

5. Select a step from the Available Steps list.

6. Click Move to add the step to the script. (You can also double-click a step to add it to the list.)

7. If the step has brackets ([...]) after it, select or deselect step options in the Options box.

8. Move any additional steps into the script. To remove a step from the script (for example, a preset 
script step), select it in the script list and click Clear. To remove all script steps, click Clear All.

9. When you complete the script, click OK.

10. Click Done.

To list the script in the Scripts menu, click Include in Menu in the Define Scripts dialog box.

To edit a script:

1. Do the tasks you want to include in the edited script. (See step 1 above.)

2. Choose ScriptMaker from the Scripts menu.

3. Select the script name in the Define Scripts dialog box.

4. Click Edit.

5. Use the Move button to move selected steps into the script list, or the use Clear button to remove 
steps. If the step has brackets ([...]) after it, select or deselect options for it in the Options box.

6. To reorder script steps, press the double arrow to the left of the step and drag it to a new location.

7. Click OK. If you change the specifications of steps stored in the script (such as changing the print 
setup), you see a dialog box that asks for more information.

8. In the dialog box, click Keep for options you want to stay the same. Click Replace for options 
where you want to use new information. Click OK to confirm the changes.

9. Click Done.

To delete a script:

1. Choose ScriptMaker from the Scripts menu.

2. Select the script name in the Define Scripts dialog box.

3. Click Delete and then click Delete in the dialog box asking you to confirm the deletion.

4. Click Done.



See Also

Script Steps Summary 

Creating Buttons 



Script Steps Summary
You can include any number of steps in a script and customize many of the steps by selecting 
options.

FileMaker Pro includes the following script step types:

Perform Script Steps 

Go To Steps 

Sorting, Import/Export, and Printing Steps 

Find Steps 

Mode Steps 

Data Entry Steps 

Editing Steps 

Toggling and Scrolling Steps 

File Steps 

See Also

Creating Scripts 



Perform Script Steps 

Use this scripting 
step:

To tell FileMaker Pro to: Options:

Perform Script [...] Perform a sub-script 
from within a script

Perform sub-scripts

Specify the script

Pause/Resume Script Stop the script 
temporarily so the user 
can do a task and then 
resume the script



Go To Steps

Use this scripting 
step:

To tell FileMaker Pro to: Options:

Go to Layout [...] Switch to the layout you 
want FileMaker Pro to 
use when performing the
script

Select a layout from 
pop-up menu

Refresh screen

Go to 
Record/Request [...]

Move to a specific record
or find request in the file

Perform without dialog 
Specify Record

Go to Next 
Record/Request [...]

Move to the next record 
or find request in the file

Exit script after last

Go to Previous 
Record/Request [...]

Move to the previous 
record or find request in 
the file

Exit script after last

Go to Field [...] Move to a specific field in
the file

Select/Play

Specify Field

Go to Next Field Move to the next field in 
the file

Go to Previous Field Move to the previous 
field in the file



Sorting, Import/Export, and Printing Steps

Use this scripting 
step:

To tell FileMaker Pro to: Options:

Sort [...] Order the records 
according to the sort 
order you set when you 
defined the script

Restore sort order

Perform without dialog

Unsort Restore the records to 
their original order

Import Records [...] Get records from the type
of file you specify

Restore import order

Specify File

Perform without dialog

Import Picture... Get a picture from 
another application or file

Import Movie... Import a QuickTime for 
Windows movie

Export Records [...] Send records to another 
file according to the file 
and format you specify

Restore export order

Specify File

Perform without dialog

Print Setup [...] Set options in the Print 
Setup dialog box

Restore Setup Options

Perform without dialog

Print [...] Print the specified 
records or file

Perform without dialog



Find Steps

Use this scripting 
step:

To tell FileMaker Pro to: Options:

Perform Find [...] Find one or more records 
according to the find 
request

Restore find requests

Find All Find all records in the file

Refind Displays the last find 
request 

Omit Leave a record out of the 
found set

Omit Multiple [...] Leave the specified 
number of records out of 
the found set

Perform without dialog

Specify Record

Find Omitted Find the records omitted 
from a found set



Mode Steps

Use this scripting step: To tell FileMaker Pro to: Options:

Enter Browse Mode 
[...]

Move to Browse Pause

Enter Find Mode [...] Move to Find, where you 
can define a temporary 
find request

Restore find requests

Pause

Enter Preview Mode 
[...]

Move to Preview to 
preview pages in actual, 
reduced, or enlarged size

Pause



Data Entry Steps

Use this scripting step: To tell FileMaker Pro to: Options:

New Record/Request Present a blank layout for 
adding a record or find 
request

Duplicate 
Record/Request

Copy a record or find 
request

Delete 
Record/Request [...]

Delete a record or find 
request

Perform without 
dialog

Delete Found Set [...] Delete the records 
retrieved by a find request

Perform without 
dialog

Paste from Index [...] Paste a value from the 
index into a field

Select entire 
contents

Specify Field

Paste from Last 
Record [...]

Paste the data from a field 
in the last record you 
modified into the same 
field in the current record 
or request

Select entire 
contents

Specify Field

Paste Current Date [...] Paste the current system 
date into a field

Select entire 
contents

Specify Field

Paste Current Time [...] Paste the current system 
time into a field

Select entire 
contents

Specify Field

Paste Current User [...] Paste the name of the 
current user into a field

Select entire 
contents

Specify Field

Paste Literal [...] Paste a text string into a 
field

Specify

Replace [...] Copy the contents of the 
current field into the same 
field in all records of the 
found set

Perform without 
dialog

Specify Field

Reserialize [...] Replace the current serial 
numbers with sequential 
numbers

Perform without 
dialog

Specify Field

Relookup [...] Copy the new values from 
the lookup file into the 
current file

Perform without 
dialog

Specify Field



Editing Steps

Use this scripting step: To tell FileMaker Pro to: Options:

Undo Undo the last move

Cut [...] Cut the contents of the 
specified field

Select entire 
contents

Specify Field

Copy [...] Copy the contents of the 
specified field

Select entire 
contents

Specify Field

Paste [...] Paste the contents of the 
specified field

Select entire 
contents

Specify Field

Paste Without Style

Clear [...] Clear the contents of the 
specified field

Select entire 
contents

Specify Field

Select All Select the entire contents of
a field in Browse

Spell Check Selection 
[...]

Check the spelling of text in
the selected field

Select entire 
contents

Specify Field

Spell Check Record Check the spelling of text in
a record

Spell Check Found 
Set

Check the spelling of data 
in the found set



Toggling and Scrolling Steps

Use this scripting 
step:

To tell FileMaker Pro to: Options:

Toggle Status Area 
[...]

Show or hide the status 
area

Specify Show, Hide, 
Toggle

Refresh screen

Toggle View-as-List 
[...]

Turn on or off the View As 
List option

Specify Show, Hide, 
Toggle

Refresh screen

Toggle Window [...] Hide or change the size of 
the current window

Specify Minimize, 
Maximize, or Restore

Refresh screen

Home Scrolls to the top of the 
layout

Page Up Scrolls up one page

Page Down Scrolls down one page

End Scrolls to the bottom of the 
layout



File Steps

Use this scripting 
step:

To tell FileMaker Pro to: Options:

Send Message [...] Launch an application or 
open and print a document 
in another application

File Type

Send the <option> 
message

Specify File

Specify Field

Specify Text

Bring target 
application to 
foreground

Help... Display the FileMaker Pro 
Help system

Open [...] Open a file Specify File

Close Close the current file and 
stop the script

Save a Copy as [...] Save a copy of the file as an 
exact duplicate, a 
compressed copy, or a clone
without data

Specify File

Define Fields... Display the Define Fields 
dialog box

Send Mail [...] Send mail to Microsoft Mail 
or Lotus cc:Mail users

Perform without dialog

To

CC

Subject

Message

Attach (Specify File)

DDE Execute [...] Send a Dynamic Data 
Exchange (DDE) command 
to another application to 
execute a series of 
commands

Service Name (usually
the name of the target 
application)

Topic

Commands

Specify Field

Exit Close all open files and quit 
FileMaker Pro

Running Scripts
You can instruct FileMaker Pro to perform a script in a number of ways.

To perform a script:

- Choose the script name from the Scripts menu. The script appears in the Scripts menu 
if you select Include in Menu in the Define Scripts dialog box.

- Choose ScriptMaker from the Scripts menu. Select the script name in the Define 
Scripts dialog box and click Perform.

- Click a button defined to run a script.

To perform a script each time you open the document:



1. Choose Preferences from the File menu.

2. Click the Document icon.

3. Select Perform Script and specify the script name in the pop-up list. (To appear in this list, the 
script must be defined for the current file.)

4. Click Done.

See Also

Creating Scripts 

Script Steps Summary 

Setting Document Preferences 

Creating Buttons 



Creating Buttons
You can create and use buttons to perform scripts or carry out FileMaker Pro commands.

When you click a button in Browse or Find, FileMaker Pro executes the script or the command. If you 
have linked several scripts together, the button starts the script sequence.

To create a button:

1. Choose Layout with the mode selector at the bottom of the screen.

2. Create or select an object you want to define as a button. You can use graphic objects or layout 
text, but not fields.

3. Choose Define Button from the Scripts menu. You see the Define Button dialog box.

4. Select an option from the list:

- To run a script with the button, select Perform Script. Click the arrow and select a script
from the Specify pop-up list.

- To run a command with the button, select the command. If options appear beneath the 
list, select options to specify how FileMaker Pro should run the command. (See the 
Script Steps Summary.)

To disable a button:

1. Choose Layout from the mode selector at the bottom of the screen.

2. Select the button.

3. Choose Define Button from the Scripts menu. You see the Define Button dialog box.

4. Click on one of the lines between the steps to deselect the option.

5. Click OK.

To delete a button:

1. Choose Layout from the mode selector at the bottom of the screen.

2. Select the button.

3. Choose Cut or Clear from the Edit menu.

See Also
Creating Scripts 

Script Steps Summary 



Scripts Menu
Use Scripts menu commands to define scripts for running a series of FileMaker Pro commands and 
creating buttons to run scripts and activate individual commands. 

ScriptMaker... 

Define Button... 

Script Names      



ScriptMaker...
Scripts Menu

Sets up scripts for running a series of FileMaker Pro commands. You can create, modify, delete, and 
run one script or a sequence of scripts, and you can add script names to the Script menu.

You name and define scripts in the Define Scripts dialog box.

    
Define Scripts Dialog Box

From the Define Scripts dialog box, you create or edit scripts in the Script Definition dialog box. 

 
Script Definition Dialog Box

See Also

Using Scripts and Buttons 

Creating Scripts 

Script Steps Summary 

Selecting Print Options 



Define Scripts Dialog Box

Option Action

List View the list of scripts defined for the current file

Select a script to perform or change

Change the order of the scripts list by dragging the double arrow next to 
the script name

Script Name Type a name for a new or changed script

Include in menu Click to add the selected script to the Scripts menu

Perform Click to run the selected script

Edit Change the selected script's commands in the Script Definition dialog box 

Create Click to create a new script    in the Script Definition dialog box

Rename Click to change the name of the selected script to the new name you 
typed in the Script Name box

Duplicate Click to create a copy of the selected script

Delete Click to remove the selected script

Done Click when you finish defining scripts



Script Definition Dialog Box

Option Action

Available Steps Select steps to include in your script

The list includes most menu commands, window 
controls, and the Perform Script command to run a 
sequence of scripts.

For a complete list of the steps you can select and the 
options available for each, see the Script Steps 
Summary    

<script name> View the steps selected for the script, drag a step by the 
double arrow next to the step name to change the order 
of steps, or select a step to clear from the list

Options Select the options you want for a selected step, if any 
are available

Steps with square brackets ([ ]) in the step name have 
options

Clear All Click to remove all steps from the script

Move/Clear From the Available Steps list, select a step you want to 
add to your script and click Move

From the <script name> list, select a step you want to 
remove and click Clear

Define Button...
Scripts Menu

Makes a text or graphic object into a button that can perform a script in Browse or Find.

 
Define Button Dialog Box 

See Also

Using Scripts and Buttons 

Creating Buttons 



Define Button Dialog Box

Option Action

List Select a script or step you want to associate with a 
button

For a complete list of available steps and options, see 
Script Steps Summary

If you select Perform Script, select a script from the 
Specify pop-up list

Options Select the options, if any are available, for the script 
steps activated by the button

Script Names
Scripts Menu

Lists the scripts that you have selected to appear in the Script menu. The first ten scripts appear in 
the menu with a keyboard equivalent.

When you choose a script name from the Scripts menu, FileMaker Pro performs the script.

See Also

Using Scripts and Buttons 

Running Scripts 

Creating Scripts 



Select Menu
Use Select menu commands to switch between Browse, Find, Layout, and Preview modes, to search 
and sort records, to determine the type information in your fields, and to view records in a list format.

Browse 

Find 

Layout 

Preview 

Find All 

Refind 

Omit 

Omit Multiple... 

Find Omitted 

Define Fields... 

Sort... 

View as List 



Browse
Select Menu

Activates Browse mode. In Browse you can create new records and edit, sort, print, and export them 
to another file. The records appear in the current layout.

FileMaker Pro selects Browse after you define fields or open a new file.

See Also

Browse Status Area

Entering Data 

Moving to Fields      



Find
Select Menu

Activates Find mode. In Find you make find requests to locate records based on selected criteria. The
located records become the found set for browsing, sorting, previewing, and printing.

FileMaker Pro switches to Browse after completing a find request.

See Also

Find Status Area 

Using Find Mode 

Making a Find Request 



Layout
Select Menu

Activates Layout mode. In Layout you work with layouts by arranging and formatting fields, layout 
text, and pictures. 

You can use specific layouts to present or emphasize data in different ways.

See Also

Layout Status Area 

Using Layout Mode 

Working with Layouts 



Preview
Select Menu

Activates Preview mode. In Preview you can see your records and reports as they will look when 
printed. 

See Also

Preview Status Area 

Previewing a File    



Find All
Select Menu

Finds all the records in the file and makes them available for browsing, sorting, previewing, and 
printing. The Find All command is available after you've made a find request.

See Also

Finding All Records 



Refind
Select Menu

Changes to Find and displays the last find request. Click Find to repeat the find request.

See Also

Updating a Find Request 

Making a Find Request 



Omit
Select Menu

In Browse, the Omit command excludes the current record from the found set.

See Also

Omitting Records 



Omit Multiple...
Select Menu

In Browse, the Omit Multiple command excludes a specific number of consecutive records from the 
found set.

 
Omit Multiple Dialog Box

See Also

Omitting Records 



Omit Multiple Dialog Box

Option Action

Starting from the current
record, omit <number> 
records

Type the number of records you want to exclude from 
the found set, starting with the current record

Omit Click to omit the number of consecutive records 
specified



Find Omitted
Select Menu

Switches the found set and the omitted set. The currently omitted records become the found set and 
the original found set becomes the omitted set.

See Also

Omitting Records 

Making a Find Request 



Define Fields...
Select Menu

Names fields and specifies the type of information they can contain.

You begin defining fields in the Define Fields dialog box.

    
Define Fields Dialog Box

Text, Number, Date, Time, and Picture/Sound Fields
Use the Options button to further define these field types in the Entry Options dialog box.

    
Entry Options Dialog Box

From the Entry Options dialog box:
Select Use a Pre-Defined Value List and click the Edit Values button to set up a predefined list of 
values for the field in the Display Values dialog box.

 
Display Values Dialog Box

Select Look Up Values from a File and click the Lookup Values button. In the Lookup Values dialog 
box, link fields in one file or record with fields in another file or record

 
Lookup Value Dialog Box

Once you define a picture/sound field, you can record a sound if you have the required hardware and 
software. In Browse, double-click in the field and record a sound in the Sound Record dialog box.

 
Sound Record Dialog Box

Summary Fields
When you define a summary field, set up summary definitions in the Options for Summary Field 
dialog box.

 
Options for Summary Field Dialog Box

Calculation Fields
When you define a calculation field, set up the calculation formula in the Options for Field dialog box.

 
Options for Field Dialog Box

See Also

Creating a New Field 

Defining Fields and Entering Data 





Define Fields Dialog Box

Option Action

View by Select the order for viewing field names in all field lists in
FileMaker Pro dialog boxes

You can view fields by creation order, field name, field 
type, or custom order (drag the double arrow next to the 
field name)

List View the name, type, and options that have been 
defined for all fields in the file, or select a field to change

Name Type a name for a new field or a different name for an 
existing field

Type

Text Click to create a field for any kind of text

Number Click to create a field that can contain a number and 
non-indexed text

The field contents must fit on one line of 255 characters 

Date Click to create a field for a date

Time Click to create a field for a time

Picture/Sound Click to create a field for an imported or pasted picture 
or a    sound

Calculation Click to create a field that shows the results of a 
calculation of data from the current record

Define the calculation field in the Options for Field dialog
box

Summary Click to create a field that shows the result of a formula 
that uses the same field in a group of records

Define the summary formula in the Options for Summary
Field dialog box 

Create Click to establish a field with the name and type selected

Change Click to enter the changes you've made for the selected 
field

Delete Click to delete the selected field 

Options... Click to open the Entry Options dialog box and set 
additional definitions for the selected field

Duplicate Click to create an exact copy of the selected field

Done Click when you finish defining fields



Entry Options Dialog Box

Option Action

Auto-enter a value that's

the... Select the type of information you want to enter:
Creation Date, Creation Time, Modification Date, 
Modification Time, Creator Name, or Modifier 
Name

a serial number To enter a serial number in the field (for serially 
numbered records), type values for Next Value 
and Increment By

data Type the data you want FileMaker Pro to enter 
automatically

Verify that the field value is

not empty Click if a value must always be entered in the 
field

unique Click if the values in this field must always be 
unique 

an existing value Click if the values in this field must always be the
same as existing values

of type Click if the values in this field must always be a 
number, date, or time

from/to Click if the values in this field must fall within the 
number range you type in the From and To 
boxes

Prohibit modification of auto-
entered values

Click to prevent automatically-entered data in the
field from being edited

Repeating field with a 
maximum of <number> 
values

Click to define a field that can have multiple 
entries and type the number of values you want

Use a pre-defined value list: Click to set up a list of values for data entry that 
appear when you click the field in Browse

Click the Edit Values button to change values in 
the Display Values dialog box

Look up values from a file: Click to select a lookup file for entering data from 
another file

Click Set Lookup to select the lookup file from the
Lookup Values dialog box



Display Values Dialog Box
Type the values you want to display in the field and click OK.



Lookup Values Dialog Box

Option Action

Lookup File Make sure the name of the lookup file you want to use 
appears on the left (to change the lookup file, click Set 
Lookup File...)

Current File View the name of the current file

Copy the contents of: Select the field from the lookup file that contains the data
you want to copy

...into the field View the name of the field that will contain the data you 
copy from the lookup file

...when the value in: Select the field in the lookup file that should contain a 
value that matches a value in the current field and file

...matches a new entry 
in:

Select the field in the current file that will contain a value 
to match

If no exact match, then Specify an alternative if the values don't match: Don't 
Copy, Copy Next Lower Value, Copy Next Higher Value, 
or Use (with a value typed in the Use box)

Set Lookup File.. Click to select a different lookup file from the Open File 
dialog box 



Sound Record Dialog Box

Option Action

Record Click to begin recording

Play Click to play the recorded sound

Pause Click to pause recording or playing

Stop Click to stop recording or playing



Options for Field Dialog Box

Option Action

Fields Select a field 

Symbol keypad Click the symbols you want to include in the 
formula:

& joins pieces of text, " " surrounds text you 
want included in the formula, ¶ starts a new line 
in the formula's result, ( ) indicates the order of 
operations, / divides values, * multiplies values, -
subtracts values, + adds values

See Introduction to Operators for more 
information on symbols

Number keypad Click numbers you want to include in the formula

Operators Click operators you want to select for the 
formula 

See Introduction to Operators for more 
information on operators

Functions Select functions for the formula

See Introduction to Functions for more 
information on functions

Formula box View the formula as you build it

Calculation result is Select a result type for the calculation: Number, 
Date, or Time

Repeating field with a 
maximum of <number> 
values

Select the number of different values the field 
can have



Options for Summary Field Dialog Box

Option Action

<summary formula> Select a summary formula to apply to the field's data

See Summary Formulas for descriptions

of <field name> Select a field to be summarized



Sort...
Select Menu

Determines the order for displaying and printing records. Records are sorted by the first field in the 
sort order list, then by the second, and so on. Values within each field are sorted in ascending, 
descending, or custom order.

You can also sort records based on the requirements of a different country.

 
Sort Records Dialog Box 

See Also

Basic Sorts 

Changing the Sort Order    



Sort Records Dialog Box

Option Action

Language list Select a country from the pop-up list to sort according to 
that country's requirements

Field List Select a field name to add to the sort order 

Clear All Click to clear the Sort Order list and start over

Move/Clear From the Field List, select a field to add to the sort order 
and click Move

From the Sort Order list, select a field to remove from 
the sort order and click Clear

Sort Click to sort the current records in the order specified in 
the Sort Order list

Unsort Click to undo the sort

Done Click to save the sort order

Sort Order View the sort order

FileMaker Pro sorts records by the first field name, then 
by the second, and so on

A symbol next to each field name shows whether 
records are sorted in ascending, descending, or custom 
order

Include summary fields Click if you want summary fields to appear in the Field 
List

Ascending order With a field name selected in the Sort Order list, click to 
sort records alphabetically from A to Z, numerically from 
lowest to highest, or chronologically from earliest to 
latest date and time

Descending order With a field name selected in the Sort Order list, click to 
sort records alphabetically from Z to A, numerically from 
highest to lowest, or chronologically from latest to 
earliest date and times

Custom order based on 
field's value list

If a field uses a value list, you can sort records according
to those values

With a field selected in the Sort Order list, click to sort 
records by the first value in the values list, then by the 
second value, and so on



View as List
Select Menu

Displays records in a continuous list so you can see them all at once instead of one by one.

See Also

Working with Layouts 

Previewing a File 



Setting Preferences
To set FileMaker Pro preferences, choose Preferences from the File menu and click the General, 
Document, or Memory icon in the Preferences dialog box. 

Setting General Preferences 

Setting Document Preferences 

Setting Memory Preferences 



Setting General Preferences
Click the General icon in the Preferences dialog box to set preferences that apply to all your 
documents.

- To keep the current layout tool selected, click Always Lock Layout Tools.

- To add new fields to the current layout, click Add Newly Defined Fields to Current 
Layout.

- To show both the FileMaker Pro for Windows and FileMaker Pro for Macintosh 
keyboard shortcuts in the menus, click Show Macintosh Accelerators in Menus. In the 
menus, the Ctrl key replaces the Macintosh command key.

- To set the name that you can paste into a field with the Current User Name command, 
accept the preset (the name you typed in the registration screen when you installed 
FileMaker Pro) or type a different name.

See Also

Layout Status Area 

Adding Layout Pictures 

Defining Fields and Entering Data 

Macintosh Key Equivalents 

Paste Special 



Setting Document Preferences
Click the Document icon in the Preferences dialog box to set preferences to customize the current 
document.

- To use curly apostrophe or quotation marks in field and layout text, click Use Smart 
Quotes.

Note: Not all fonts have curly apostrophe or quotation marks.

- To view pictures in both the Macintosh and Windows versions of FileMaker Pro, click 
Store Macintosh Picture Formats. This stores pictures in the Macintosh PICT format in 
addition to the Windows Metafile WMF format. When this option is off, FileMaker Pro 
stores the pictures in WMF format only and pictures appear on the Macintosh as 
framed rectangles. If you will view pictures with the Windows version of FileMaker Pro 
only, you can save disk space by keeping this option off.

- To use a particular layout when you open the file, click Switch to Layout and choose a 
layout from the list.

- To hide the status area when you open the file, click Status Area and select Hide. 
Select Show to display it.

- To enlarge the window to full screen size when you open the file, click Maximize 
Window.

- To perform a specific script when you open the file, click Perform Script and choose a 
script from the list.

See Also
Selecting a Layout 

Using the Status Area 

Running Scripts 

Field Types 



Setting Memory Preferences
Click the Memory icon in the Preferences dialog box to specify when FileMaker Pro saves changes to
disk and to check the current size of the file cache.

- To save changes to disk whenever the system isn't busy, click During Idle Time.

- To save changes to disk at a specific time interval, click Every n Minutes Or When 
Necessary and choose a time interval from the list.

Note: If you are using a battery-powered computer you can conserve battery power by setting the 
memory preference to save every 10 or 15 minutes.

See Also

Saving Files 



Troubleshooting
If something goes wrong when you're working with FileMaker Pro, you may be able to correct the 
problem by referring to the list of messages and solutions, or by following the procedure for 
recovering damaged files.

Recovering Files 

Messages 



Recovering Files
If a file is too damaged to open or use, you can salvage as much information as FileMaker Pro can 
reconstruct. 

To recover a damaged file:

1. Choose Recover from the File menu. You see the Open Damaged File dialog box.

2. Select the file drive from the Drives list box and the directory from the Directories list box.

3. Select the file name from the File Name list box.

4. Click OK. You see the Name Recovered File dialog box.

5. Type a new name for the recovered version of the file in the File Name box or accept r<file name> 
as the name.

6. Choose the directory or disk you want to use for the saved version of the file. Choose a disk with 
sufficient disk space to hold the new file; the new file will not be usable if FileMaker Pro runs out of 
space.

7. Click OK. FileMaker Pro shows each item it checks and displays a recovery report.

See Also
Messages 

Customer Support 



Messages
Below is an alphabetical list of the most common FileMaker Pro alert messages and suggestions for 
dealing with them. If you're unable to resolve your problem, call Customer Support.

Message Suggested Solution

Access to this layout is not currently 
available. Therefore this change will be 
made only to your temporary local copy.

You do not have access 
privileges to the layout. You can 
temporarily change the layout, 
but the changes will not be 
saved. To permanently change 
the layout you must obtain the 
password from your system 
administrator.

Communication with the host was 
interrupted and could not be re-
established.

Click the Exit button to quit 
FileMaker Pro 

Try restarting FileMaker Pro and 
reopening the file from the 
network 

"File name" cannot be opened because it
would exceed the host's capacity. Try 
again later.

The file is currently in use by the 
maximum number of guests

Another guest must close the file 
before you can open it

"File name" is currently in use and could 
not be opened. The file is single-user, or 
the host could not be found on the 
network.

Contact the host to open the file 
as multi-user

FileMaker cannot host or be a guest of a 
file because FMPNTALK.EXE was not 
executed before starting Windows (-
9111)

You aren't running the PhoneNET
Talk PC software or the FileMaker
Pro terminate-and-stay resident 
program FMPNTALK.EXE

See the PhoneNET 
documentation and the FileMaker
Pro Installation Guide for more 
information

FileMaker cannot host or be a guest of a 
file because Netware for Windows is not 
installed (-9118)

You aren't running the Netware 
driver or the Netware server isn't 
available on the network

See the FileMaker Pro Installation
Guide for more information

Network synchronization error. Click the Exit button to quit 
FileMaker Pro 

Try restarting FileMaker Pro and 
reopening the file from the 
network

Some time field values could not be 
recognized as valid times. You can find 
these by searching for "?."

FileMaker Pro can't recognize the
format of the time values you've 
imported

Search for invalid date values 
that aren't in the standard format 
of hh:mm:ss by using the ? 
operator in a find request

Sorry, this file is badly damaged. Please 
use the Recover command.

Choose Recover from the File 
menu to create a reconstructed 
version of the file 

Sorry, FileMaker is unable to read the Your disk is full or the file is 



disk. Click Retry to try again, or click Quit
and copy this file to another disk. (Error n
at n)

damaged

If you are unable to open the file 
after clicking Retry, copy the file 
to another disk 

Sorry, FileMaker is unable to update the 
disk. Click Retry to try again, or click Quit
and copy this file to another disk. (Error n
at n)

FileMaker Pro can't save the file 
to your disk because of a disk 
error

Follow the instructions in the 
message to save the file to a 
different disk

Sorry, there is not enough memory to 
complete this operation.

Close all other files and    
applications and try again

Sorry, "file name" could not be imported. 
There may be a problem in the file.

Make sure the file is in a format 
that can be recognized by 
FileMaker Pro and try again

Sorry, FileMaker is unable to continue 
printing. (Error n)

Make sure the printer is 
connected to your computer and 
switched on

If you are printing through a 
network, make sure you are 
connected to the network and the
network is currently functioning

The field "field name" in the lookup file 
"file name" has been defined to have n 
more repetitions than the field "field 
name" in this file. As a result, some data 
may not be copied when a lookup is 
performed. Proceed anyway?

You are using a lookup file that 
has more repetitions than the 
matching field in the current 
database

Redefine the field in one of the 
files so the field in both files has 
the same number of repetitions

There may not be enough disk space to 
complete this operation. FileMaker will 
not be able to open the file if this 
operation fails. Proceed anyway?

Click Cancel, copy the file to a 
disk with free space, and try the 
operation again

Waiting for response from "guest" All 
other guests must wait until the problem 
is resolved or "guest" is disconnected.

One of the guests on the network 
has inadvertently lost connection 
with the file's host or is busy with 
another application

Ask the guest to make sure 
FileMaker Pro is active

You cannot replace the found set 
because your password does not allow 
you to edit records or the file is multi-
user.

You are importing records and 
you don't have access privileges 
for editing records

Contact the file's host or your 
network administrator

You are trying to replace a found 
set across the network but 
replacing found sets isn't allowed 
across the network because 
some of the records may be 
locked



Window Menu
Use the Window menu commands to arrange and activate file windows.

Tile 

Cascade 

Arrange Icons 

Windows 1 through 9    



Tile
Window Menu

Arranges up to 16 FileMaker Pro windows in a tile pattern. The upper left window becomes the active 
window.



Cascade
Window Menu

Arranges multiple FileMaker Pro windows so they overlap with the title bar of each window visible.



Arrange Icons
Window Menu

Arranges FileMaker Pro document icons in a row at the bottom of the FileMaker Pro window.



Windows 1 through 9
Window Menu

Lists up to nine of the currently open files. If more than nine files are open, choose More Windows 
from the Windows menu to a see a list of the remaining open files.

To activate a file, select its name from the list.




